summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2018-07-04 22:56:33 +0900
committerAkinori Hattori <hattya@gentoo.org>2018-07-04 22:56:33 +0900
commit56d9c51fe6a474950f04fe2597fc7d768c4c9d04 (patch)
tree356239e8f1dc67bda9e3e562d344db2a930beeea /www-servers/h2o/h2o-9999.ebuild
parentwww-servers/h2o: update init script (diff)
downloadgentoo-56d9c51fe6a474950f04fe2597fc7d768c4c9d04.tar.gz
gentoo-56d9c51fe6a474950f04fe2597fc7d768c4c9d04.tar.bz2
gentoo-56d9c51fe6a474950f04fe2597fc7d768c4c9d04.zip
www-servers/h2o: use system oniguruma
Closes: https://bugs.gentoo.org/655462 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'www-servers/h2o/h2o-9999.ebuild')
-rw-r--r--www-servers/h2o/h2o-9999.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/www-servers/h2o/h2o-9999.ebuild b/www-servers/h2o/h2o-9999.ebuild
index 0d21e4e8bee1..89f63062ca99 100644
--- a/www-servers/h2o/h2o-9999.ebuild
+++ b/www-servers/h2o/h2o-9999.ebuild
@@ -5,7 +5,7 @@ EAPI="6"
CMAKE_MAKEFILE_GENERATOR="emake"
USE_RUBY="ruby23 ruby24"
-inherit cmake-utils git-r3 ruby-single systemd user
+inherit cmake-utils git-r3 ruby-single systemd toolchain-funcs user
DESCRIPTION="H2O - the optimized HTTP/1, HTTP/2 server"
HOMEPAGE="https://h2o.examp1e.net/"
@@ -22,10 +22,14 @@ RDEPEND="dev-lang/perl
libressl? ( dev-libs/libressl:0= )"
DEPEND="${RDEPEND}
mruby? (
- sys-devel/bison
${RUBY_DEPS}
+ dev-libs/oniguruma
+ sys-devel/bison
+ virtual/pkgconfig
)"
+PATCHES=( "${FILESDIR}"/${PN}-2.3-mruby.patch )
+
pkg_setup() {
enewgroup ${PN}
enewuser ${PN} -1 -1 -1 ${PN}
@@ -48,6 +52,10 @@ src_prepare() {
sed -i \
-e "s: ruby: ${ruby}:" \
CMakeLists.txt
+
+ sed -i "s:pkg-config:$(tc-getPKG_CONFIG):g" deps/mruby/lib/mruby/gem.rb
+ tc-export CC
+ export LD="$(tc-getCC)"
}
src_configure() {