summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2018-07-04 21:59:44 +0900
committerAkinori Hattori <hattya@gentoo.org>2018-07-04 22:23:46 +0900
commitc68e501b8b299cdd5dbd42f6f26dcd32fbb911a3 (patch)
tree88421301991aa4b148fe9299757103edeea64f1b /www-servers/h2o/h2o-9999.ebuild
parentwww-servers/h2o: build with make (diff)
downloadgentoo-c68e501b8b299cdd5dbd42f6f26dcd32fbb911a3.tar.gz
gentoo-c68e501b8b299cdd5dbd42f6f26dcd32fbb911a3.tar.bz2
gentoo-c68e501b8b299cdd5dbd42f6f26dcd32fbb911a3.zip
www-servers/h2o: tidy
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'www-servers/h2o/h2o-9999.ebuild')
-rw-r--r--www-servers/h2o/h2o-9999.ebuild36
1 files changed, 19 insertions, 17 deletions
diff --git a/www-servers/h2o/h2o-9999.ebuild b/www-servers/h2o/h2o-9999.ebuild
index b0583fd88558..d6c5d65d8239 100644
--- a/www-servers/h2o/h2o-9999.ebuild
+++ b/www-servers/h2o/h2o-9999.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI="6"
CMAKE_MAKEFILE_GENERATOR="emake"
USE_RUBY="ruby23 ruby24"
inherit cmake-utils git-r3 ruby-single systemd user
-DESCRIPTION="An optimized HTTP server with support for HTTP/1.x and HTTP/2"
-HOMEPAGE="https://h2o.examp1e.net"
+DESCRIPTION="H2O - the optimized HTTP/1, HTTP/2 server"
+HOMEPAGE="https://h2o.examp1e.net/"
EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
LICENSE="MIT"
@@ -16,7 +16,8 @@ SLOT="0"
KEYWORDS=""
IUSE="libressl +mruby"
-RDEPEND="
+RDEPEND="dev-lang/perl
+ sys-libs/zlib
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )"
DEPEND="${RDEPEND}
@@ -26,14 +27,14 @@ DEPEND="${RDEPEND}
)"
pkg_setup() {
- enewgroup h2o
- enewuser h2o -1 -1 -1 h2o
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
}
src_configure() {
local mycmakeargs=(
- -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}"/etc/h2o
- -DWITH_MRUBY="$(usex mruby)"
+ -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}"/etc/${PN}
+ -DWITH_MRUBY=$(usex mruby)
-DWITHOUT_LIBS=ON
)
cmake-utils_src_configure
@@ -42,17 +43,18 @@ src_configure() {
src_install() {
cmake-utils_src_install
- newinitd "${FILESDIR}"/h2o.initd h2o
- systemd_dounit "${FILESDIR}"/h2o.service
-
- insinto /etc/h2o
- doins "${FILESDIR}"/h2o.conf
+ keepdir /var/www/localhost/htdocs
- keepdir /var/log/h2o
- fperms 0700 /var/log/h2o
+ insinto /etc/${PN}
+ doins "${FILESDIR}"/${PN}.conf
- keepdir /var/www/localhost/htdocs
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ systemd_dounit "${FILESDIR}"/${PN}.service
insinto /etc/logrotate.d
- newins "${FILESDIR}"/h2o.logrotate h2o
+ newins "${FILESDIR}"/${PN}.logrotate ${PN}
+
+ keepdir /var/log/${PN}
+ fowners ${PN}:${PN} /var/log/${PN}
+ fperms 0750 /var/log/${PN}
}