summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-servers/hiawatha/hiawatha-9.8.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-servers/hiawatha/hiawatha-9.8.ebuild')
-rw-r--r--www-servers/hiawatha/hiawatha-9.8.ebuild90
1 files changed, 90 insertions, 0 deletions
diff --git a/www-servers/hiawatha/hiawatha-9.8.ebuild b/www-servers/hiawatha/hiawatha-9.8.ebuild
new file mode 100644
index 000000000000..37ebe2492239
--- /dev/null
+++ b/www-servers/hiawatha/hiawatha-9.8.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# ssl USE flag currently broken, unconditionally enabled
+# rproxy USE flag broken too, unconditionally enabled
+
+EAPI=5
+
+CMAKE_MIN_VERSION="2.8.4"
+
+inherit cmake-utils systemd user
+
+DESCRIPTION="Advanced and secure webserver"
+HOMEPAGE="http://www.hiawatha-webserver.org"
+SRC_URI="http://www.hiawatha-webserver.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +cache ipv6 monitor +rewrite tomahawk +xslt"
+
+RDEPEND="
+ >=net-libs/polarssl-1.3[threads]
+ xslt? ( dev-libs/libxslt
+ dev-libs/libxml2 )"
+DEPEND="${RDEPEND}"
+PDEPEND="monitor? ( www-apps/hiawatha-monitor )"
+
+# set this in make.conf if you want to use a different user/group
+HIAWATHA_USER=${HIAWATHA_USER:-hiawatha}
+HIAWATHA_GROUP=${HIAWATHA_GROUP:-hiawatha}
+
+pkg_setup() {
+ enewgroup ${HIAWATHA_GROUP}
+ enewuser ${HIAWATHA_USER} -1 -1 /var/www/hiawatha ${HIAWATHA_GROUP}
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-9.5-cflags.patch
+
+ rm -r polarssl || die
+
+ grep '#ServerId =' config/hiawatha.conf.in 1>/dev/null || die
+ sed -i \
+ -e "s/#ServerId =.*$/ServerId = ${HIAWATHA_USER}/" \
+ config/hiawatha.conf.in || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCONFIG_DIR:STRING=/etc/hiawatha
+ $(cmake-utils_use_enable cache CACHE)
+ $(cmake-utils_use_enable debug DEBUG)
+ $(cmake-utils_use_enable ipv6 IPV6)
+ $(cmake-utils_use_enable kernel_linux LOADCHECK)
+ $(cmake-utils_use_enable monitor MONITOR)
+ -DENABLE_SSL=YES
+ $(cmake-utils_use_enable tomahawk TOMAHAWK)
+ $(cmake-utils_use_enable rewrite TOOLKIT)
+ $(cmake-utils_use_enable xslt XSLT)
+ -DLOG_DIR:STRING=/var/log/hiawatha
+ -DPID_DIR:STRING=/var/run
+ -DUSE_SHARED_POLARSSL_LIBRARY=ON
+ -DUSE_SYSTEM_POLARSSL=ON
+ -DWEBROOT_DIR:STRING=/var/www/hiawatha
+ -DWORK_DIR:STRING=/var/lib/hiawatha
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ rm -rf "${ED%%/}"/var/www/hiawatha/*
+
+ newinitd "${FILESDIR}"/hiawatha.initd hiawatha
+ systemd_dounit "${FILESDIR}"/hiawatha.service
+
+ local i
+ for i in /var/{lib,log}/hiawatha ; do
+ keepdir ${i}
+ fowners ${HIAWATHA_USER}:${HIAWATHA_GROUP} ${i}
+ fperms 0750 ${i}
+ done
+
+ keepdir /var/www/hiawatha
+ fowners ${HIAWATHA_USER}:${HIAWATHA_GROUP} /var/www/hiawatha
+}