summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-12-13 16:37:16 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-12-13 16:39:29 +0100
commit4a33b110e36087f1a5e43e47dd846f7bf26b4414 (patch)
tree400dcf191b145bbb0e3f2128856d2fbe3e1844a2 /www-servers/nginx
parentmedia-video/gpac: amd64 stable wrt bug #669966 (diff)
downloadgentoo-4a33b110e36087f1a5e43e47dd846f7bf26b4414.tar.gz
gentoo-4a33b110e36087f1a5e43e47dd846f7bf26b4414.tar.bz2
gentoo-4a33b110e36087f1a5e43e47dd846f7bf26b4414.zip
www-servers/nginx: http_auth_pam: adjust loglevel for auth failures
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'www-servers/nginx')
-rw-r--r--www-servers/nginx/files/http_auth_pam-1.5.1-adjust-loglevel-for-authentication-failures.patch22
-rw-r--r--www-servers/nginx/nginx-1.14.2-r1.ebuild (renamed from www-servers/nginx/nginx-1.14.2.ebuild)6
-rw-r--r--www-servers/nginx/nginx-1.15.7-r1.ebuild (renamed from www-servers/nginx/nginx-1.15.7.ebuild)6
3 files changed, 34 insertions, 0 deletions
diff --git a/www-servers/nginx/files/http_auth_pam-1.5.1-adjust-loglevel-for-authentication-failures.patch b/www-servers/nginx/files/http_auth_pam-1.5.1-adjust-loglevel-for-authentication-failures.patch
new file mode 100644
index 000000000000..632dcdee50e2
--- /dev/null
+++ b/www-servers/nginx/files/http_auth_pam-1.5.1-adjust-loglevel-for-authentication-failures.patch
@@ -0,0 +1,22 @@
+https://github.com/sto/ngx_http_auth_pam_module/pull/18
+
+--- a/ngx_http_auth_pam_module.c
++++ b/ngx_http_auth_pam_module.c
+@@ -348,7 +348,7 @@ ngx_http_auth_pam_authenticate(ngx_http_request_t *r,
+ /* try to authenticate user, log error on failure */
+ if ((rc = pam_authenticate(pamh,
+ PAM_DISALLOW_NULL_AUTHTOK)) != PAM_SUCCESS) {
+- ngx_log_debug2(NGX_LOG_DEBUG_HTTP, r->connection->log, 0,
++ ngx_log_error(NGX_LOG_ERR, r->connection->log, 0,
+ "PAM: user '%s' - not authenticated: %s",
+ ainfo.username.data, pam_strerror(pamh, rc));
+ pam_end(pamh, PAM_SUCCESS);
+@@ -357,7 +357,7 @@ ngx_http_auth_pam_authenticate(ngx_http_request_t *r,
+
+ /* check that the account is healthy */
+ if ((rc = pam_acct_mgmt(pamh, PAM_DISALLOW_NULL_AUTHTOK)) != PAM_SUCCESS) {
+- ngx_log_debug2(NGX_LOG_DEBUG_HTTP, r->connection->log, 0,
++ ngx_log_error(NGX_LOG_ERR, r->connection->log, 0,
+ "PAM: user '%s' - invalid account: %s",
+ ainfo.username.data, pam_strerror(pamh, rc));
+ pam_end(pamh, PAM_SUCCESS);
diff --git a/www-servers/nginx/nginx-1.14.2.ebuild b/www-servers/nginx/nginx-1.14.2-r1.ebuild
index 66b09925f1e0..08100e455787 100644
--- a/www-servers/nginx/nginx-1.14.2.ebuild
+++ b/www-servers/nginx/nginx-1.14.2-r1.ebuild
@@ -381,6 +381,12 @@ src_prepare() {
eapply "${FILESDIR}/${PN}-1.4.1-fix-perl-install-path.patch"
eapply "${FILESDIR}/${PN}-httpoxy-mitigation-r1.patch"
+ if use nginx_modules_http_auth_pam; then
+ cd "${HTTP_AUTH_PAM_MODULE_WD}" || die
+ eapply "${FILESDIR}"/http_auth_pam-1.5.1-adjust-loglevel-for-authentication-failures.patch
+ cd "${S}" || die
+ fi
+
if use nginx_modules_http_brotli; then
cd "${HTTP_BROTLI_MODULE_WD}" || die
eapply "${FILESDIR}"/http_brotli-detect-brotli-r2.patch
diff --git a/www-servers/nginx/nginx-1.15.7.ebuild b/www-servers/nginx/nginx-1.15.7-r1.ebuild
index e873f4b54163..6fbcd2eaad4b 100644
--- a/www-servers/nginx/nginx-1.15.7.ebuild
+++ b/www-servers/nginx/nginx-1.15.7-r1.ebuild
@@ -381,6 +381,12 @@ src_prepare() {
eapply "${FILESDIR}/${PN}-1.4.1-fix-perl-install-path.patch"
eapply "${FILESDIR}/${PN}-httpoxy-mitigation-r1.patch"
+ if use nginx_modules_http_auth_pam; then
+ cd "${HTTP_AUTH_PAM_MODULE_WD}" || die
+ eapply "${FILESDIR}"/http_auth_pam-1.5.1-adjust-loglevel-for-authentication-failures.patch
+ cd "${S}" || die
+ fi
+
if use nginx_modules_http_brotli; then
cd "${HTTP_BROTLI_MODULE_WD}" || die
eapply "${FILESDIR}"/http_brotli-detect-brotli-r2.patch