summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-10-02 09:52:25 +0200
committerMichał Górny <mgorny@gentoo.org>2015-10-02 10:43:18 +0200
commit0fa2428af279ab042b6e562729d8098ff9786fcc (patch)
treefd027df865dda9c8b5b949b9929af7fb0eeabc83 /www-servers/pshs
parentnet-misc/autoupnp: Version bump with miniupnpc compat fix (diff)
downloadgentoo-0fa2428af279ab042b6e562729d8098ff9786fcc.tar.gz
gentoo-0fa2428af279ab042b6e562729d8098ff9786fcc.tar.bz2
gentoo-0fa2428af279ab042b6e562729d8098ff9786fcc.zip
www-servers/pshs: Version bump with miniupnpc compat & UPnP fix
Package-Manager: portage-2.2.22
Diffstat (limited to 'www-servers/pshs')
-rw-r--r--www-servers/pshs/Manifest1
-rw-r--r--www-servers/pshs/pshs-0.3.ebuild37
-rw-r--r--www-servers/pshs/pshs-9999.ebuild13
3 files changed, 44 insertions, 7 deletions
diff --git a/www-servers/pshs/Manifest b/www-servers/pshs/Manifest
index ecfcecdf7166..83f18e6098ac 100644
--- a/www-servers/pshs/Manifest
+++ b/www-servers/pshs/Manifest
@@ -1 +1,2 @@
DIST pshs-0.2.6.tar.bz2 82150 SHA256 8f3cf95e82de21ae6ffee1b50a1517ef5a63475a70bc2f01af124b6ea52e1459 SHA512 d61addeb3ff1b347d333f0a625ff11c99ae8d2b6d47f980e2983847b85cdc0ac827bdc5a6f9044030016df4104b00a63eebc491b01e630f4f242154d064ec1d6 WHIRLPOOL b11a7c2533895c9a9006562fb87018462498346c7ddb748804ca84891a2bdc643de27e30ff041169d5782b52199375675933222f3aa01cb2e92f5c0e555382c4
+DIST pshs-0.3.tar.bz2 81622 SHA256 c3c4d2abc7f3ee9ef80eff2dd4811d542ab5b4b229e3a0615c50ae2a530d7e63 SHA512 17dd21603ea36ecbe69923a2c476f6f41fea026b654a9d4819132047bad67f60a797cd0008afc85ab27ed3538681cfe8d79f9f33fc60823fd425337138723d45 WHIRLPOOL 515e551f41aee68729594f00bad4a9b48974103897d3e9a31e9ac77fe5dec62284cedac78759513b198d3638c3529842e517a903ee09b1aabb265dce6eeb92d2
diff --git a/www-servers/pshs/pshs-0.3.ebuild b/www-servers/pshs/pshs-0.3.ebuild
new file mode 100644
index 000000000000..d195a4c03573
--- /dev/null
+++ b/www-servers/pshs/pshs-0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Pretty small HTTP server -- a command-line tool to share files"
+HOMEPAGE="https://bitbucket.org/mgorny/pshs/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+magic +netlink qrcode ssl upnp"
+
+RDEPEND=">=dev-libs/libevent-2:0=
+ magic? ( sys-apps/file:0= )
+ qrcode? ( media-gfx/qrencode:0= )
+ ssl? ( >=dev-libs/libevent-2.1:0=[ssl]
+ dev-libs/openssl:0= )
+ upnp? ( net-libs/miniupnpc:0= )"
+DEPEND="${RDEPEND}
+ netlink? ( sys-apps/iproute2
+ >=sys-kernel/linux-headers-2.6.27 )"
+# libnetlink is static only ATM
+
+src_configure() {
+ local myconf=(
+ $(use_enable magic libmagic)
+ $(use_enable netlink)
+ $(use_enable qrcode qrencode)
+ $(use_enable ssl)
+ $(use_enable upnp)
+ )
+
+ econf "${myconf[@]}"
+}
diff --git a/www-servers/pshs/pshs-9999.ebuild b/www-servers/pshs/pshs-9999.ebuild
index 892184e3cdbc..6d71ea0c59aa 100644
--- a/www-servers/pshs/pshs-9999.ebuild
+++ b/www-servers/pshs/pshs-9999.ebuild
@@ -5,15 +5,12 @@
EAPI=5
#if LIVE
-AUTOTOOLS_AUTORECONF=yes
EGIT_REPO_URI="https://bitbucket.org/mgorny/${PN}.git"
-inherit git-r3
+inherit autotools git-r3
#endif
-inherit autotools-utils
-
-DESCRIPTION="Pretty small HTTP server - a command-line tool to share files"
+DESCRIPTION="Pretty small HTTP server -- a command-line tool to share files"
HOMEPAGE="https://bitbucket.org/mgorny/pshs/"
SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
@@ -36,10 +33,12 @@ DEPEND="${RDEPEND}
#if LIVE
KEYWORDS=
SRC_URI=
+
+src_prepare() { eautoreconf; }
#endif
src_configure() {
- myeconfargs=(
+ local myconf=(
$(use_enable magic libmagic)
$(use_enable netlink)
$(use_enable qrcode qrencode)
@@ -47,5 +46,5 @@ src_configure() {
$(use_enable upnp)
)
- autotools-utils_src_configure
+ econf "${myconf[@]}"
}