summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-04-13 18:42:20 +0200
committerSebastian Pipping <sping@gentoo.org>2020-04-13 18:48:11 +0200
commit88a02a545c00375a71f87b991ae78c5c2ad38e07 (patch)
tree85fbccb6e0b15953a2596e21c24c597d61d595b7 /www-servers/tornado
parentapp-office/abiword: Remove old (diff)
downloadgentoo-88a02a545c00375a71f87b991ae78c5c2ad38e07.tar.gz
gentoo-88a02a545c00375a71f87b991ae78c5c2ad38e07.tar.bz2
gentoo-88a02a545c00375a71f87b991ae78c5c2ad38e07.zip
www-servers/tornado: 6.0.4 + QA
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.98, Repoman-2.3.22
Diffstat (limited to 'www-servers/tornado')
-rw-r--r--www-servers/tornado/Manifest1
-rw-r--r--www-servers/tornado/tornado-6.0.4.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/www-servers/tornado/Manifest b/www-servers/tornado/Manifest
index 07d6f004dd1c..61034a8fe14a 100644
--- a/www-servers/tornado/Manifest
+++ b/www-servers/tornado/Manifest
@@ -1,3 +1,4 @@
DIST tornado-4.5.3.tar.gz 484221 BLAKE2B 7b3682fa85a7f6ad32351d40993516a3e397b7b0a5de9d807bcd8b2b21325a6170f3670cb13e12aa208b6590313cf165ddf40537dba1fee61fa9d71954265a66 SHA512 c17dd7a3b541c26950d27c8a399ae4fdff1d99d16ff0c5de9871fe2de4c0f797c96712b23b5ed5efdaee06bb251f7def114c83fe6f7f37f344cdac9996d14448
DIST tornado-5.1.tar.gz 516359 BLAKE2B 1ff6e6ced124b7b0df0e476eac555de20e4ac86f01369ee484e33bf5d749c269a81dd11a0b4c8b3169db6fd9f7a1b4e3c3551d46474c53a1fed8e342660c57f9 SHA512 8f45e5bbee5453a4225f05840a9fa80dd574c5a9cac9ec4d787f11c3f86f347c66d39c984a8bbe96dbb41f599e25102f1a3dad1c55b479bebee7d856aaca764a
DIST tornado-6.0.3.tar.gz 482444 BLAKE2B 1dda4baae52034d779879fef507d5764894f4aa054e60b00a2f8a989df4b31b495cbed6397d602e7c19844ea1538988558d5741da91646b64b6dbb8e78d618ed SHA512 2db182da7327fdd32fe76a50726a1285332139972766368c3b3dac5b4d54b4bd452a76062c09d1d158a97ace78b7915d93a29a7a8138499a2e56aee9df461abc
+DIST tornado-6.0.4.tar.gz 496204 BLAKE2B 6c092214d03baf5cf7615b780043e2fa40a4ed623b7ca59a2528cc3625ba904b21ef93c528278adedaf83e3b6e5a6311d867833dfe9826637e97918dee6fa334 SHA512 d29d69cf40f8b34fb2c55d81b6ecd9bc7c6fdf644eb4ff35452829510c0d5ec185da0a6067fec3e8afb2bedf9f5f08b06adb0ad53dcab04cb791a75abc304d6e
diff --git a/www-servers/tornado/tornado-6.0.4.ebuild b/www-servers/tornado/tornado-6.0.4.ebuild
new file mode 100644
index 000000000000..766d414ad37e
--- /dev/null
+++ b/www-servers/tornado/tornado-6.0.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python web framework and asynchronous networking library"
+HOMEPAGE="https://www.tornadoweb.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="
+ >=dev-python/pycurl-7.19.3.1[${PYTHON_USEDEP}]
+ >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ ${CDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme \
+ dev-python/sphinxcontrib-asyncio
+
+python_test() {
+ local -x ASYNC_TEST_TIMEOUT=60
+ "${PYTHON}" -m tornado.test.runtests --verbose ||
+ die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r demos/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}