summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-25 08:12:35 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-25 10:39:50 +0100
commit8c8a1fb0e763212b4ee24e9d5fd25fb048366aed (patch)
treea345c2a50d8b1f87fe22975a8e78e2d97b42934c /www-servers/tornado
parentprofiles/base: Mask app-backup/bup[web] (diff)
downloadgentoo-8c8a1fb0e763212b4ee24e9d5fd25fb048366aed.tar.gz
gentoo-8c8a1fb0e763212b4ee24e9d5fd25fb048366aed.tar.bz2
gentoo-8c8a1fb0e763212b4ee24e9d5fd25fb048366aed.zip
www-servers/tornado: Remove py2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'www-servers/tornado')
-rw-r--r--www-servers/tornado/tornado-4.5.3.ebuild15
-rw-r--r--www-servers/tornado/tornado-5.1-r1.ebuild8
2 files changed, 3 insertions, 20 deletions
diff --git a/www-servers/tornado/tornado-4.5.3.ebuild b/www-servers/tornado/tornado-4.5.3.ebuild
index 9de109a2f008..2f8adca7e838 100644
--- a/www-servers/tornado/tornado-4.5.3.ebuild
+++ b/www-servers/tornado/tornado-4.5.3.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_6 )
+PYTHON_COMPAT=( python3_6 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -21,18 +21,7 @@ RESTRICT="!test? ( test )"
CDEPEND="
dev-python/certifi[${PYTHON_USEDEP}]
>=dev-python/pycurl-7.19.3.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7')
- || (
- >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
- ( $(python_gen_cond_dep 'dev-python/twisted-names[${PYTHON_USEDEP}]' 'python2_7')
- $(python_gen_cond_dep 'dev-python/twisted-web[${PYTHON_USEDEP}]' 'python2_7')
- )
- )
- $(python_gen_cond_dep '
- dev-python/backports-abc[${PYTHON_USEDEP}]
- dev-python/futures[${PYTHON_USEDEP}]
- dev-python/singledispatch[${PYTHON_USEDEP}]
- ' -2)
+ >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
diff --git a/www-servers/tornado/tornado-5.1-r1.ebuild b/www-servers/tornado/tornado-5.1-r1.ebuild
index d2edc90b3331..9fe88cdfb051 100644
--- a/www-servers/tornado/tornado-5.1-r1.ebuild
+++ b/www-servers/tornado/tornado-5.1-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -19,14 +19,8 @@ IUSE="examples test"
RESTRICT="!test? ( test )"
CDEPEND="
- $(python_gen_cond_dep 'dev-python/futures[${PYTHON_USEDEP}]' 'python2_7')
>=dev-python/pycurl-7.19.3.1[${PYTHON_USEDEP}]
>=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/backports-abc[${PYTHON_USEDEP}]
- dev-python/futures[${PYTHON_USEDEP}]
- dev-python/singledispatch[${PYTHON_USEDEP}]
- ' -2)
"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]