summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-03-18 18:53:28 +1100
committerMichael Palimaka <kensington@gentoo.org>2017-03-18 18:53:34 +1100
commit0cc34faf9c5e8519d3e63cb6ffc4d2dc0d2c90cd (patch)
tree035e4ed1b64a24122dd32bdce80a452aa0d22ff4 /www-servers
parentnet-libs/liboauth: remove 1.0.1 (diff)
downloadgentoo-0cc34faf9c5e8519d3e63cb6ffc4d2dc0d2c90cd.tar.gz
gentoo-0cc34faf9c5e8519d3e63cb6ffc4d2dc0d2c90cd.tar.bz2
gentoo-0cc34faf9c5e8519d3e63cb6ffc4d2dc0d2c90cd.zip
www-servers/bozohttpd: version bump 20170201
Gentoo-bug: 592832 Gentoo-bug: 611398 Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/bozohttpd/Manifest1
-rw-r--r--www-servers/bozohttpd/bozohttpd-20170201.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/www-servers/bozohttpd/Manifest b/www-servers/bozohttpd/Manifest
index 2ced85fe9062..cddf8803f6ea 100644
--- a/www-servers/bozohttpd/Manifest
+++ b/www-servers/bozohttpd/Manifest
@@ -1 +1,2 @@
DIST bozohttpd-20140708.tar.bz2 58024 SHA256 3919e4beec82dd67f19a99e222a05358ef4d06433dbf2df48b5895499af28fc7 SHA512 ebdb27f33cd9e8c893edcb8d62f8d78d2127a3fadde0f75432b9c95fac56a0b743c1b917405b2090c15f4729e9be4ee725f73f14978b62071d2ac7261629607f WHIRLPOOL d3a59f1c39b8668fc3695f4dea649c18f11dba36115e6ba6de0a40800140bd790ce32d53354e72f829a37a3dcd5ad3bef6833144d4637d07dcfde34b6610ce32
+DIST bozohttpd-20170201.tar.bz2 55730 SHA256 bfec085149f1d84358554216a1eeb0ec246e8138443118060be4de416d2a95c5 SHA512 f8fba17a454b3825bf0562072bf0acf5890639d83e3bc5c6b7e87f13860d37a3dfc3fd155bd9873d5201b85f31185b24677c22db1cb303fd556f22afa8b7895e WHIRLPOOL 14c7bbe8c7e0955d68c386b91cb009b8cd81a8c89e70f7ab74445d4a9d321ec0347c28233e7688650ba438ef45f66b105434d6e6c74898db60aaa8f1ef20f3b8
diff --git a/www-servers/bozohttpd/bozohttpd-20170201.ebuild b/www-servers/bozohttpd/bozohttpd-20170201.ebuild
new file mode 100644
index 000000000000..1044a7a84412
--- /dev/null
+++ b/www-servers/bozohttpd/bozohttpd-20170201.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+DESCRIPTION="bozohttpd is a small and secure http server"
+HOMEPAGE="http://www.eterna.com.au/bozohttpd/"
+SRC_URI="http://www.eterna.com.au/bozohttpd/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="libressl"
+
+DEPEND="!libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )"
+RDEPEND="${DEPEND}
+ virtual/logger"
+
+src_prepare() {
+ default
+ mv Makefile{.boot,} || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" OPT="${CFLAGS}"
+}
+
+src_install() {
+ dobin bozohttpd
+ doman bozohttpd.8
+
+ newconfd "${FILESDIR}"/${PN}.conffile bozohttpd
+ newinitd "${FILESDIR}"/${PN}.initscript bozohttpd
+}