summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerb Miller Jr <herb@hlmjr.com>2021-05-20 17:05:19 -0400
committerJoonas Niilola <juippis@gentoo.org>2021-07-03 18:42:19 +0300
commit386e519bafff8c44a4b04a0f658b6bf382b0c095 (patch)
treeb5568d0fcab3bfae67f3d53c884cc8695362c410 /www-servers
parentwww-servers/lighttpd: Version bump (v1.4.59) (diff)
downloadgentoo-386e519bafff8c44a4b04a0f658b6bf382b0c095.tar.gz
gentoo-386e519bafff8c44a4b04a0f658b6bf382b0c095.tar.bz2
gentoo-386e519bafff8c44a4b04a0f658b6bf382b0c095.zip
www-servers/lighttpd: Fix nspr header location
Bug: https://bugs.gentoo.org/783936 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Herb Miller Jr. <herb@hlmjr.com> Closes: https://github.com/gentoo/gentoo/pull/20900 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/lighttpd/files/lighttpd-1.4.59-nspr-header.patch16
-rw-r--r--www-servers/lighttpd/lighttpd-1.4.59.ebuild2
2 files changed, 18 insertions, 0 deletions
diff --git a/www-servers/lighttpd/files/lighttpd-1.4.59-nspr-header.patch b/www-servers/lighttpd/files/lighttpd-1.4.59-nspr-header.patch
new file mode 100644
index 000000000000..497ea36a1675
--- /dev/null
+++ b/www-servers/lighttpd/files/lighttpd-1.4.59-nspr-header.patch
@@ -0,0 +1,16 @@
+diff --git a/configure.ac b/configure.ac
+index 325a1b4b..3f32daa9 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -887,7 +887,10 @@ if test "x$use_nss" = "xyes"; then
+ NSS_LIBS="-L$WITH_NSS/lib -lnss3"
+ else
+ PKG_CHECK_MODULES([NSS],[nss])
+- CPPFLAGS="$CPPFLAGS -I/usr/include/nspr4"
++ if test "x$CRYPTO_LIB" = "x"; then
++ PKG_CHECK_MODULES([NSPR],[nspr])
++ CPPFLAGS="$CPPFLAGS $NSPR_CFLAGS"
++ fi
+ fi
+ AC_DEFINE([HAVE_NSS_NSS_H], [1], [nss/nss.h])
+ AC_DEFINE([HAVE_NSS3_NSS_H], [1], [nss3/nss.h])
diff --git a/www-servers/lighttpd/lighttpd-1.4.59.ebuild b/www-servers/lighttpd/lighttpd-1.4.59.ebuild
index b3d8e44ff791..86b8878e8422 100644
--- a/www-servers/lighttpd/lighttpd-1.4.59.ebuild
+++ b/www-servers/lighttpd/lighttpd-1.4.59.ebuild
@@ -71,6 +71,8 @@ RDEPEND="${COMMON_DEPEND}
selinux? ( sec-policy/selinux-apache )
"
+PATCHES=( "${FILESDIR}"/${P}-nspr-header.patch )
+
# update certain parts of lighttpd.conf based on conditionals
update_config() {
local config="${D}/etc/lighttpd/lighttpd.conf"