summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2016-09-23 11:08:49 -0700
committerBrian Dolbec <dolsen@gentoo.org>2016-09-23 11:52:10 -0700
commit90c9aa5b38437b03b7066683110962c4a65c67bc (patch)
tree924cfe3eb7ca4e945fd6446b2c1805627ba31309 /www-servers
parentdev-util/buildbot-www: Version bump (diff)
downloadgentoo-90c9aa5b38437b03b7066683110962c4a65c67bc.tar.gz
gentoo-90c9aa5b38437b03b7066683110962c4a65c67bc.tar.bz2
gentoo-90c9aa5b38437b03b7066683110962c4a65c67bc.zip
www-servers/tornado: Version bump
Add new twisted single pkg dep (almost ready for the tree) Needed for newer salt version(s) Package-Manager: portage-2.3.1_p4
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/tornado/Manifest1
-rw-r--r--www-servers/tornado/files/4.4-drop-intersphinx.patch36
-rw-r--r--www-servers/tornado/files/4.4.1-options-test.patch13
-rw-r--r--www-servers/tornado/tornado-4.4.1.ebuild66
4 files changed, 116 insertions, 0 deletions
diff --git a/www-servers/tornado/Manifest b/www-servers/tornado/Manifest
index 6eabc15272b2..cfe138c6ddbe 100644
--- a/www-servers/tornado/Manifest
+++ b/www-servers/tornado/Manifest
@@ -1,2 +1,3 @@
DIST tornado-4.2.1.tar.gz 434304 SHA256 a16fcdc4f76b184cb82f4f9eaeeacef6113b524b26a2cb331222e4a7fa6f2969 SHA512 5bb391b05c8574c8ae5e315b7617e1259ab80e993f1230db611c5beef8058517cc588daf75fac2e0f7969668715470b06ed183c9832b22081be265beb6967e30 WHIRLPOOL 5230055b1d10c32968c1f400e3d1fffbde1cbf9b4578ec42835cb202234d24daf6d4e621622a2fc884d3db8e5b3f64d6e62d17841bb9d71ab8ab91928cd0dfe3
DIST tornado-4.3.tar.gz 450916 SHA256 c9c2d32593d16eedf2cec1b6a41893626a2649b40b21ca9c4cac4243bde2efbf SHA512 4220ae67eb8bfbe112edead47f37308eca9a272df24f073a7e5d1a0d0e90fb9f8c74b48db0d78fd995463591924800ab5268d32bcacc497ba204f164bce438bc WHIRLPOOL 13dec91628a7941623d0e8d381aa893ec6e4f1a480171bb29263c85cb11449d650488f459705c0b5d7b2d37044628caec6f14fa13762e67fce2688da6706fc78
+DIST tornado-4.4.1.tar.gz 456992 SHA256 371d0cf3d56c47accc66116a77ad558d76eebaa8458a6b677af71ca606522146 SHA512 46cd686d73348c20dfdb2a997b8368f3bb12f08d9f610c804090a4411b1d478ca11b5b34e1421873a3ab66eb6c2580b2cb3b092357cb60b72acf646fa8e0af43 WHIRLPOOL 1135555da16b8033eff24148458798be6d113682557d1c699c895429fb92377c36ea9f00677c0ce7bab3b7d56d5e4d33d4512186a481f23ad52d899c93b85195
diff --git a/www-servers/tornado/files/4.4-drop-intersphinx.patch b/www-servers/tornado/files/4.4-drop-intersphinx.patch
new file mode 100644
index 000000000000..cec403e772fb
--- /dev/null
+++ b/www-servers/tornado/files/4.4-drop-intersphinx.patch
@@ -0,0 +1,36 @@
+diff --git a/docs/Makefile b/docs/Makefile
+index 7001b80..ab2ffdd 100644
+--- a/docs/Makefile
++++ b/docs/Makefile
+@@ -3,7 +3,7 @@ all: sphinx
+
+ # No -W for doctests because that disallows tests with empty output.
+ SPHINX_DOCTEST_OPTS=-n -d build/doctress .
+-SPHINXOPTS=-n -W -d build/doctrees .
++SPHINXOPTS=-n -d build/doctrees .
+
+ .PHONY: sphinx
+ sphinx:
+diff --git a/docs/conf.py b/docs/conf.py
+index 368e4e8..85a276d 100644
+--- a/docs/conf.py
++++ b/docs/conf.py
+@@ -17,7 +17,6 @@ extensions = [
+ "sphinx.ext.coverage",
+ "sphinx.ext.doctest",
+ "sphinx.ext.extlinks",
+- "sphinx.ext.intersphinx",
+ "sphinx.ext.viewcode",
+ ]
+
+@@ -92,10 +91,6 @@
+ 'tornado-%s.tar.g' % version),
+ }
+
+-intersphinx_mapping = {
+- 'python': ('https://docs.python.org/3.5/', None),
+- }
+-
+ on_rtd = os.environ.get('READTHEDOCS', None) == 'True'
+
+ # On RTD we can't import sphinx_rtd_theme, but it will be applied by
diff --git a/www-servers/tornado/files/4.4.1-options-test.patch b/www-servers/tornado/files/4.4.1-options-test.patch
new file mode 100644
index 000000000000..480362647717
--- /dev/null
+++ b/www-servers/tornado/files/4.4.1-options-test.patch
@@ -0,0 +1,13 @@
+diff --git a/tornado/test/options_test.py b/tornado/test/options_test.py
+index f7b215c..c050cb6 100644
+--- a/tornado/test/options_test.py
++++ b/tornado/test/options_test.py
+@@ -36,7 +36,7 @@ class OptionsTest(unittest.TestCase):
+ options.define("port", default=80)
+ options.define("username", default='foo')
+ options.define("my_path")
+- config_path = os.path.join(os.path.dirname(__file__),
++ config_path = os.path.join(os.path.dirname(os.path.abspath(__file__)),
+ "options_test.cfg")
+ options.parse_config_file(config_path)
+ self.assertEqual(options.port, 443)
diff --git a/www-servers/tornado/tornado-4.4.1.ebuild b/www-servers/tornado/tornado-4.4.1.ebuild
new file mode 100644
index 000000000000..520d50c532d8
--- /dev/null
+++ b/www-servers/tornado/tornado-4.4.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python web framework and asynchronous networking library"
+HOMEPAGE="http://www.tornadoweb.org/ https://pypi.python.org/pypi/tornado"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+CDEPEND="
+ dev-python/certifi[${PYTHON_USEDEP}]
+ >=dev-python/pycurl-7.19.3.1[${PYTHON_USEDEP}]
+ dev-python/backports-ssl-match-hostname[${PYTHON_USEDEP}]
+ || (
+ ( $(python_gen_cond_dep 'dev-python/twisted-names[${PYTHON_USEDEP}]' 'python2_7')
+ $(python_gen_cond_dep 'dev-python/twisted-web[${PYTHON_USEDEP}]' 'python2_7')
+ )
+ >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+ )
+ virtual/python-backports_abc[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${CDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/4.4-drop-intersphinx.patch
+ "${FILESDIR}"/4.4.1-options-test.patch
+)
+
+python_compile_all() {
+ use doc && emake -C docs sphinx
+}
+
+python_test() {
+ "${PYTHON}" -m tornado.test.runtests || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ use examples && local EXAMPLES=( demos/. )
+
+ distutils-r1_python_install_all
+}