summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-12-21 08:26:02 +0100
committerHans de Graaff <graaff@gentoo.org>2022-12-21 08:34:54 +0100
commitb956bb91bdb2fc2bad69c71cc49f4bf164451e27 (patch)
treeecf23413429e96bdf614162a6944a39d39314b46 /www-servers
parentdev-ml/reason: keyword 3.8.2 for ~x86 (diff)
downloadgentoo-b956bb91bdb2fc2bad69c71cc49f4bf164451e27.tar.gz
gentoo-b956bb91bdb2fc2bad69c71cc49f4bf164451e27.tar.bz2
gentoo-b956bb91bdb2fc2bad69c71cc49f4bf164451e27.zip
www-servers/puma: add 6.0.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/puma/Manifest1
-rw-r--r--www-servers/puma/puma-6.0.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/www-servers/puma/Manifest b/www-servers/puma/Manifest
index 61018191bab6..acc90192fb78 100644
--- a/www-servers/puma/Manifest
+++ b/www-servers/puma/Manifest
@@ -1,3 +1,4 @@
DIST puma-5.6.4.tar.gz 310770 BLAKE2B 124190a0ca791352d055f833caec470be3be910ec4dbae5dc6860b79f5c678566f9bada3c6cf1066bc12f040ab891e9ea1a1da3188a9715db7643ef8d8f6b26f SHA512 6321a08e99be1023a1216466914416fbc91f5436ecccec4ea4cbfdc9c4ebc4979f93894ae12b72654269b0410d6a3053230806b860cb912c1abdf89766683a27
DIST puma-5.6.5.tar.gz 314953 BLAKE2B 2aca92ff3d32995be8f05b626c2299c07f8665f345a6830f3ec3a3a561dbeb41d68d65851cef9c33a56d1d508c9adf2ebb254ca5c1d4dd8fbc896d6d6d2b440a SHA512 0ad41f3372732bdea6594a20b116ec4fc03a8a1d2ff807b3c315e7769aef4e5361ff775975575125002fbfc83315e6906fa8691ce666161bd8beee8c469289d8
DIST puma-6.0.0.tar.gz 345407 BLAKE2B eb7b1c44e04249441dd9c3084cb4a7965216fe31d3d851026e0548f91dc5d20355e2635d54a062a9c32622ee0b21ba64669b2c905976e2cae83e8fdb7a153616 SHA512 2b5b31e315fc4b5f8f510e7e08941100835c9ab33007569da178eeca0c729ac45955146b85294792d89b7a13168fbb9173a2c55c38e1cd1e10fa243c30966be3
+DIST puma-6.0.1.tar.gz 348199 BLAKE2B 5f27b6e1e688d875b90420382afe75c6aced0010bc89b9a526c9cc47d14cefc1171e6fc19f13596d127294842a85f4456a5cd8c65d9382aa60c39b72a7d16a6c SHA512 e5025613a23c3677caf120486e1e8072be0ddc61752706cfbda26abd4fa3e0e3c1e80ce3999bc90a6e3d75482ca129a842a7a9765537d1dc88d14bf61556618b
diff --git a/www-servers/puma/puma-6.0.1.ebuild b/www-servers/puma/puma-6.0.1.ebuild
new file mode 100644
index 000000000000..edca73aeeea8
--- /dev/null
+++ b/www-servers/puma/puma-6.0.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_GEMSPEC="puma.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/puma_http11/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR=lib/puma
+
+inherit ruby-fakegem
+
+DESCRIPTION="a simple, fast, threaded, and highly concurrent HTTP 1.1 server for Ruby/Rack"
+HOMEPAGE="https://puma.io/"
+SRC_URI="https://github.com/puma/puma/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+DEPEND+=" dev-libs/openssl:0 test? ( net-misc/curl )"
+RDEPEND+=" dev-libs/openssl:0="
+
+ruby_add_bdepend "virtual/ruby-ssl
+ test? ( dev-ruby/localhost dev-ruby/rack >=dev-ruby/minitest-5.9:5 >=dev-ruby/test-unit-3.0:2 )"
+
+ruby_add_rdepend "dev-ruby/nio4r:2"
+
+all_ruby_prepare() {
+ sed -e '/bundler/ s:^:#:' \
+ -e '/prove/ s:^:#:' \
+ -e '/stub_const/ s:^:#:' \
+ -i test/helper.rb || die
+
+ # Avoid tests failing inconsistently
+ sed -i -e '/test_bad_client/askip "inconsistent results"' test/test_web_server.rb || die
+
+ # Avoid launcher tests since they make assumptions about bundler use
+ rm -f test/test_launcher.rb test/test_worker_gem_independence.rb test/test_bundle_pruner.rb || die
+
+ # Skip integration tests since they make a lot of assumptions about
+ # the environment
+ rm -f test/test_integration_* test/test_preserve_bundler_env.rb|| die
+
+ # Avoid test that uses unpackaged stub_const
+ sed -i -e '/test_shutdown_with_grace/,/^ end/ s:^:#:' test/test_thread_pool.rb || die
+
+ sed -e 's/git ls-files --/find/' \
+ -e 's:_relative ": "./:' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ einfo "Running test suite"
+ ${RUBY} -Ilib:.:test -e "gem 'minitest', '~>5.9'; gem 'test-unit', '~>3.0'; require 'minitest/autorun'; Dir['test/**/*test_*.rb'].each{|f| require f}" || die
+}