summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-03-31 08:15:15 +0200
committerHans de Graaff <graaff@gentoo.org>2022-03-31 08:15:15 +0200
commitd124ed2d374838aef21c00ba42fc97d28db8e6ca (patch)
tree2b0572fa3fe986c13a931a03f9796bf41c6be158 /www-servers
parentdev-ruby/localhost: enable ruby31 (diff)
downloadgentoo-d124ed2d374838aef21c00ba42fc97d28db8e6ca.tar.gz
gentoo-d124ed2d374838aef21c00ba42fc97d28db8e6ca.tar.bz2
gentoo-d124ed2d374838aef21c00ba42fc97d28db8e6ca.zip
www-servers/puma: add 5.6.4
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/puma/Manifest1
-rw-r--r--www-servers/puma/files/puma-5.6.4-logwriter-test.patch14
-rw-r--r--www-servers/puma/puma-5.6.4.ebuild61
3 files changed, 76 insertions, 0 deletions
diff --git a/www-servers/puma/Manifest b/www-servers/puma/Manifest
index 7f1978fba022..31e207e4d223 100644
--- a/www-servers/puma/Manifest
+++ b/www-servers/puma/Manifest
@@ -1,2 +1,3 @@
DIST puma-5.5.2.tar.gz 302778 BLAKE2B 5911accde19aaed34cffecc71eb2db02f0d9f9ea7b57437ff7cf7580b0b51245ed68b254778cbdc11bea624b9f192aef0bfa7e24acde73b77290d780ab177933 SHA512 9887b465c6ed2a8e551b15fd161f19a9d2baa96b8eb8e247f13c98df9d34f6097bce81a52e8f88d69088d9b5f8477137af9110b7546afabc53767f337ad00ef8
DIST puma-5.6.2.tar.gz 309057 BLAKE2B 21a8c02f5fdfd23863a525987b55fbdb5c6b42d550cd8bb4580a78faf0206db42ee9b98409ce7b881dfad43bf5d31d202e228e3a62f0327083f043e22de32b3a SHA512 e08ebb968cb139136d11cfb12f7ebef7f4cafcbf3f26cf229c063aa0e55769ba8c4bc1df1dd9e04a4969d6f423cae1a09ce87e154315c9df80d61ec56b6f96e7
+DIST puma-5.6.4.tar.gz 310770 BLAKE2B 124190a0ca791352d055f833caec470be3be910ec4dbae5dc6860b79f5c678566f9bada3c6cf1066bc12f040ab891e9ea1a1da3188a9715db7643ef8d8f6b26f SHA512 6321a08e99be1023a1216466914416fbc91f5436ecccec4ea4cbfdc9c4ebc4979f93894ae12b72654269b0410d6a3053230806b860cb912c1abdf89766683a27
diff --git a/www-servers/puma/files/puma-5.6.4-logwriter-test.patch b/www-servers/puma/files/puma-5.6.4-logwriter-test.patch
new file mode 100644
index 000000000000..75086f76f027
--- /dev/null
+++ b/www-servers/puma/files/puma-5.6.4-logwriter-test.patch
@@ -0,0 +1,14 @@
+--- a/test/test_request_invalid.rb.orig 2022-03-31 08:02:24.833118111 +0200
++++ b/test/test_request_invalid.rb 2022-03-31 08:02:41.897215442 +0200
+@@ -35,9 +35,8 @@
+ [200, {}, [body]]
+ }
+
+- @log_writer = Puma::LogWriter.strings
+- events = Puma::Events.new
+- @server = Puma::Server.new app, @log_writer, events
++ events = Puma::Events.new($stdout, $stderr)
++ @server = Puma::Server.new app, events
+ @port = (@server.add_tcp_listener @host, 0).addr[1]
+ @server.run
+ sleep 0.15 if Puma.jruby?
diff --git a/www-servers/puma/puma-5.6.4.ebuild b/www-servers/puma/puma-5.6.4.ebuild
new file mode 100644
index 000000000000..97be04bd98eb
--- /dev/null
+++ b/www-servers/puma/puma-5.6.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_GEMSPEC="puma.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/puma_http11/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR=lib/puma
+
+inherit ruby-fakegem
+
+DESCRIPTION="a simple, fast, threaded, and highly concurrent HTTP 1.1 server for Ruby/Rack"
+HOMEPAGE="https://puma.io/"
+SRC_URI="https://github.com/puma/puma/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+DEPEND+=" dev-libs/openssl:0 test? ( net-misc/curl )"
+RDEPEND+=" dev-libs/openssl:0="
+
+PATCHES=( "${FILESDIR}/${P}-logwriter-test.patch" )
+
+ruby_add_bdepend "virtual/ruby-ssl
+ test? ( dev-ruby/localhost dev-ruby/rack >=dev-ruby/minitest-5.9:5 >=dev-ruby/test-unit-3.0:2 )"
+
+ruby_add_rdepend "dev-ruby/nio4r:2"
+
+all_ruby_prepare() {
+ sed -e '/bundler/ s:^:#:' \
+ -e '/prove/ s:^:#:' \
+ -e '/stub_const/ s:^:#:' \
+ -i test/helper.rb || die
+
+ # Avoid tests failing inconsistently
+ sed -i -e '/test_bad_client/askip "inconsistent results"' test/test_web_server.rb || die
+
+ # Avoid launcher tests since they make assumptions about bundler use
+ rm -f test/test_launcher.rb test/test_worker_gem_independence.rb || die
+
+ # Skip integration tests since they make a lot of assumptions about
+ # the environment
+ rm -f test/test_integration_* test/test_preserve_bundler_env.rb|| die
+
+ # Avoid test that uses unpackaged stub_const
+ sed -i -e '/test_shutdown_with_grace/,/^ end/ s:^:#:' test/test_thread_pool.rb || die
+
+ sed -e 's/git ls-files --/find/' \
+ -e 's:_relative ": "./:' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ einfo "Running test suite"
+ ${RUBY} -Ilib:.:test -e "gem 'minitest', '~>5.9'; gem 'test-unit', '~>3.0'; require 'minitest/autorun'; Dir['test/**/*test_*.rb'].each{|f| require f}" || die
+}