summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2022-05-14 09:13:06 -0400
committerAnthony G. Basile <blueness@gentoo.org>2022-05-14 09:13:18 -0400
commitd680df5c3d204195d05634703351e26193a0843b (patch)
tree580461a5e6115f4dc3744dab10c14fe5d375a7de /www-servers
parentdev-python/httpretty: Enable py3.11 (diff)
downloadgentoo-d680df5c3d204195d05634703351e26193a0843b.tar.gz
gentoo-d680df5c3d204195d05634703351e26193a0843b.tar.bz2
gentoo-d680df5c3d204195d05634703351e26193a0843b.zip
www-servers/varnish: version bump to 7.1.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/varnish/Manifest1
-rw-r--r--www-servers/varnish/varnish-7.1.0.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/www-servers/varnish/Manifest b/www-servers/varnish/Manifest
index 7e193eed0bc4..1e73067f0df4 100644
--- a/www-servers/varnish/Manifest
+++ b/www-servers/varnish/Manifest
@@ -1,3 +1,4 @@
DIST varnish-6.5.2.tgz 3464372 BLAKE2B 68a7bca159ed9539126f66d21450c87780b49b66a2d45a5abc7db6fe9d68c8526aa059546fb1d865de753736793e700611f4f110edb1c649f4e9753c4dfedacc SHA512 31673eaa95e5d3413cd3a4a6fb324c1f0ad2efb22b75409fc0e02c61446787eb167bd530ee5b0a199da4fc76cc36f3603984d86781f856cc6a4aac48260fe4ef
DIST varnish-6.6.1.tgz 3518308 BLAKE2B 6a88165394c0578427de20588ac2c17f502242bf94f30e9284f7bc2c271b77c3d6511a9dfb8d1cb6d75e1fc4563360fb0bec762aa17481fa598cb5e9d9527705 SHA512 af3ee1743af2ede2d3efbb73e5aa9b42c7bbd5f86163ec338c8afd1989c3e51ff3e1b40bed6b72224b5d339a74f22d6e5f3c3faf2fedee8ab4715307ed5d871b
DIST varnish-7.0.1.tgz 3712763 BLAKE2B ec47b557d8623e349032ac48459ea0c636a4b2810b4354666a651b652b65389abedafd0b665ca1e8178ea2b8339be8fd782dc61e1245f9307e00d665a3c20500 SHA512 7541d50b03a113f0a13660d459cc4c2eb45d57fb19380ab56a5413a4e5d702f9c0856585f09aeea6084a239ad8c69017af3805a864540b4697e0eac29f00b408
+DIST varnish-7.1.0.tgz 3787588 BLAKE2B 1a019b140c467063861460b529c253361975826cee797c304c7c096645c315b67ad20400467ecf11711abae5354134ac29a934793691283e12e3fbe29921943b SHA512 ad9ce0cdc759976fcb7044914d28863edd197167f583fab2d1bc57f4e5b86c224b7c948faf1f7364a2a16bde9c415375d011462bdc43026c5f7a60e65bd21f73
diff --git a/www-servers/varnish/varnish-7.1.0.ebuild b/www-servers/varnish/varnish-7.1.0.ebuild
new file mode 100644
index 000000000000..9043508fdaf4
--- /dev/null
+++ b/www-servers/varnish/varnish-7.1.0.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit autotools systemd python-r1
+
+DESCRIPTION="Varnish is a state-of-the-art, high-performance HTTP accelerator"
+HOMEPAGE="https://varnish-cache.org/"
+SRC_URI="http://varnish-cache.org/_downloads/${P}.tgz"
+
+LICENSE="BSD-2 GPL-2"
+SLOT="0/2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="jemalloc jit static-libs"
+
+CDEPEND="
+ sys-libs/readline:0=
+ dev-libs/libpcre[jit?]
+ jemalloc? ( dev-libs/jemalloc )
+ sys-libs/ncurses:0="
+
+#varnish compiles stuff at run time
+RDEPEND="
+ ${PYTHON_DEPS}
+ ${CDEPEND}
+ acct-user/varnish
+ acct-group/varnish
+ sys-devel/gcc"
+
+DEPEND="
+ ${CDEPEND}
+ dev-python/docutils
+ dev-python/sphinx
+ virtual/pkgconfig"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="test" #315725
+
+src_prepare() {
+ # Remove -Werror bug #528354
+ sed -i -e 's/-Werror\([^=]\)/\1/g' configure.ac
+
+ # Upstream doesn't put varnish.m4 in the m4/ directory
+ # We link because the Makefiles look for the file in
+ # the original location
+ ln -sf ../varnish.m4 m4/varnish.m4
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ $(use_enable jit pcre2-jit)
+ $(use_with jemalloc)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ python_replicate_script "${D}/usr/share/varnish/vmodtool.py"
+
+ newinitd "${FILESDIR}"/varnishlog.initd varnishlog
+ newconfd "${FILESDIR}"/varnishlog.confd varnishlog
+
+ newinitd "${FILESDIR}"/varnishncsa.initd varnishncsa
+ newconfd "${FILESDIR}"/varnishncsa.confd varnishncsa
+
+ newinitd "${FILESDIR}"/varnishd.initd-r4 varnishd
+ newconfd "${FILESDIR}"/varnishd.confd-r4 varnishd
+
+ insinto /etc/logrotate.d/
+ newins "${FILESDIR}/varnishd.logrotate-r2" varnishd
+
+ diropts -m750
+
+ keepdir /var/lib/varnish
+ keepdir /var/log/varnish
+
+ systemd_dounit "${FILESDIR}/${PN}d.service"
+
+ insinto /etc/varnish/
+ doins vmod/vmod_*.vcc
+ doins etc/example.vcl
+
+ dodoc README.rst
+ dodoc doc/changes.rst
+
+ fowners root:varnish /etc/varnish/
+ fowners varnish:varnish /var/lib/varnish/
+ fperms 0750 /var/lib/varnish/ /etc/varnish/
+}