summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-07-10 09:43:50 +0200
committerMichał Górny <mgorny@gentoo.org>2016-07-10 09:48:21 +0200
commite1b62949f93557280aa2260db47c126e83dd0b53 (patch)
tree1709f84b23d70a546e1d1d46cbb94e56315d4caf /www-servers
parentwww-servers/pshs: Bump the live ebuild to EAPI=6 (diff)
downloadgentoo-e1b62949f93557280aa2260db47c126e83dd0b53.tar.gz
gentoo-e1b62949f93557280aa2260db47c126e83dd0b53.tar.bz2
gentoo-e1b62949f93557280aa2260db47c126e83dd0b53.zip
www-servers/pshs: Bump to 0.3.1
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/pshs/Manifest1
-rw-r--r--www-servers/pshs/pshs-0.3.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/www-servers/pshs/Manifest b/www-servers/pshs/Manifest
index d04f9aa35d9d..6705107a1b08 100644
--- a/www-servers/pshs/Manifest
+++ b/www-servers/pshs/Manifest
@@ -1 +1,2 @@
+DIST pshs-0.3.1.tar.bz2 80022 SHA256 842a60bd0451c5ad86566d5d42a83eeccd9c5d91118d62f7483f6be4c483bfa8 SHA512 a82c2a3e6fa64e521d77fafc48d1d9a6799d62c16cef3f01b3c11ba17e4e98cedafd200abaa97a45563f6d78efcfc6dbef4c5fa84ba39e9857fdc9ea2b1dc2c2 WHIRLPOOL ac4dd540182687a7be1b711a7b5895fadc6cb650d6b5c540442e33569c5fd6ea7ddc921f8b5e1e7be3b9d0544183c31f58400970bfac7d4690986304fa9df2e4
DIST pshs-0.3.tar.bz2 81622 SHA256 c3c4d2abc7f3ee9ef80eff2dd4811d542ab5b4b229e3a0615c50ae2a530d7e63 SHA512 17dd21603ea36ecbe69923a2c476f6f41fea026b654a9d4819132047bad67f60a797cd0008afc85ab27ed3538681cfe8d79f9f33fc60823fd425337138723d45 WHIRLPOOL 515e551f41aee68729594f00bad4a9b48974103897d3e9a31e9ac77fe5dec62284cedac78759513b198d3638c3529842e517a903ee09b1aabb265dce6eeb92d2
diff --git a/www-servers/pshs/pshs-0.3.1.ebuild b/www-servers/pshs/pshs-0.3.1.ebuild
new file mode 100644
index 000000000000..e6275ada442e
--- /dev/null
+++ b/www-servers/pshs/pshs-0.3.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Pretty small HTTP server -- a command-line tool to share files"
+HOMEPAGE="https://github.com/mgorny/pshs/"
+SRC_URI="https://github.com/mgorny/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl +magic +netlink qrcode ssl upnp"
+
+RDEPEND=">=dev-libs/libevent-2:0=
+ magic? ( sys-apps/file:0= )
+ qrcode? ( media-gfx/qrencode:0= )
+ ssl? ( >=dev-libs/libevent-2.1:0=[ssl]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ upnp? ( net-libs/miniupnpc:0= )"
+DEPEND="${RDEPEND}
+ netlink? ( sys-apps/iproute2
+ >=sys-kernel/linux-headers-2.6.27 )"
+# libnetlink is static only ATM
+
+src_configure() {
+ local myconf=(
+ $(use_enable magic libmagic)
+ $(use_enable netlink)
+ $(use_enable qrcode qrencode)
+ $(use_enable ssl)
+ $(use_enable upnp)
+ )
+
+ econf "${myconf[@]}"
+}