summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-apps/xkbset
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-apps/xkbset')
-rw-r--r--x11-apps/xkbset/Manifest1
-rw-r--r--x11-apps/xkbset/files/xkbset-0.5-ldflags.patch11
-rw-r--r--x11-apps/xkbset/metadata.xml10
-rw-r--r--x11-apps/xkbset/xkbset-0.5-r1.ebuild41
4 files changed, 63 insertions, 0 deletions
diff --git a/x11-apps/xkbset/Manifest b/x11-apps/xkbset/Manifest
new file mode 100644
index 000000000000..9647eccd8e29
--- /dev/null
+++ b/x11-apps/xkbset/Manifest
@@ -0,0 +1 @@
+DIST xkbset-0.5.tar.gz 13933 SHA256 01c2579495b39e00d870f50225c441888dc88021e9ee3b693a842dd72554d172 SHA512 64de1a18076c0e0fd3e3189444b6033880028f53777566286caf935bfafcf062ccbd408d20926e2a4febb77d15b026349e0288f2aa93c815ddd9437b96589d8c WHIRLPOOL 225d5f0e35ed7efb7c6b122f87d607ba25dd5f3bf92e9daea1a580f7b488f7ad2141c57d755fbdda8c723de4d4c482846448ab341ebbec96bb0e118a713a946c
diff --git a/x11-apps/xkbset/files/xkbset-0.5-ldflags.patch b/x11-apps/xkbset/files/xkbset-0.5-ldflags.patch
new file mode 100644
index 000000000000..69dda8739d75
--- /dev/null
+++ b/x11-apps/xkbset/files/xkbset-0.5-ldflags.patch
@@ -0,0 +1,11 @@
+--- xkbset-0.5/Makefile
++++ xkbset-0.5/Makefile
+@@ -11,7 +11,7 @@
+ all: xkbset xkbset.1
+
+ xkbset: getargs.o print.o usage.o main.o misc.o
+- ${CC} ${CFLAGS} ${INC_PATH} ${LIB_PATH} getargs.o print.o usage.o main.o misc.o -o $@ ${LIBS}
++ ${CC} ${CFLAGS} ${LDFLAGS} ${INC_PATH} ${LIB_PATH} getargs.o print.o usage.o main.o misc.o -o $@ ${LIBS}
+
+ getargs.o: getargs.c xkbset.h
+ ${CC} ${CFLAGS} ${INC_PATH} ${LIB_PATH} -c getargs.c
diff --git a/x11-apps/xkbset/metadata.xml b/x11-apps/xkbset/metadata.xml
new file mode 100644
index 000000000000..03b143fb398e
--- /dev/null
+++ b/x11-apps/xkbset/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>jer@gentoo.org</email>
+</maintainer>
+<use>
+<flag name='tk'>Install the <pkg>dev-perl/perl-tk</pkg> based xkbset-gui utility</flag>
+</use>
+</pkgmetadata>
diff --git a/x11-apps/xkbset/xkbset-0.5-r1.ebuild b/x11-apps/xkbset/xkbset-0.5-r1.ebuild
new file mode 100644
index 000000000000..ad440cc4be38
--- /dev/null
+++ b/x11-apps/xkbset/xkbset-0.5-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Manage xkb features such as MouseKeys, AccessX, StickyKeys, BounceKeys and SlowKeys"
+HOMEPAGE="http://www.math.missouri.edu/~stephen/software/"
+SRC_URI="http://www.math.missouri.edu/~stephen/software/xkbset/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="tk"
+
+CDEPEND="
+ x11-libs/libX11
+"
+DEPEND="
+ ${CDEPEND}
+"
+RDEPEND="
+ ${CDEPEND}
+ tk? ( dev-perl/perl-tk )
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) INC_PATH= LIB_PATH=
+}
+
+src_install() {
+ dobin xkbset
+ use tk && dobin xkbset-gui
+ doman xkbset.1
+ dodoc README TODO
+}