summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2017-10-18 16:49:18 -0700
committerMatt Turner <mattst88@gentoo.org>2017-10-18 16:53:56 -0700
commit031cfd0fe8b099adf04c75360a4054f9edc6217b (patch)
treed6bdeeb2f10fab4a92ff4c82f9a50eb50d2273e2 /x11-apps
parentsys-apps/openrc: 0.33.1 version bump (diff)
downloadgentoo-031cfd0fe8b099adf04c75360a4054f9edc6217b.tar.gz
gentoo-031cfd0fe8b099adf04c75360a4054f9edc6217b.tar.bz2
gentoo-031cfd0fe8b099adf04c75360a4054f9edc6217b.zip
x11-apps/xinit: Rev bump for commit 2bb6b9e50bdb
Commit 2bb6b9e50bdb8efc9a4627e60a4e63d38e8d6255 ("x11-apps/xinit: use /lib/gentoo/functions.sh instead of deprecated /etc/init.d/functions.sh") modified a file installed by all versions of the package (which were all stable) without a rev bump. It also neglected to add a dependency on sys-apps/gentoo-functions. This commit revs the version (straight to stable) so users get the new startDM.sh script, and the next commit will remove all other xinit versions. Gentoo-Bug: https://bugs.gentoo.org/504140
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xinit/xinit-1.3.4-r2.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/x11-apps/xinit/xinit-1.3.4-r2.ebuild b/x11-apps/xinit/xinit-1.3.4-r2.ebuild
new file mode 100644
index 000000000000..d07cc9662f8d
--- /dev/null
+++ b/x11-apps/xinit/xinit-1.3.4-r2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit xorg-2
+
+DESCRIPTION="X Window System initializer"
+
+LICENSE="${LICENSE} GPL-2"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="+minimal systemd"
+
+RDEPEND="
+ !systemd? ( sys-apps/gentoo-functions )
+ !<x11-base/xorg-server-1.8.0
+ x11-apps/xauth
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}"
+PDEPEND="x11-apps/xrdb
+ !minimal? (
+ x11-apps/xclock
+ x11-apps/xsm
+ x11-terms/xterm
+ x11-wm/twm
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.3.3-gentoo-customizations.patch"
+)
+
+src_prepare() {
+ # this patch breaks startx on non-systemd systems, bug #526802
+ if use !systemd; then
+ PATCHES+=( "${FILESDIR}"/${PN}-1.3.4-startx-current-vt.patch )
+ fi
+ xorg-2_src_prepare
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ --with-xinitdir="${EPREFIX}"/etc/X11/xinit
+ )
+ xorg-2_src_configure
+}
+
+src_install() {
+ xorg-2_src_install
+
+ exeinto /etc/X11
+ doexe "${FILESDIR}"/chooser.sh "${FILESDIR}"/startDM.sh
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}"/Xsession
+ exeinto /etc/X11/xinit
+ newexe "${FILESDIR}"/xserverrc.1 xserverrc
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}"/00-xhost
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/Xsession.desktop
+}
+
+pkg_postinst() {
+ xorg-2_pkg_postinst
+ ewarn "If you use startx to start X instead of a login manager like gdm/kdm,"
+ ewarn "you can set the XSESSION variable to anything in /etc/X11/Sessions/ or"
+ ewarn "any executable. When you run startx, it will run this as the login session."
+ ewarn "You can set this in a file in /etc/env.d/ for the entire system,"
+ ewarn "or set it per-user in ~/.bash_profile (or similar for other shells)."
+ ewarn "Here's an example of setting it for the whole system:"
+ ewarn " echo XSESSION=\"Gnome\" > /etc/env.d/90xsession"
+ ewarn " env-update && source /etc/profile"
+}