summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-09-11 23:55:55 +0200
committerManuel Rüger <mrueg@gentoo.org>2015-09-11 23:57:03 +0200
commit0363eaa374845b5f7d4a6716dacdd8a89631f3de (patch)
treeb2b24a24a8a330661d77f286f170e5867bc40734 /x11-apps
parentsys-fs/zfs: ${EROOT} includes / (diff)
downloadgentoo-0363eaa374845b5f7d4a6716dacdd8a89631f3de.tar.gz
gentoo-0363eaa374845b5f7d4a6716dacdd8a89631f3de.tar.bz2
gentoo-0363eaa374845b5f7d4a6716dacdd8a89631f3de.zip
x11-apps/radeontop: Version bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/radeontop/Manifest1
-rw-r--r--x11-apps/radeontop/radeontop-0.9.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/x11-apps/radeontop/Manifest b/x11-apps/radeontop/Manifest
index 03d8e4d33259..810fef96606a 100644
--- a/x11-apps/radeontop/Manifest
+++ b/x11-apps/radeontop/Manifest
@@ -1,2 +1,3 @@
DIST radeontop-0.7.tar.gz 28353 SHA256 57542644d95a05e321223b2137836cc300935d8615110ed134c2d83e3ff0058d SHA512 92d98c0849ebfabaa0b7086461e41c736020e4a9af1e5e31dc0d2e098496a6eebb878fd4a5694035a9bb48f33267e31802063e413becf8f9c2924355fdf60b81 WHIRLPOOL 045c1ee5a6dcc1c2fbe6ec86fabad9723938298685e37fa0efc6967ab621ac9087832a10b636424e8d9f1c8fdb5d403a64a1fe0a0bea79810ed7d5f751723a10
DIST radeontop-0.8.tar.gz 29719 SHA256 4430e1aaca895d70ea496a9b14010d9d94cadd6269b28a66104af89ff29d8489 SHA512 8c711377a617cc071599ef2c3355bb1f5e68aa69e2999396272a93657c5ba448005e0829dea34666e88466c9fd7da2f58cf44ccd542be4d63a72b3ae3e1fc04a WHIRLPOOL 4c95e3aca57ad75d71f15969b91131eb7e4a73e686ca22cc2df8f2e946327ccc41d8dabc02930e3d2cdb292758887864ce4ab3e4a1c6bf799c934fe1df857665
+DIST radeontop-0.9.tar.gz 31186 SHA256 e78a56d1222c8a45f08f09409f178ddda83461085b012e5ba54b716e6c8dd61d SHA512 d219e000c3ed39e3022c8316a3412f423b363abafefb3d8d6e80fa2ac505084afaf4a18b3f6bba5918f29c1a659668e07c08d02a6fdbf9ef1764758350db449a WHIRLPOOL 744834650ae98fd87e34ca1511183a1c3a9e1b215b3a31e7872b8329f7bfd8d97df33a9425e47d2c6169412f8000b516f09526978fee4042016a76e8574f1cd6
diff --git a/x11-apps/radeontop/radeontop-0.9.ebuild b/x11-apps/radeontop/radeontop-0.9.ebuild
new file mode 100644
index 000000000000..f5cabf72bb8d
--- /dev/null
+++ b/x11-apps/radeontop/radeontop-0.9.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Utility to view Radeon GPU utilization"
+HOMEPAGE="https://github.com/clbr/radeontop"
+LICENSE="GPL-3"
+SRC_URI="https://github.com/clbr/radeontop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ sys-libs/ncurses
+ x11-libs/libpciaccess
+ x11-libs/libdrm
+ nls? ( sys-libs/ncurses[unicode] virtual/libintl )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ epatch_user
+
+cat > include/version.h << EOF || die
+#ifndef VER_H
+#define VER_H
+
+#define VERSION "${PV}"
+
+#endif
+EOF
+ >getver.sh || die
+ touch .git || die
+}
+
+src_configure() {
+ tc-export CC
+ export nls=$(usex nls 1 0)
+ # Do not add -g or -s to CFLAGS
+ export plain=1
+}