summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-09-19 19:55:53 +0200
committerManuel Rüger <mrueg@gentoo.org>2015-09-19 19:55:53 +0200
commit6e15b80934a8fa31b72dfa616919bf6c787909ce (patch)
tree8d91f511d9e2896b867853e93bf9725dfc66fdab /x11-apps
parentdev-python/mechanize: Stable for ppc. Fixes bug 558974. (diff)
downloadgentoo-6e15b80934a8fa31b72dfa616919bf6c787909ce.tar.gz
gentoo-6e15b80934a8fa31b72dfa616919bf6c787909ce.tar.bz2
gentoo-6e15b80934a8fa31b72dfa616919bf6c787909ce.zip
x11-apps/intel-gpu-tools: Version bump
Package-Manager: portage-2.2.20_p168
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/intel-gpu-tools/Manifest1
-rw-r--r--x11-apps/intel-gpu-tools/intel-gpu-tools-1.12.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/x11-apps/intel-gpu-tools/Manifest b/x11-apps/intel-gpu-tools/Manifest
index f8b3cc64492d..0dcdbe707d93 100644
--- a/x11-apps/intel-gpu-tools/Manifest
+++ b/x11-apps/intel-gpu-tools/Manifest
@@ -1,3 +1,4 @@
DIST intel-gpu-tools-1.10.tar.bz2 1501523 SHA256 6df2bef12d7cd252d702e4412937fbdc48fa954dd5f7f6988f567912f63b9874 SHA512 b6d5e2b377534a2132a22e22af5786086360646ea6d788b863e7424dd68898c6e35c31c2620f4301b00659cea56aa5739609781d8324c04929bba367f61fc8da WHIRLPOOL 916d97f24972fc9f3dad52b80193921e2fff309345d7c977d9bee89d0f03db361ce167c52eaeda311ba87d4de11a4bdc1824ed27c79bf11a64581ecb085ef5bf
DIST intel-gpu-tools-1.11.tar.bz2 1586385 SHA256 48823450452b57c52c74e00c8c763ed7cdd0c81cc877e8c2f619f7f6c45dade4 SHA512 4d36240dbc5b40ba452d49a7d7af9512f8ace923a2f87bfb3d6bec32053390e672308f1bac0dc5f83ff5430ad9806a9f5e487ca2b27ac4bc941de2c21fd5826f WHIRLPOOL d443b48b32b0101b6e0a3767933d910619ee02a6c082c026034ec5d814bbd121f370566e6a09a283988a24e955f4d0aa02829764ade766d25a4e6008947a3db3
+DIST intel-gpu-tools-1.12.tar.bz2 1621343 SHA256 143fe0ae4a52560b9c032aa7592fe8d36b1578abb873fa9b026a75acf7e38be3 SHA512 0643ffcc5198ad3c03d7fb2323f95b1a23fabc529ab00b5165a2355fe7b7d4d5e81b76627bf19f41fb6111fc3c9a32e83010e09941aa78097c9e58dce5832c81 WHIRLPOOL cb34e5410ef21ad143ae52c062c5d9b3b388885514364f2aca531746971cbb8775e4d3d26b7fe83ae68cf73eab9a99a1b9d6eeb4b4e5e09e896f872f68dcb905
DIST intel-gpu-tools-1.7.tar.bz2 11780573 SHA256 22612343bbd9b518b9f92a983555dbbcae8040ee577a38277dbf873c8900207a SHA512 13181db6d2424fa27c97c30ecb83b8554fc2e9ce98bec7b7735f919aa9d7e2563c3e1860dc6e5aedf3918c029acb205b8fcf6a32de1567f557f8cd98c09a5d98 WHIRLPOOL f66e0710377aa4f46067840efd1cf70814e10cd81ff24ebb5db21b901787846f63b1461502ec01ba7383ead76e985c25860801355a9582d5509a861fa70aacb0
diff --git a/x11-apps/intel-gpu-tools/intel-gpu-tools-1.12.ebuild b/x11-apps/intel-gpu-tools/intel-gpu-tools-1.12.ebuild
new file mode 100644
index 000000000000..8251c6f968d0
--- /dev/null
+++ b/x11-apps/intel-gpu-tools/intel-gpu-tools-1.12.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+inherit python-single-r1 xorg-2
+
+DESCRIPTION="Intel GPU userland tools"
+KEYWORDS="~amd64 ~x86"
+IUSE="python test-programs unwind video_cards_nouveau"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="test"
+
+DEPEND="dev-libs/glib:2
+ >=x11-libs/cairo-1.12.0
+ >=x11-libs/libdrm-2.4.52[video_cards_intel,video_cards_nouveau?]
+ >=x11-libs/libpciaccess-0.10
+ python? ( ${PYTHON_DEPS} )
+ unwind? ( sys-libs/libunwind )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable python dumper)
+ $(use_enable video_cards_nouveau nouveau)
+ $(use_enable test-programs tests)
+ $(use_with unwind libunwind)
+ )
+ xorg-2_src_configure
+}
+
+src_install() {
+ xorg-2_src_install
+ if use test-programs; then
+ local testprogram
+ pushd "${AUTOTOOLS_BUILD_DIR}"/tests || die
+ for testprogram in $(<multi-tests.txt) $(<single-tests.txt); do
+ if [[ -f ${testprogram} ]]; then
+ dobin "${testprogram}"
+ fi
+ done
+ popd
+ fi
+}
+
+pkg_postinst() {
+ xorg-2_pkg_postinst
+ if use test-programs; then
+ elog "Test programs for DRM driver development were installed. These are not"
+ elog "designed to run outside their source tree, so may or may not work as"
+ elog "intended."
+ fi
+}