summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-02-24 18:18:17 -0500
committerMatt Turner <mattst88@gentoo.org>2021-02-24 19:02:24 -0500
commit59eca50f432d61ed7abb31acaab653784a48e06f (patch)
tree0da1e6fae2fd462fc0c58d4278583b961e2c1371 /x11-base/xorg-proto/xorg-proto-2021.2.ebuild
parentx11-base/xorg-proto: Add IUSE=test (diff)
downloadgentoo-59eca50f432d61ed7abb31acaab653784a48e06f.tar.gz
gentoo-59eca50f432d61ed7abb31acaab653784a48e06f.tar.bz2
gentoo-59eca50f432d61ed7abb31acaab653784a48e06f.zip
x11-base/xorg-proto: Version bump to 2021.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-base/xorg-proto/xorg-proto-2021.2.ebuild')
-rw-r--r--x11-base/xorg-proto/xorg-proto-2021.2.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/x11-base/xorg-proto/xorg-proto-2021.2.ebuild b/x11-base/xorg-proto/xorg-proto-2021.2.ebuild
new file mode 100644
index 000000000000..9aa9a84a71d7
--- /dev/null
+++ b/x11-base/xorg-proto/xorg-proto-2021.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+MY_PN="${PN/xorg-/xorg}"
+MY_P="${MY_PN}-${PV}"
+
+EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/proto/${MY_PN}.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} meson python-any-r1
+
+DESCRIPTION="X.Org combined protocol headers"
+HOMEPAGE="https://gitlab.freedesktop.org/xorg/proto/xorgproto"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+ SRC_URI="https://xorg.freedesktop.org/archive/individual/proto/${MY_P}.tar.gz
+ https://cgit.freedesktop.org/xorg/proto/xorgproto/plain/scripts/keysym-generator.py?id=7b6836f0d5ba44d94abb7b3163ef715d023b270c -> keysym-generator.py"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ $(python_gen_any_dep '
+ dev-python/python-libevdev[${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND=""
+
+python_check_deps() {
+ has_version -b "dev-python/python-libevdev[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_unpack() {
+ default
+ mkdir "${S}"/scripts
+ mv "${DISTDIR}"/keysym-generator.py "${S}/scripts"
+}