summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-08-11 13:37:33 -0400
committerMatt Turner <mattst88@gentoo.org>2022-08-11 13:40:36 -0400
commit369f9d3e07ee4771ea5dd15544d24257662203c5 (patch)
tree6e3c0d53ffbcc071faf2af27b9852530a9ed4a00 /x11-base
parentx11-base/xorg-proto: Add Python 3.11 compatibility (diff)
downloadgentoo-369f9d3e07ee4771ea5dd15544d24257662203c5.tar.gz
gentoo-369f9d3e07ee4771ea5dd15544d24257662203c5.tar.bz2
gentoo-369f9d3e07ee4771ea5dd15544d24257662203c5.zip
x11-base/xorg-proto: Version bump to 2022.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xorg-proto/Manifest1
-rw-r--r--x11-base/xorg-proto/xorg-proto-2022.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/x11-base/xorg-proto/Manifest b/x11-base/xorg-proto/Manifest
index 724cae2bffbd..24828bbfcd00 100644
--- a/x11-base/xorg-proto/Manifest
+++ b/x11-base/xorg-proto/Manifest
@@ -1 +1,2 @@
DIST xorgproto-2022.1.tar.gz 1107316 BLAKE2B b7c60d77978f95b62208c5c5974c7310a9b6197c8b14218ba319eb44660f20c5eb33ef106beccae16f79a0530a20bd38b6aa2de81329c4b48a2da285ab903c31 SHA512 e34404eb9f7edfebdecbf38c66491fbca91929c59b5762d3266b2808cdae3f4e65589001d29bf5374effc56173a5467f5a107bf4fe05acae69839b841e83f72c
+DIST xorgproto-2022.2.tar.xz 757080 BLAKE2B 0fee7910fced83548780fd1c7bfd214c932c7c5064c6ebd40ac9285d071837056b9eca24dadb53a572a05768f8762c4dd81ac58fcf6b43028f557ed56a98f7f9 SHA512 8e6108110600d076a94cc6d0e465b2e9adfbbe8d7e6b75fae9c5262d99dc6074ab1ed561a74d6d451f00f5b7af9f507a6317be9c0770efeed9e60b64beb7a1c9
diff --git a/x11-base/xorg-proto/xorg-proto-2022.2.ebuild b/x11-base/xorg-proto/xorg-proto-2022.2.ebuild
new file mode 100644
index 000000000000..ccbe4831235d
--- /dev/null
+++ b/x11-base/xorg-proto/xorg-proto-2022.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+MY_PN="${PN/xorg-/xorg}"
+MY_P="${MY_PN}-${PV}"
+
+EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/proto/${MY_PN}.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} meson python-any-r1
+
+DESCRIPTION="X.Org combined protocol headers"
+HOMEPAGE="https://gitlab.freedesktop.org/xorg/proto/xorgproto"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+ SRC_URI="https://xorg.freedesktop.org/archive/individual/proto/${MY_P}.tar.xz"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ $(python_gen_any_dep '
+ dev-python/python-libevdev[${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND=""
+
+python_check_deps() {
+ has_version -b "dev-python/python-libevdev[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_install() {
+ meson_src_install
+
+ mv "${ED}"/usr/share/doc/{xorgproto,${P}} || die
+}