summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-04-08 22:06:32 -0400
committerMatt Turner <mattst88@gentoo.org>2023-04-08 22:10:20 -0400
commit5cd3901cfc0fb124beebf75cff421bb518e4d5a4 (patch)
tree95c9a6e41e35341f063b5bf1f9b3f1baa64fb855 /x11-base
parentmedia-libs/mesa: Version bump to 23.0.2 (diff)
downloadgentoo-5cd3901cfc0fb124beebf75cff421bb518e4d5a4.tar.gz
gentoo-5cd3901cfc0fb124beebf75cff421bb518e4d5a4.tar.bz2
gentoo-5cd3901cfc0fb124beebf75cff421bb518e4d5a4.zip
x11-base/xwayland: Version bump to 23.1.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xwayland/Manifest1
-rw-r--r--x11-base/xwayland/xwayland-23.1.1.ebuild101
2 files changed, 102 insertions, 0 deletions
diff --git a/x11-base/xwayland/Manifest b/x11-base/xwayland/Manifest
index c0062184b886..c5708bd1f2f5 100644
--- a/x11-base/xwayland/Manifest
+++ b/x11-base/xwayland/Manifest
@@ -1,2 +1,3 @@
DIST xwayland-22.1.8.tar.xz 1273668 BLAKE2B ad1f3e0a6a3782b271653864380d0beb0db60293fb96ab8f218caaeef245967ad46ca505fb516a936115c9d49e6a32bffb725bc6c95dc98a6c4c24521c6022df SHA512 f52c6f99d8ef7605bc1c651d5ee5e306c12af30649a2d712b1c4c3cf4c7c80246ae24bd9ac39461d47aafc78f5d659446a459cd6259e05ef3128b204981d114a
DIST xwayland-23.1.0.tar.xz 1286056 BLAKE2B 19f3cee10f9b86a1ee4529f91de3125c303a771ddb00ab1d76764fec2d8d2639e20585de777741fc3706ec6e2f03a1295024cd9c582c1e4a744fa1a43d8997e6 SHA512 984213a193b903e6023ecb3144a15f483dc3e9ec7cb02c36d8e67c6859b501b8b3e5a6e1ade9cb245450ad93002322f392b81d9286377ac34350cc3ea1f9679f
+DIST xwayland-23.1.1.tar.xz 1286460 BLAKE2B 2f0095510a15eab4096696fcfdbf0cfe6814b48bd5b5666701a61bc942ce2fe00555a7d5a45cbaec2066bbbfd9b863909e0398d3d6aaab1dfc0e78d1ea913080 SHA512 21c386847135c5cb4ac884926b0fbeb6ad21c9ee54752e0cdc8418e31a72872d81032159c1d91b8afb915aaaf65e80454342461d676996b2f3c535a37b0147f0
diff --git a/x11-base/xwayland/xwayland-23.1.1.ebuild b/x11-base/xwayland/xwayland-23.1.1.ebuild
new file mode 100644
index 000000000000..d7e53ec8adcf
--- /dev/null
+++ b/x11-base/xwayland/xwayland-23.1.1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/xserver.git"
+ inherit git-r3
+else
+ SRC_URI="https://xorg.freedesktop.org/archive/individual/xserver/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Standalone X server running under Wayland"
+HOMEPAGE="https://wayland.freedesktop.org/xserver.html"
+
+IUSE="selinux video_cards_nvidia unwind xcsecurity"
+
+LICENSE="MIT"
+SLOT="0"
+
+COMMON_DEPEND="
+ dev-libs/libbsd
+ dev-libs/openssl:=
+ >=dev-libs/wayland-1.21.0
+ >=dev-libs/wayland-protocols-1.28
+ media-fonts/font-util
+ >=media-libs/libepoxy-1.5.4[X,egl(+)]
+ media-libs/libglvnd[X]
+ >=media-libs/mesa-21.1[X(+),egl(+),gbm(+)]
+ >=x11-libs/libdrm-2.4.109
+ >=x11-libs/libXau-1.0.4
+ x11-libs/libxcvt
+ >=x11-libs/libXdmcp-1.0.2
+ >=x11-libs/libXfont2-2.0.1
+ x11-libs/libxkbfile
+ >=x11-libs/libxshmfence-1.1
+ >=x11-libs/pixman-0.27.2
+ >=x11-misc/xkeyboard-config-2.4.1-r3
+
+ unwind? ( sys-libs/libunwind )
+ video_cards_nvidia? ( gui-libs/egl-wayland )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ >=x11-base/xorg-proto-2022.2
+ >=x11-libs/xtrans-1.3.5
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ x11-apps/xkbcomp
+ !<=x11-base/xorg-server-1.20.11
+ selinux? ( sec-policy/selinux-xserver )
+"
+BDEPEND="
+ sys-devel/flex
+ dev-util/wayland-scanner
+"
+
+PATCHES=(
+ "${FILESDIR}"/xwayland-drop-redundantly-installed-files.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use selinux xselinux)
+ $(meson_use unwind libunwind)
+ $(meson_use xcsecurity)
+ $(meson_use video_cards_nvidia xwayland_eglstream)
+ -Ddpms=true
+ -Ddri3=true
+ -Ddrm=true
+ -Ddtrace=false
+ -Dglamor=true
+ -Dglx=true
+ -Dipv6=true
+ -Dsecure-rpc=false
+ -Dscreensaver=true
+ -Dsha1=libcrypto
+ -Dxace=true
+ -Dxdmcp=true
+ -Dxinerama=true
+ -Dxvfb=true
+ -Dxv=true
+ -Dxwayland-path="${EPREFIX}"/usr/bin
+ -Dlibdecor=false
+ -Ddocs=false
+ -Ddevel-docs=false
+ -Ddocs-pdf=false
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ dosym ../bin/Xwayland /usr/libexec/Xwayland
+
+ meson_src_install
+}