summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-07-16 19:30:26 -0500
committerMatt Turner <mattst88@gentoo.org>2018-07-17 07:15:21 -0700
commit382f34ce82f3f8aec3583bac347605139cb378d6 (patch)
tree9077b19aec950182e4026513de7d920e385a3113 /x11-drivers/xf86-input-evdev
parentx11-drivers/xf86-input-evdev: port to EAPI 7 (diff)
downloadgentoo-382f34ce82f3f8aec3583bac347605139cb378d6.tar.gz
gentoo-382f34ce82f3f8aec3583bac347605139cb378d6.tar.bz2
gentoo-382f34ce82f3f8aec3583bac347605139cb378d6.zip
x11-drivers/xf86-input-evdev: add live ebuild
Package-Manager: Portage-2.3.42, Repoman-2.3.9
Diffstat (limited to 'x11-drivers/xf86-input-evdev')
-rw-r--r--x11-drivers/xf86-input-evdev/xf86-input-evdev-9999.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-evdev/xf86-input-evdev-9999.ebuild b/x11-drivers/xf86-input-evdev/xf86-input-evdev-9999.ebuild
new file mode 100644
index 000000000000..8905d3eea3fa
--- /dev/null
+++ b/x11-drivers/xf86-input-evdev/xf86-input-evdev-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info
+
+DESCRIPTION="Generic Linux input driver"
+HOMEPAGE="https://www.x.org/wiki/ https://cgit.freedesktop.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/xorg/driver/xf86-input-evdev.git"
+ inherit autotools git-r3
+ LIVE_DEPEND=">=x11-misc/util-macros-1.18"
+else
+ SRC_URI="mirror://xorg/driver/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh sparc x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ dev-libs/libevdev
+ sys-libs/mtdev
+ virtual/libudev:=
+ >=x11-base/xorg-server-1.18[udev]
+"
+DEPEND="
+ ${LIVE_DEPEND}
+ ${RDEPEND}
+ >=sys-kernel/linux-headers-2.6
+ x11-base/xorg-proto
+ x11-misc/util-macros
+"
+
+pkg_pretend() {
+ if use kernel_linux ; then
+ CONFIG_CHECK="~INPUT_EVDEV"
+ fi
+ check_extra_config
+}
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}