summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2017-01-29 10:55:22 -0800
committerMatt Turner <mattst88@gentoo.org>2017-01-29 11:00:14 -0800
commit81e5a77e95d087c418c08f65a561de9a0cc8541c (patch)
treea92902f866f051874a7073a4062bcc57f66fb461 /x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-9999.ebuild
parentmedia-gfx/exiv2: dropped ~x86-freebsd (diff)
downloadgentoo-81e5a77e95d087c418c08f65a561de9a0cc8541c.tar.gz
gentoo-81e5a77e95d087c418c08f65a561de9a0cc8541c.tar.bz2
gentoo-81e5a77e95d087c418c08f65a561de9a0cc8541c.zip
x11-drivers/xf86-input-vmmouse: Add live ebuild.
Diffstat (limited to 'x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-9999.ebuild')
-rw-r--r--x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-9999.ebuild b/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-9999.ebuild
new file mode 100644
index 000000000000..942951afd8ea
--- /dev/null
+++ b/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit xorg-2
+
+DESCRIPTION="VMWare mouse input driver"
+IUSE=""
+KEYWORDS=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ x11-proto/randrproto"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ --with-hal-bin-dir=/punt
+ --with-hal-callouts-dir=/punt
+ --with-hal-fdi-dir=/punt
+ )
+
+ xorg-2_pkg_setup
+}
+
+src_install() {
+ xorg-2_src_install
+ rm -rf "${ED}"/punt
+}