summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2015-10-26 19:05:09 +0100
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2015-10-26 19:05:09 +0100
commit0eb75b021dd97db71b8327296499967117003f97 (patch)
treebfa78321c9a76e97edc8a877723e227a4cdd87a1 /x11-drivers/xf86-input-wacom
parentgames-strategy/0ad: rm old (diff)
downloadgentoo-0eb75b021dd97db71b8327296499967117003f97.tar.gz
gentoo-0eb75b021dd97db71b8327296499967117003f97.tar.bz2
gentoo-0eb75b021dd97db71b8327296499967117003f97.zip
x11-drivers/xf86-input-wacom: Version bump
Bug: https://bugs.gentoo.org/show_bug.cgi?id=562698 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'x11-drivers/xf86-input-wacom')
-rw-r--r--x11-drivers/xf86-input-wacom/Manifest1
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-0.31.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-wacom/Manifest b/x11-drivers/xf86-input-wacom/Manifest
index 70fc4121ee35..8e420d7e701e 100644
--- a/x11-drivers/xf86-input-wacom/Manifest
+++ b/x11-drivers/xf86-input-wacom/Manifest
@@ -1,3 +1,4 @@
DIST xf86-input-wacom-0.24.0.tar.bz2 581176 SHA256 96478b26c125938245d386f50b5286e362b85efdd71bf7faf27ed3d5292032b8 SHA512 e7c3af4a358d9a8e39992b6151201bb19c7df69b9b3a162015c73b8789e2e803317e02dd8492b00e769815b6936ff06f300676d64726b4dd5b5896122cd05fd6 WHIRLPOOL 5b9ec0321e2a35f23eb9242d71401b0f312983805297d9ac7586050f8f00c8890eabd823a08ff629cf2829b639098030f0e2247648697322342656479d0e85b9
DIST xf86-input-wacom-0.29.0.tar.bz2 589495 SHA256 88507e76f1eb98a20c4381806e03c694adcff88ac0028f93892019a7a6fc8b96 SHA512 26035a0b49f15f1782ab0ffe4c24383db84f203f0e8c2e82a9e1f4fa015bc3272b6e7250ee2c25eaa1bba4c4eeb71775f2adc331d0df957bbb952dbe1c6766a4 WHIRLPOOL 68a89ea73370bcd7b9b79a7c17c6c10edf603c80300d3ea0b6092731bb9fff767fe4cc454a1f60585fa273165ce7706e72a6a07cf9d287867a504c385dcff8f1
DIST xf86-input-wacom-0.30.0.tar.bz2 591648 SHA256 8ad4e479a4fc6d3c18e680958a8f42c3c87f15fdf8d2561810ca01a0a78841f5 SHA512 115e87715e736d77ad4e45e29287c855289cea5871983b7ad2e7e1e64954078de184d1b78157e958a0c9e7b949061b4c5599e2b11e87d5019a843bcaa34e0381 WHIRLPOOL 92f93b8694760c5dfbfb0182909e5b2ec3a8c197143962249c032f51483f3b194db12ad522cdfe8401b7368f99395dbf0b941b73a9691cea19cc156a180e6fb6
+DIST xf86-input-wacom-0.31.0.tar.bz2 592564 SHA256 e7e9723f048071adabc878bf6139342ea39dea5e3a8134452df5a33bef2e3f76 SHA512 6c24394038585d90b9b30c594b773b36b5ea26ea5eaab73519cd2e1b56eb2ad3e1f3991ca3962a70468da32e83105c9619f524afbf4e6c500661c7c62b4261e8 WHIRLPOOL d84326730a73a50c420876c2e81adc836dcf657d746e09b614902c879390230c43d657f748fd015f874ebe11f277c9b586ddaf762e1aac551ff05a74321c48ff
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.31.0.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.31.0.ebuild
new file mode 100644
index 000000000000..8ec78b81c76c
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.31.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-info xorg-2
+
+DESCRIPTION="Driver for Wacom tablets and drawing devices"
+HOMEPAGE="http://linuxwacom.sourceforge.net/"
+LICENSE="GPL-2"
+EGIT_REPO_URI="git://linuxwacom.git.sourceforge.net/gitroot/linuxwacom/${PN}"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="mirror://sourceforge/linuxwacom/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+# depend on libwacom for its udev rules, bug #389633
+RDEPEND="dev-libs/libwacom
+ virtual/udev
+ >=x11-base/xorg-server-1.7
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXinerama"
+DEPEND="${RDEPEND}
+ x11-proto/randrproto"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable debug)
+ )
+}
+
+src_install() {
+ xorg-2_src_install
+
+ rm -rf "${ED}"/usr/share/hal
+}
+
+pkg_pretend() {
+ linux-info_pkg_setup
+
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present TABLET_USB_WACOM \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ ewarn " [*] Tablets --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+}