summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-03-10 20:14:04 +0100
committerDavid Seifert <soap@gentoo.org>2018-03-10 20:14:30 +0100
commit2e4ddcb2d2d31b8c0a5785a47a836e0a451523b0 (patch)
tree1f8233e3cd6529cfe969c09b78fc3a04b9c014f6 /x11-drivers
parentdev-lang/perl/perl: unbreak Solaris, we NEED -lnsl there (diff)
downloadgentoo-2e4ddcb2d2d31b8c0a5785a47a836e0a451523b0.tar.gz
gentoo-2e4ddcb2d2d31b8c0a5785a47a836e0a451523b0.tar.bz2
gentoo-2e4ddcb2d2d31b8c0a5785a47a836e0a451523b0.zip
x11-drivers/xf86-video-r128: Add missing include on stdint.h
Closes: https://bugs.gentoo.org/649496 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-r128/files/xf86-video-r128-6.10.2-fix-stdint_h.patch11
-rw-r--r--x11-drivers/xf86-video-r128/xf86-video-r128-6.10.2.ebuild14
2 files changed, 23 insertions, 2 deletions
diff --git a/x11-drivers/xf86-video-r128/files/xf86-video-r128-6.10.2-fix-stdint_h.patch b/x11-drivers/xf86-video-r128/files/xf86-video-r128-6.10.2-fix-stdint_h.patch
new file mode 100644
index 000000000000..e5b731660632
--- /dev/null
+++ b/x11-drivers/xf86-video-r128/files/xf86-video-r128-6.10.2-fix-stdint_h.patch
@@ -0,0 +1,11 @@
+--- a/src/atipcirename.h
++++ b/src/atipcirename.h
+@@ -29,6 +29,8 @@
+ #ifndef ATIPCIRENAME_H
+ #define ATIPCIRENAME_H
+
++#include <stdint.h>
++
+ enum region_type {
+ REGION_MEM,
+ REGION_IO
diff --git a/x11-drivers/xf86-video-r128/xf86-video-r128-6.10.2.ebuild b/x11-drivers/xf86-video-r128/xf86-video-r128-6.10.2.ebuild
index 6bab28438f22..6369cbf866a1 100644
--- a/x11-drivers/xf86-video-r128/xf86-video-r128-6.10.2.ebuild
+++ b/x11-drivers/xf86-video-r128/xf86-video-r128-6.10.2.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
XORG_DRI=dri
-inherit xorg-2
+
+inherit flag-o-matic xorg-2
DESCRIPTION="ATI Rage128 video driver"
@@ -13,8 +14,17 @@ IUSE="dri"
RDEPEND=">=x11-base/xorg-server-1.2"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-fix-stdint_h.patch )
+
pkg_setup() {
XORG_CONFIGURE_OPTIONS=(
$(use_enable dri)
)
}
+
+src_configure() {
+ # always use C11 semantics
+ append-cflags -std=gnu11
+
+ xorg-2_src_configure
+}