summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-02 00:11:54 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-02 00:13:28 -0400
commit91f9b197889d1d72fa1ffb175fc902c7049391f0 (patch)
tree49f554c5878c58c6a78001d5153ca2527e5d00a1 /x11-drivers
parentx11-drivers/nvidia-drivers: warn about simpledrm again + FB/nouveau (diff)
downloadgentoo-91f9b197889d1d72fa1ffb175fc902c7049391f0.tar.gz
gentoo-91f9b197889d1d72fa1ffb175fc902c7049391f0.tar.bz2
gentoo-91f9b197889d1d72fa1ffb175fc902c7049391f0.zip
x11-drivers/nvidia-drivers: note that the FB warning can be ignored
Varied configuration is part of why I haven't included these kind of warnings before (may be noisy for some) -- but getting a console to work with nvidia has become near nonsensial unless know exactly what still works (between my own kernel and gentoo-kernel-bin-5.15.x I didn't really notice these new issues). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-390.154.ebuild7
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-470.141.03.ebuild7
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-510.85.02.ebuild7
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-515.49.19.ebuild7
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-515.65.01.ebuild7
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-515.76.ebuild7
6 files changed, 24 insertions, 18 deletions
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-390.154.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-390.154.ebuild
index 6fefc8a6b044..056c04443660 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-390.154.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-390.154.ebuild
@@ -144,10 +144,11 @@ pkg_setup() {
# nvidia-drivers does not handle the tty (beside mode restoration) but,
# given few options are viable, try to warn if all missing
warn+=(
- " CONFIG_FB_(EFI|SIMPLE|VESA): none set, but note at least one is needed"
- " to get a display for the tty console. In most cases, it is"
+ " CONFIG_FB_(EFI|SIMPLE|VESA): none set, but note at least one is normally"
+ " needed to get a display for the tty console. In most cases, it is"
" recommended to enable FB_EFI=y and disable FB_SIMPLE (can be quirky)."
- " Non-EFI systems are likely to want FB_VESA=y."
+ " Non-EFI systems are likely to want FB_VESA=y. Users with multiple GPUs"
+ " or not using the tty may be able to safely ignore this warning."
)
fi
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-470.141.03.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-470.141.03.ebuild
index c4c457890298..0f4634979526 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-470.141.03.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-470.141.03.ebuild
@@ -147,10 +147,11 @@ pkg_setup() {
# nvidia-drivers does not handle the tty (beside mode restoration) but,
# given few options are viable, try to warn if all missing
warn+=(
- " CONFIG_FB_(EFI|SIMPLE|VESA): none set, but note at least one is needed"
- " to get a display for the tty console. In most cases, it is"
+ " CONFIG_FB_(EFI|SIMPLE|VESA): none set, but note at least one is normally"
+ " needed to get a display for the tty console. In most cases, it is"
" recommended to enable FB_EFI=y and disable FB_SIMPLE (can be quirky)."
- " Non-EFI systems are likely to want FB_VESA=y."
+ " Non-EFI systems are likely to want FB_VESA=y. Users with multiple GPUs"
+ " or not using the tty may be able to safely ignore this warning."
)
fi
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-510.85.02.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-510.85.02.ebuild
index 6739680f1336..de65d9d7dbde 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-510.85.02.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-510.85.02.ebuild
@@ -150,10 +150,11 @@ pkg_setup() {
# nvidia-drivers does not handle the tty (beside mode restoration) but,
# given few options are viable, try to warn if all missing
warn+=(
- " CONFIG_FB_(EFI|SIMPLE|VESA): none set, but note at least one is needed"
- " to get a display for the tty console. In most cases, it is"
+ " CONFIG_FB_(EFI|SIMPLE|VESA): none set, but note at least one is normally"
+ " needed to get a display for the tty console. In most cases, it is"
" recommended to enable FB_EFI=y and disable FB_SIMPLE (can be quirky)."
- " Non-EFI systems are likely to want FB_VESA=y."
+ " Non-EFI systems are likely to want FB_VESA=y. Users with multiple GPUs"
+ " or not using the tty may be able to safely ignore this warning."
)
fi
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-515.49.19.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-515.49.19.ebuild
index 6568dcc23e75..58ea8699f7d7 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-515.49.19.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-515.49.19.ebuild
@@ -159,10 +159,11 @@ pkg_setup() {
# nvidia-drivers does not handle the tty (beside mode restoration) but,
# given few options are viable, try to warn if all missing
warn+=(
- " CONFIG_FB_(EFI|SIMPLE|VESA): none set, but note at least one is needed"
- " to get a display for the tty console. In most cases, it is"
+ " CONFIG_FB_(EFI|SIMPLE|VESA): none set, but note at least one is normally"
+ " needed to get a display for the tty console. In most cases, it is"
" recommended to enable FB_EFI=y and disable FB_SIMPLE (can be quirky)."
- " Non-EFI systems are likely to want FB_VESA=y."
+ " Non-EFI systems are likely to want FB_VESA=y. Users with multiple GPUs"
+ " or not using the tty may be able to safely ignore this warning."
)
fi
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-515.65.01.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-515.65.01.ebuild
index 9edb6fe04224..9c35dd8fe324 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-515.65.01.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-515.65.01.ebuild
@@ -159,10 +159,11 @@ pkg_setup() {
# nvidia-drivers does not handle the tty (beside mode restoration) but,
# given few options are viable, try to warn if all missing
warn+=(
- " CONFIG_FB_(EFI|SIMPLE|VESA): none set, but note at least one is needed"
- " to get a display for the tty console. In most cases, it is"
+ " CONFIG_FB_(EFI|SIMPLE|VESA): none set, but note at least one is normally"
+ " needed to get a display for the tty console. In most cases, it is"
" recommended to enable FB_EFI=y and disable FB_SIMPLE (can be quirky)."
- " Non-EFI systems are likely to want FB_VESA=y."
+ " Non-EFI systems are likely to want FB_VESA=y. Users with multiple GPUs"
+ " or not using the tty may be able to safely ignore this warning."
)
fi
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-515.76.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-515.76.ebuild
index f5d9379122e2..5aff3c436a26 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-515.76.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-515.76.ebuild
@@ -159,10 +159,11 @@ pkg_setup() {
# nvidia-drivers does not handle the tty (beside mode restoration) but,
# given few options are viable, try to warn if all missing
warn+=(
- " CONFIG_FB_(EFI|SIMPLE|VESA): none set, but note at least one is needed"
- " to get a display for the tty console. In most cases, it is"
+ " CONFIG_FB_(EFI|SIMPLE|VESA): none set, but note at least one is normally"
+ " needed to get a display for the tty console. In most cases, it is"
" recommended to enable FB_EFI=y and disable FB_SIMPLE (can be quirky)."
- " Non-EFI systems are likely to want FB_VESA=y."
+ " Non-EFI systems are likely to want FB_VESA=y. Users with multiple GPUs"
+ " or not using the tty may be able to safely ignore this warning."
)
fi