summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-19 21:23:31 +0000
committerSam James <sam@gentoo.org>2021-12-19 21:30:12 +0000
commitbd3fc7a8f0191de5f3a7ff225c4ff386d217cd46 (patch)
tree1e8a3d901ce560f7aa7ccbfe7281b1ff95044e9a /x11-drivers
parentdev-util/sysdig: fix build with newer grpc (diff)
downloadgentoo-bd3fc7a8f0191de5f3a7ff225c4ff386d217cd46.tar.gz
gentoo-bd3fc7a8f0191de5f3a7ff225c4ff386d217cd46.tar.bz2
gentoo-bd3fc7a8f0191de5f3a7ff225c4ff386d217cd46.zip
x11-drivers/xf86-video-vmware: fix build with newer xorg-server
Closes: https://bugs.gentoo.org/829627 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-vmware/files/xf86-video-vmware-13.3.0-fix-include-order-bool.patch51
-rw-r--r--x11-drivers/xf86-video-vmware/xf86-video-vmware-13.3.0.ebuild4
2 files changed, 55 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-vmware/files/xf86-video-vmware-13.3.0-fix-include-order-bool.patch b/x11-drivers/xf86-video-vmware/files/xf86-video-vmware-13.3.0-fix-include-order-bool.patch
new file mode 100644
index 000000000000..9ffa436a41e5
--- /dev/null
+++ b/x11-drivers/xf86-video-vmware/files/xf86-video-vmware-13.3.0-fix-include-order-bool.patch
@@ -0,0 +1,51 @@
+https://gitlab.freedesktop.org/xorg/driver/xf86-video-vmware/-/commit/50ab008cb965dc9e47e0a84a1950e2485bbd3c44
+https://bugs.gentoo.org/829627
+
+From: Martin Krastev <krastevm@vmware.com>
+Date: Tue, 30 Nov 2021 11:47:39 -0800
+Subject: [PATCH] vmwgfx: Change header inclusion order to avoid xorg headers
+ catching stdbool.h
+
+libdrm commit e641e2a632d779f638ac2ba983b9fceb20b3fac4 added
+stdbool.h to the library headers which conflicts with xorg headers.
+
+Signed-off-by: Martin Krastev <krastevm@vmware.com>
+Reviewed-by: Zack Rusin <zackr@vmware.com>
+Signed-off-by: Zack Rusin <zackr@vmware.com>
+--- a/vmwgfx/vmwgfx_driver.h
++++ b/vmwgfx/vmwgfx_driver.h
+@@ -36,15 +36,15 @@
+ #include <stddef.h>
+ #include <stdint.h>
+ #include <errno.h>
+-#include <drm.h>
+-#include <xf86drm.h>
+-#include <xf86drmMode.h>
+ #include <xorg-server.h>
+ #include <xf86.h>
+ #include <xf86Crtc.h>
+ #include <xf86xv.h>
+ #include <xa_tracker.h>
+ #include <xf86Module.h>
++#include <drm.h>
++#include <xf86drm.h>
++#include <xf86drmMode.h>
+
+ #include "../src/compat-api.h"
+ #ifdef DRI2
+--- a/vmwgfx/vmwgfx_saa.c
++++ b/vmwgfx/vmwgfx_saa.c
+@@ -29,11 +29,11 @@
+ #include <xorgVersion.h>
+ #include <mi.h>
+ #include <fb.h>
+-#include <xf86drmMode.h>
+ #include <xa_context.h>
+ #include "vmwgfx_saa.h"
+ #include "vmwgfx_drmi.h"
+ #include "vmwgfx_saa_priv.h"
++#include <xf86drmMode.h>
+
+ /*
+ * Damage to be added as soon as we attach storage to the pixmap.
+GitLab
diff --git a/x11-drivers/xf86-video-vmware/xf86-video-vmware-13.3.0.ebuild b/x11-drivers/xf86-video-vmware/xf86-video-vmware-13.3.0.ebuild
index d08ada7668f2..ee472df8b0d6 100644
--- a/x11-drivers/xf86-video-vmware/xf86-video-vmware-13.3.0.ebuild
+++ b/x11-drivers/xf86-video-vmware/xf86-video-vmware-13.3.0.ebuild
@@ -17,3 +17,7 @@ RDEPEND="
media-libs/mesa[xa]
)"
DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-include-order-bool.patch
+)