summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-03-19 23:39:25 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-19 23:39:25 +0100
commitcd64257c4ba3bf4c365311de336e211b5ee326d8 (patch)
treed89c79865f9ce3a3c21af20a87e5c5d89ee9ab09 /x11-drivers
parentx11-drivers/xf86-video-ast: Port to EAPI 7 (diff)
downloadgentoo-cd64257c4ba3bf4c365311de336e211b5ee326d8.tar.gz
gentoo-cd64257c4ba3bf4c365311de336e211b5ee326d8.tar.bz2
gentoo-cd64257c4ba3bf4c365311de336e211b5ee326d8.zip
x11-drivers/xf86-video-dummy: Port to EAPI 7
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-dummy/xf86-video-dummy-0.3.8.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/x11-drivers/xf86-video-dummy/xf86-video-dummy-0.3.8.ebuild b/x11-drivers/xf86-video-dummy/xf86-video-dummy-0.3.8.ebuild
index 436ff4aaa8a9..93c6b8a3bb46 100644
--- a/x11-drivers/xf86-video-dummy/xf86-video-dummy-0.3.8.ebuild
+++ b/x11-drivers/xf86-video-dummy/xf86-video-dummy-0.3.8.ebuild
@@ -1,21 +1,23 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit xorg-2
+EAPI=7
+
+inherit xorg-3
DESCRIPTION="X.Org driver for dummy cards"
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
IUSE="dga"
-RDEPEND=">=x11-base/xorg-server-1.0.99"
-DEPEND="${RDEPEND}
+RDEPEND="x11-base/xorg-server"
+DEPEND="
+ ${RDEPEND}
dga? ( x11-base/xorg-proto )"
-pkg_setup() {
- XORG_CONFIGURE_OPTIONS=(
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
$(use_enable dga)
)
- xorg-2_pkg_setup
+ xorg-3_src_configure
}