summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2016-12-14 14:22:35 -0800
committerMatt Turner <mattst88@gentoo.org>2016-12-14 14:23:28 -0800
commite29b610e676f0bd700f827e27088cda201baefc6 (patch)
tree539226f1cf5630000b4f91b4111162ffb5a8cb1d /x11-drivers
parentsys-devel/llvm: Rebase the llvm-config patch for -9999 (diff)
downloadgentoo-e29b610e676f0bd700f827e27088cda201baefc6.tar.gz
gentoo-e29b610e676f0bd700f827e27088cda201baefc6.tar.bz2
gentoo-e29b610e676f0bd700f827e27088cda201baefc6.zip
x11-drivers/xf86-video-dummy: Version bump to 0.3.8.
Straight to stable.
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-dummy/Manifest1
-rw-r--r--x11-drivers/xf86-video-dummy/xf86-video-dummy-0.3.8.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-dummy/Manifest b/x11-drivers/xf86-video-dummy/Manifest
index 9ac79f47954c..8426f9e06810 100644
--- a/x11-drivers/xf86-video-dummy/Manifest
+++ b/x11-drivers/xf86-video-dummy/Manifest
@@ -1,2 +1,3 @@
DIST xf86-video-dummy-0.3.6.tar.bz2 285892 SHA256 44335b640126d339700256dae731bd5af79afd027da172bad8a991a33a1de798 SHA512 3a530083d591ebde37b58a329d9a6ed4955d09d8f3f7fb566840681f2588aa752014c8753f411aec0410a2704b3b55729868a27aee138df42eb7d7bb5a5a52c5 WHIRLPOOL 4475426b4469968ad63f830a66cc44452f39194c0abcaf9b54e527fe8c560f6dc7b38030a5f1dd95ecec9e82f291bcb3bde3820c1506f2bcdce60d1e352e6ec4
DIST xf86-video-dummy-0.3.7.tar.bz2 279806 SHA256 56f84fcbc515685529ad8e10bca1072731d9c096b97c5d35ddc95cd589b98680 SHA512 2893964f19901af0b18417a271a3418c5adfaa311cd1688c159b86a7bdf68517d53d98a9b2c1a9942c7d2cde8ccb742832fd78c2ab0aa29844d261b9334548ec WHIRLPOOL 7c028fdd13ee0194cedecc7ca1409254b5cfc3f1766c50f87cbd36e9d8e705e603c4cb7d02980b2ad6f35774686560690441b292206ec637bcbe3e9237196315
+DIST xf86-video-dummy-0.3.8.tar.bz2 302353 SHA256 3712bb869307233491e4c570732d6073c0dc3d99adfdb9977396a3fdf84e95b9 SHA512 f534113fd9987e44d2e0d0c53bd1b71be4ba69ec239ecec4aba8fcdcc10597722c54cbc01da38e0975ac7660e4e4028330e4cdd369e755c25ec059d2dfabad80 WHIRLPOOL 623340bdcdefecc239f4b0ff8cf24d9c56c7d8484928f62ce78ae41c8d1af37a24c3be7bb87236e3abe64cd0bc764908bb872d590197366ae26e2063f4790914
diff --git a/x11-drivers/xf86-video-dummy/xf86-video-dummy-0.3.8.ebuild b/x11-drivers/xf86-video-dummy/xf86-video-dummy-0.3.8.ebuild
new file mode 100644
index 000000000000..058b35852f37
--- /dev/null
+++ b/x11-drivers/xf86-video-dummy/xf86-video-dummy-0.3.8.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xorg-2
+
+DESCRIPTION="X.Org driver for dummy cards"
+
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="dga"
+
+RDEPEND=">=x11-base/xorg-server-1.0.99"
+DEPEND="${RDEPEND}
+ dga? (
+ x11-proto/xf86dgaproto
+ )"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable dga)
+ )
+ xorg-2_pkg_setup
+}