summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2017-12-29 13:40:57 -0500
committerMatt Turner <mattst88@gentoo.org>2017-12-29 13:42:24 -0500
commit06f1e7b6cd6831cbf122684a81385790661d7feb (patch)
treef576cf49121cc78854bcb2f01d7adbf5b8425bb3 /x11-libs/cairo
parentapp-text/xiphos: amd64 stable wrt bug #639638 (diff)
downloadgentoo-06f1e7b6cd6831cbf122684a81385790661d7feb.tar.gz
gentoo-06f1e7b6cd6831cbf122684a81385790661d7feb.tar.bz2
gentoo-06f1e7b6cd6831cbf122684a81385790661d7feb.zip
x11-libs/cairo: Drop directfb support
Has been masked since late 2014. Bug: https://bugs.gentoo.org/642516
Diffstat (limited to 'x11-libs/cairo')
-rw-r--r--x11-libs/cairo/cairo-1.14.10.ebuild15
-rw-r--r--x11-libs/cairo/cairo-1.14.12.ebuild15
-rw-r--r--x11-libs/cairo/cairo-1.14.8.ebuild15
-rw-r--r--x11-libs/cairo/cairo-9999.ebuild15
4 files changed, 8 insertions, 52 deletions
diff --git a/x11-libs/cairo/cairo-1.14.10.ebuild b/x11-libs/cairo/cairo-1.14.10.ebuild
index 396118fc0619..a6ea82e1c364 100644
--- a/x11-libs/cairo/cairo-1.14.10.ebuild
+++ b/x11-libs/cairo/cairo-1.14.10.ebuild
@@ -18,7 +18,7 @@ DESCRIPTION="A vector graphics library with cross-device output support"
HOMEPAGE="https://www.cairographics.org"
LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
SLOT="0"
-IUSE="X aqua debug directfb gles2 +glib opengl static-libs +svg valgrind xcb"
+IUSE="X aqua debug gles2 +glib opengl static-libs +svg valgrind xcb"
# gtk-doc regeneration doesn't seem to work with out-of-source builds
#[[ ${PV} == *9999* ]] && IUSE="${IUSE} doc" # API docs are provided in tarball, no need to regenerate
@@ -32,7 +32,6 @@ RDEPEND=">=dev-libs/lzo-2.06-r1[${MULTILIB_USEDEP}]
sys-libs/binutils-libs:0=[${MULTILIB_USEDEP}]
>=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
>=x11-libs/pixman-0.32.4[${MULTILIB_USEDEP}]
- directfb? ( dev-libs/DirectFB )
gles2? ( >=media-libs/mesa-9.1.6[gles2,${MULTILIB_USEDEP}] )
glib? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
opengl? ( >=media-libs/mesa-9.1.6[egl,${MULTILIB_USEDEP}] )
@@ -64,10 +63,6 @@ REQUIRED_USE="
gles2? ( !opengl )
"
-MULTILIB_WRAPPED_HEADERS=(
- /usr/include/cairo/cairo-directfb.h
-)
-
PATCHES=(
"${FILESDIR}"/${PN}-1.12.18-disable-test-suite.patch
"${FILESDIR}"/${PN}-respect-fontconfig.patch
@@ -99,12 +94,6 @@ multilib_src_configure() {
use elibc_FreeBSD && myopts+=" --disable-symbol-lookup"
[[ ${CHOST} == *-darwin* ]] && myopts+=" --disable-symbol-lookup"
- # TODO: remove this (and add USE-dep) when DirectFB is converted,
- # bug #484248 -- but beware of the circular dep.
- if ! multilib_is_native_abi; then
- myopts+=" --disable-directfb"
- fi
-
# TODO: remove this (and add USE-dep) when qtgui is converted, bug #498010
if ! multilib_is_native_abi; then
myopts+=" --disable-qt"
@@ -122,7 +111,6 @@ multilib_src_configure() {
$(use_enable aqua quartz) \
$(use_enable aqua quartz-image) \
$(use_enable debug test-surfaces) \
- $(use_enable directfb) \
$(use_enable gles2 glesv2) \
$(use_enable glib gobject) \
$(use_enable opengl gl) \
@@ -135,6 +123,7 @@ multilib_src_configure() {
--enable-pdf \
--enable-png \
--enable-ps \
+ --disable-directfb \
--disable-drm \
--disable-gallium \
--disable-qt \
diff --git a/x11-libs/cairo/cairo-1.14.12.ebuild b/x11-libs/cairo/cairo-1.14.12.ebuild
index 396118fc0619..1d8b4ec96d4d 100644
--- a/x11-libs/cairo/cairo-1.14.12.ebuild
+++ b/x11-libs/cairo/cairo-1.14.12.ebuild
@@ -18,7 +18,7 @@ DESCRIPTION="A vector graphics library with cross-device output support"
HOMEPAGE="https://www.cairographics.org"
LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
SLOT="0"
-IUSE="X aqua debug directfb gles2 +glib opengl static-libs +svg valgrind xcb"
+IUSE="X aqua debug gles2 +glib opengl static-libs +svg valgrind xcb"
# gtk-doc regeneration doesn't seem to work with out-of-source builds
#[[ ${PV} == *9999* ]] && IUSE="${IUSE} doc" # API docs are provided in tarball, no need to regenerate
@@ -32,7 +32,6 @@ RDEPEND=">=dev-libs/lzo-2.06-r1[${MULTILIB_USEDEP}]
sys-libs/binutils-libs:0=[${MULTILIB_USEDEP}]
>=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
>=x11-libs/pixman-0.32.4[${MULTILIB_USEDEP}]
- directfb? ( dev-libs/DirectFB )
gles2? ( >=media-libs/mesa-9.1.6[gles2,${MULTILIB_USEDEP}] )
glib? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
opengl? ( >=media-libs/mesa-9.1.6[egl,${MULTILIB_USEDEP}] )
@@ -64,10 +63,6 @@ REQUIRED_USE="
gles2? ( !opengl )
"
-MULTILIB_WRAPPED_HEADERS=(
- /usr/include/cairo/cairo-directfb.h
-)
-
PATCHES=(
"${FILESDIR}"/${PN}-1.12.18-disable-test-suite.patch
"${FILESDIR}"/${PN}-respect-fontconfig.patch
@@ -99,12 +94,6 @@ multilib_src_configure() {
use elibc_FreeBSD && myopts+=" --disable-symbol-lookup"
[[ ${CHOST} == *-darwin* ]] && myopts+=" --disable-symbol-lookup"
- # TODO: remove this (and add USE-dep) when DirectFB is converted,
- # bug #484248 -- but beware of the circular dep.
- if ! multilib_is_native_abi; then
- myopts+=" --disable-directfb"
- fi
-
# TODO: remove this (and add USE-dep) when qtgui is converted, bug #498010
if ! multilib_is_native_abi; then
myopts+=" --disable-qt"
@@ -122,7 +111,6 @@ multilib_src_configure() {
$(use_enable aqua quartz) \
$(use_enable aqua quartz-image) \
$(use_enable debug test-surfaces) \
- $(use_enable directfb) \
$(use_enable gles2 glesv2) \
$(use_enable glib gobject) \
$(use_enable opengl gl) \
@@ -136,6 +124,7 @@ multilib_src_configure() {
--enable-png \
--enable-ps \
--disable-drm \
+ --disable-directfb \
--disable-gallium \
--disable-qt \
--disable-vg \
diff --git a/x11-libs/cairo/cairo-1.14.8.ebuild b/x11-libs/cairo/cairo-1.14.8.ebuild
index e36dbac0a735..0d661077e6fd 100644
--- a/x11-libs/cairo/cairo-1.14.8.ebuild
+++ b/x11-libs/cairo/cairo-1.14.8.ebuild
@@ -18,7 +18,7 @@ DESCRIPTION="A vector graphics library with cross-device output support"
HOMEPAGE="https://www.cairographics.org"
LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
SLOT="0"
-IUSE="X aqua debug directfb gles2 +glib opengl static-libs +svg valgrind xcb"
+IUSE="X aqua debug gles2 +glib opengl static-libs +svg valgrind xcb"
# gtk-doc regeneration doesn't seem to work with out-of-source builds
#[[ ${PV} == *9999* ]] && IUSE="${IUSE} doc" # API docs are provided in tarball, no need to regenerate
@@ -32,7 +32,6 @@ RDEPEND=">=dev-libs/lzo-2.06-r1[${MULTILIB_USEDEP}]
sys-libs/binutils-libs:0=[${MULTILIB_USEDEP}]
>=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
>=x11-libs/pixman-0.32.4[${MULTILIB_USEDEP}]
- directfb? ( dev-libs/DirectFB )
gles2? ( >=media-libs/mesa-9.1.6[gles2,${MULTILIB_USEDEP}] )
glib? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
opengl? ( || ( >=media-libs/mesa-9.1.6[egl,${MULTILIB_USEDEP}] media-libs/opengl-apple ) )
@@ -64,10 +63,6 @@ REQUIRED_USE="
gles2? ( !opengl )
"
-MULTILIB_WRAPPED_HEADERS=(
- /usr/include/cairo/cairo-directfb.h
-)
-
PATCHES=(
"${FILESDIR}"/${PN}-1.12.18-disable-test-suite.patch
"${FILESDIR}"/${PN}-respect-fontconfig.patch
@@ -99,12 +94,6 @@ multilib_src_configure() {
use elibc_FreeBSD && myopts+=" --disable-symbol-lookup"
[[ ${CHOST} == *-darwin* ]] && myopts+=" --disable-symbol-lookup"
- # TODO: remove this (and add USE-dep) when DirectFB is converted,
- # bug #484248 -- but beware of the circular dep.
- if ! multilib_is_native_abi; then
- myopts+=" --disable-directfb"
- fi
-
# TODO: remove this (and add USE-dep) when qtgui is converted, bug #498010
if ! multilib_is_native_abi; then
myopts+=" --disable-qt"
@@ -122,7 +111,6 @@ multilib_src_configure() {
$(use_enable aqua quartz) \
$(use_enable aqua quartz-image) \
$(use_enable debug test-surfaces) \
- $(use_enable directfb) \
$(use_enable gles2 glesv2) \
$(use_enable glib gobject) \
$(use_enable opengl gl) \
@@ -136,6 +124,7 @@ multilib_src_configure() {
--enable-png \
--enable-ps \
--disable-drm \
+ --disable-directfb \
--disable-gallium \
--disable-qt \
--disable-vg \
diff --git a/x11-libs/cairo/cairo-9999.ebuild b/x11-libs/cairo/cairo-9999.ebuild
index 9e0f4f744bfa..7f294e891d56 100644
--- a/x11-libs/cairo/cairo-9999.ebuild
+++ b/x11-libs/cairo/cairo-9999.ebuild
@@ -18,7 +18,7 @@ DESCRIPTION="A vector graphics library with cross-device output support"
HOMEPAGE="https://www.cairographics.org"
LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
SLOT="0"
-IUSE="X aqua debug directfb gles2 +glib opengl static-libs +svg utils valgrind xcb"
+IUSE="X aqua debug gles2 +glib opengl static-libs +svg utils valgrind xcb"
# gtk-doc regeneration doesn't seem to work with out-of-source builds
#[[ ${PV} == *9999* ]] && IUSE="${IUSE} doc" # API docs are provided in tarball, no need to regenerate
@@ -32,7 +32,6 @@ RDEPEND="
sys-libs/binutils-libs:0=[${MULTILIB_USEDEP}]
>=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
>=x11-libs/pixman-0.32.4[${MULTILIB_USEDEP}]
- directfb? ( dev-libs/DirectFB )
gles2? ( >=media-libs/mesa-9.1.6[gles2,${MULTILIB_USEDEP}] )
glib? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
opengl? ( >=media-libs/mesa-9.1.6[egl,${MULTILIB_USEDEP}] )
@@ -65,10 +64,6 @@ REQUIRED_USE="
gles2? ( !opengl )
"
-MULTILIB_WRAPPED_HEADERS=(
- /usr/include/cairo/cairo-directfb.h
-)
-
PATCHES=(
"${FILESDIR}"/${PN}-1.12.18-disable-test-suite.patch
"${FILESDIR}"/${PN}-respect-fontconfig.patch
@@ -99,12 +94,6 @@ multilib_src_configure() {
use elibc_FreeBSD && myopts+=" --disable-symbol-lookup"
- # TODO: remove this (and add USE-dep) when DirectFB is converted,
- # bug #484248 -- but beware of the circular dep.
- if ! multilib_is_native_abi; then
- myopts+=" --disable-directfb"
- fi
-
# TODO: remove this (and add USE-dep) when qtgui is converted, bug #498010
if ! multilib_is_native_abi; then
myopts+=" --disable-qt"
@@ -122,7 +111,6 @@ multilib_src_configure() {
$(use_enable aqua quartz) \
$(use_enable aqua quartz-image) \
$(use_enable debug test-surfaces) \
- $(use_enable directfb) \
$(use_enable gles2 glesv2) \
$(use_enable glib gobject) \
$(use_enable opengl gl) \
@@ -139,6 +127,7 @@ multilib_src_configure() {
--enable-png \
--enable-ps \
--disable-drm \
+ --disable-directfb \
--disable-gallium \
--disable-qt \
--disable-vg \