summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/gksu/files/gksu-2.0.2-nautilus-dir.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/gksu/files/gksu-2.0.2-nautilus-dir.patch')
-rw-r--r--x11-libs/gksu/files/gksu-2.0.2-nautilus-dir.patch58
1 files changed, 58 insertions, 0 deletions
diff --git a/x11-libs/gksu/files/gksu-2.0.2-nautilus-dir.patch b/x11-libs/gksu/files/gksu-2.0.2-nautilus-dir.patch
new file mode 100644
index 000000000000..bc21b56c663f
--- /dev/null
+++ b/x11-libs/gksu/files/gksu-2.0.2-nautilus-dir.patch
@@ -0,0 +1,58 @@
+From d7ee2b46dad2070982b035a3136ccbb5787e9ed4 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Sat, 7 Apr 2012 19:39:03 -0400
+Subject: [PATCH] Fix nautilus extensions directory for nautilus-3
+
+The gksu nautilus extension works with both nautilus-2 and nautilus-3,
+so we should not assume that the extension is always installed in
+/usr/lib/nautilus/extensions-2.0
+
+https://savannah.nongnu.org/bugs/index.php?36129
+---
+ configure.ac | 14 +++++++++++++-
+ nautilus-gksu/Makefile.am | 2 +-
+ 2 files changed, 14 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 21d33bb..d65c586 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -64,9 +64,21 @@ AM_CONDITIONAL(GTK_DOC_USE_LIBTOOL, test x$use_libtool = xyes)
+
+ AC_ARG_ENABLE(nautilus-extension, [ --enable-nautilus-extension Build the nautilus extensions module [default=yes]], enable_nautilus_extension="$enableval", enable_nautilus_extension=yes)
+ AM_CONDITIONAL(ENABLE_NAUTILUS_EXTENSION, test x$enable_nautilus_extension = xyes)
++AC_ARG_WITH(nautilus-extensions-dir,
++ AS_HELP_STRING([--with-nautilus-extension-dir=DIR],
++ [Directory where nautilus extensions have to be installed (usually /usr/lib/nautilus/extensions-2.0 or -3.0)]))
+
+ if test x$enable_nautilus_extension = xyes; then
+- PKG_CHECK_MODULES(NAUTILUS, [libgksu2 >= 2.0.0, libnautilus-extension])
++ PKG_CHECK_MODULES(NAUTILUS, [libgksu2 >= 2.0.0, libnautilus-extension])
++ if test "x$with_nautilus_extension_dir" = x; then
++ AC_MSG_CHECKING([for Nautilus extensions directory])
++ with_nautilus_extension_dir=`pkg-config --variable=extensiondir libnautilus-extension`
++ if test "x$with_nautilus_extension_dir" = x; then
++ AC_MSG_ERROR([not found. You can specify the extensions directory manually using --with-nautilus-extension-dir=DIR])
++ fi
++ AC_MSG_RESULT($with_nautilus_extension_dir)
++ fi
++ AC_SUBST(NAUTILUS_EXTENSION_DIR, [$with_nautilus_extensios_dir])
+ fi
+
+ AC_CONFIG_FILES([
+diff --git a/nautilus-gksu/Makefile.am b/nautilus-gksu/Makefile.am
+index 3a70c78..cbe4d00 100644
+--- a/nautilus-gksu/Makefile.am
++++ b/nautilus-gksu/Makefile.am
+@@ -2,7 +2,7 @@ AM_CFLAGS = -g -O2 -Wall
+ INCLUDES = ${NAUTILUS_CFLAGS}
+ AM_CPPFLAGS = -DLOCALEDIR=\"$(datadir)/locale\" -DDATA_DIR=\"$(datadir)\" -DPREFIX=\"$(prefix)\"
+
+-nautilus_extensiondir=$(libdir)/nautilus/extensions-2.0
++nautilus_extensiondir=$(NAUTILUS_EXTENSION_DIR)
+ nautilus_extension_LTLIBRARIES = libnautilus-gksu.la
+ libnautilus_gksu_la_SOURCES = libnautilus-gksu.c
+ libnautilus_gksu_la_LDFLAGS = LDFLAGS = -module -avoid-version -no-undefined
+--
+1.7.8.5
+