summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/gksu/gksu-2.0.2-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/gksu/gksu-2.0.2-r1.ebuild')
-rw-r--r--x11-libs/gksu/gksu-2.0.2-r1.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/x11-libs/gksu/gksu-2.0.2-r1.ebuild b/x11-libs/gksu/gksu-2.0.2-r1.ebuild
new file mode 100644
index 000000000000..127fe6a078e6
--- /dev/null
+++ b/x11-libs/gksu/gksu-2.0.2-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2 fixheadtails
+
+DESCRIPTION="A gtk+ frontend for libgksu"
+HOMEPAGE="http://www.nongnu.org/gksu/"
+SRC_URI="http://people.debian.org/~kov/gksu/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd"
+IUSE="doc gnome"
+
+RDEPEND=">=x11-libs/libgksu-2.0.8
+ >=x11-libs/gtk+-2.4:2
+ >=gnome-base/gconf-2
+ gnome? (
+ >=gnome-base/nautilus-2
+ x11-terms/gnome-terminal )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+ G2CONF="${G2CONF}
+ --disable-static
+ $(use_enable gnome nautilus-extension)"
+}
+
+src_prepare() {
+ ht_fix_file "${S}/gksu-migrate-conf.sh"
+
+ # https://savannah.nongnu.org/bugs/index.php?36127
+ epatch "${FILESDIR}/${PN}-2.0.2-glib-2.31.patch"
+
+ if use gnome ; then
+ sed 's/x-terminal-emulator/gnome-terminal/' \
+ -i gksu.desktop || die "sed 1 failed"
+
+ # Conditional patch to avoid eautoreconf
+ # https://savannah.nongnu.org/bugs/index.php?36129
+ epatch "${FILESDIR}/${PN}-2.0.2-nautilus-dir.patch"
+
+ sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die #467024
+ eautoreconf
+ else
+ sed 's/dist_desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)/dist_desktop_DATA =/' \
+ -i Makefile.am Makefile.in || die "sed 2 failed"
+ fi
+
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+ chmod +x "${D}/usr/share/gksu/gksu-migrate-conf.sh"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ einfo 'updating configuration'
+ "${ROOT}"/usr/share/gksu/gksu-migrate-conf.sh
+ einfo ""
+ einfo "A note on gksudo: It actually runs sudo to get it's work done"
+ einfo "However, by default, Gentoo's sudo wipes your environment."
+ einfo "This means that gksudo will fail to run any X-based programs."
+ einfo "You need to either add yourself to wheel and uncomment this line"
+ einfo "in your /etc/sudoers:"
+ einfo "Defaults:%wheel !env_reset"
+ einfo "Or remove the env_reset line entirely. This can cause security"
+ einfo "problems; if you don't trust your users, don't do this, use gksu"
+ einfo "instead."
+}