summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/gtk+extra/files/gtk+extra-3.0.1-fix-configure.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/gtk+extra/files/gtk+extra-3.0.1-fix-configure.patch')
-rw-r--r--x11-libs/gtk+extra/files/gtk+extra-3.0.1-fix-configure.patch173
1 files changed, 173 insertions, 0 deletions
diff --git a/x11-libs/gtk+extra/files/gtk+extra-3.0.1-fix-configure.patch b/x11-libs/gtk+extra/files/gtk+extra-3.0.1-fix-configure.patch
new file mode 100644
index 000000000000..1aa60d27aa75
--- /dev/null
+++ b/x11-libs/gtk+extra/files/gtk+extra-3.0.1-fix-configure.patch
@@ -0,0 +1,173 @@
+--- configure.in 2011/05/01 09:17:38 1.14
++++ configure.in 2011/11/26 10:39:19 1.15
+@@ -1,4 +1,13 @@
+ # Process this file with autoconf to produce a configure script.
++#
++# Help for autoconf:
++# - http://www.linuxselfhelp.com/gnu/autoconf/html_chapter/autoconf_toc.html
++# Option Syntax:
++# - http://www.linuxselfhelp.com/gnu/autoconf/html_chapter/autoconf_12.html
++# Printing Messages:
++# - http://www.linuxselfhelp.com/gnu/autoconf/html_chapter/autoconf_7.html
++#
++
+ AC_INIT(gtkextra,3.0.1)
+ AC_LANG([C])
+
+@@ -109,12 +118,15 @@
+ AM_CONDITIONAL(MS_LIB_AVAILABLE, test x$ms_librarian = xyes)
+
+ # --enable-debug option
+-dnl Check if we have enable debug support.
+-AC_MSG_CHECKING(whether to enable debugging)
+-debug_default="no"
++
++AC_MSG_CHECKING([whether to enable debugging])
++
+ AC_ARG_ENABLE(debug,
+- [ --enable-debug=[no/yes] turn on debugging [default=no]],,
+- enable_debug=$debug_default)
++ AC_HELP_STRING(
++ [--enable-debug=[no/yes]],
++ [turn on debugging [default=no]]),
++ ,
++ enable_debug=no)
+
+ if test "x$enable_debug" = "xyes"; then
+ test "$cflags_set" = set || CFLAGS="$CFLAGS -g -DDEBUG"
+@@ -237,31 +249,57 @@
+
+ # --enable-man option
+
++AC_MSG_CHECKING([whether to enable man pages])
++
+ AC_ARG_ENABLE(man,
+- [AC_HELP_STRING([--enable-man],
+- [regenerate man pages from Docbook [default=no]])],enable_man=yes,
+- enable_man=no)
++ AC_HELP_STRING(
++ [--enable-man],
++ [regenerate man pages from Docbook [default=no]])],
++ ,
++ enable_man=no)
+
+ if test "${enable_man}" != no; then
+- dnl
+- dnl Check for xsltproc
+- dnl
+- AC_PATH_PROG([XSLTPROC], [xsltproc])
+- if test -z "$XSLTPROC"; then
+- enable_man=no
+- fi
++ AC_MSG_RESULT(yes)
+
+- dnl check for DocBook DTD and stylesheets in the local catalog.
+- JH_CHECK_XML_CATALOG([-//OASIS//DTD DocBook XML V4.1.2//EN],
+- [DocBook XML DTD V4.1.2],,enable_man=no)
+- JH_CHECK_XML_CATALOG([http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl],
+- [DocBook XSL Stylesheets],,enable_man=no)
++ AC_PATH_PROG([XSLTPROC], [xsltproc])
++ if test -z "$XSLTPROC"; then
++ enable_man=no
++ fi
++
++ if test "$enable_man" = "no" ; then
++ AC_MSG_WARN([xsltproc is missing - disabling man pages])
++ fi
++
++ #check for DocBook DTD and stylesheets in the local catalog
++
++ JH_CHECK_XML_CATALOG(
++ [-//OASIS//DTD DocBook XML V4.1.2//EN],
++ [DocBook XML DTD V4.1.2],
++ ,
++ enable_man=no)
++
++ if test "$enable_man" = "no" ; then
++ AC_MSG_WARN([missing DocBook DTD - disabling man pages])
++ fi
++
++ JH_CHECK_XML_CATALOG(
++ [http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl],
++ [DocBook XSL Stylesheets],
++ ,
++ enable_man=no)
++
++ if test "$enable_man" = "no" ; then
++ AC_MSG_WARN([missing DocBook XML stylesheets - disabling man pages])
++ fi
++else
++ AC_MSG_RESULT(no)
+ fi
+ AM_CONDITIONAL(ENABLE_MAN, test x$enable_man != xno)
+
+-dnl
+-dnl Start of pkg-config checks
+-dnl
++
++##################################################
++# Start of pkg-config checks
++##################################################
+
+ PKG_PROG_PKG_CONFIG
+
+@@ -275,13 +313,18 @@
+
+ # --enable-glade option
+
++AC_MSG_CHECKING([whether to enable glade integration])
++
+ AC_ARG_ENABLE(glade,
+- [AC_HELP_STRING([--enable-glade],
+- [build glade integration files [default=no]])],
+- enable_glade=yes,
++ AC_HELP_STRING(
++ [--enable-glade],
++ [build glade integration files [default=no]]),
++ ,
+ enable_glade=no)
+
+ if test "x$enable_glade" != xno; then
++ AC_MSG_RESULT(yes)
++
+ PKG_CHECK_MODULES([GLADE], [gladeui-1.0 >= 3.6])
+
+ AC_SUBST(GLADE_CATALOG_DIR, `$PKG_CONFIG --variable=catalogdir gladeui-1.0`)
+@@ -290,24 +333,32 @@
+
+ #You must define GETTEXT_PACKAGE before including gi18n-lib.h
+ GETTEXT_PACKAGE=AC_PACKAGE_NAME
+- AC_SUBST(GETTEXT_PACKAGE)
+- AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [Name of the gettext package.])
++ AC_SUBST(GETTEXT_PACKAGE)
++ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE",
++ [Name of the gettext package.])
+ AM_GLIB_GNU_GETTEXT
++else
++ AC_MSG_RESULT(no)
+ fi
+ AM_CONDITIONAL(ENABLE_GLADE, test x$enable_glade != xno)
+
+
+ # --enable-introspection
+
++AC_MSG_CHECKING([whether to enable gobject-introspection])
++
+ AC_ARG_ENABLE(introspection,
+- [AC_HELP_STRING([--enable-introspection],
+- [build gobject-introspection [default=no]])],
+- enable_introspection=yes,
++ AC_HELP_STRING(
++ [--enable-introspection],
++ [build gobject-introspection [default=no]]),
++ ,
+ enable_introspection=no)
+
+ if test "x$enable_introspection" != xno; then
++ AC_MSG_RESULT(yes)
+ GOBJECT_INTROSPECTION_CHECK([0.6.14])
+ else
++ AC_MSG_RESULT(no)
+ AM_CONDITIONAL(HAVE_INTROSPECTION, test 1=0)
+ fi
+ AM_CONDITIONAL(ENABLE_INTROSPECTION, test x$enable_introspection != xno)