summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2016-08-12 12:19:40 -0600
committerDenis Dupeyron <calchan@gentoo.org>2016-08-12 12:20:10 -0600
commit62f5c51b744d94f8d5b2e07166a18dd192c0c9c9 (patch)
treee3583ca6ebfef160426cace16aec72468a6403d0 /x11-libs/guile-gtk/guile-gtk-2.1-r3.ebuild
parentmate-extra/mate-power-manager: Drop dependency on gtk3 for mate-polkit (diff)
downloadgentoo-62f5c51b744d94f8d5b2e07166a18dd192c0c9c9.tar.gz
gentoo-62f5c51b744d94f8d5b2e07166a18dd192c0c9c9.tar.bz2
gentoo-62f5c51b744d94f8d5b2e07166a18dd192c0c9c9.zip
x11-libs/guile-gtk: fix bugs #577630 and #590786.
Package-Manager: portage-2.3.0
Diffstat (limited to 'x11-libs/guile-gtk/guile-gtk-2.1-r3.ebuild')
-rw-r--r--x11-libs/guile-gtk/guile-gtk-2.1-r3.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/x11-libs/guile-gtk/guile-gtk-2.1-r3.ebuild b/x11-libs/guile-gtk/guile-gtk-2.1-r3.ebuild
new file mode 100644
index 000000000000..c24b3ad3a087
--- /dev/null
+++ b/x11-libs/guile-gtk/guile-gtk-2.1-r3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+WANT_AUTOMAKE=1.9
+
+inherit autotools-utils virtualx
+
+DESCRIPTION="GTK+ bindings for guile"
+HOMEPAGE="https://www.gnu.org/software/guile-gtk/"
+SRC_URI="mirror://gnu/guile-gtk/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=dev-scheme/guile-2[deprecated(+)]
+ x11-libs/gtk+:2
+ gnome-base/libglade:2.0
+ >=x11-libs/gtkglarea-1.90:2"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0-g-object-ref.diff
+ "${FILESDIR}"/${PV}-prll-install.patch
+ "${FILESDIR}"/${PV}-brokentest.patch
+ "${FILESDIR}"/${PV}_migrate_gh_functions.patch
+)
+
+src_prepare() {
+ sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac || die
+ autotools-utils_src_prepare
+}
+
+src_test() {
+ cd "${BUILD_DIR}" || die
+ Xemake check
+}
+
+src_install() {
+ autotools-utils_src_install
+ insinto /usr/share/doc/${PF}/
+ doins -r examples
+}