summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/libXaw3dXft
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/libXaw3dXft')
-rw-r--r--x11-libs/libXaw3dXft/Manifest2
-rw-r--r--x11-libs/libXaw3dXft/libXaw3dXft-1.6.2c.ebuild37
-rw-r--r--x11-libs/libXaw3dXft/libXaw3dXft-1.6.2d.ebuild37
-rw-r--r--x11-libs/libXaw3dXft/metadata.xml10
4 files changed, 86 insertions, 0 deletions
diff --git a/x11-libs/libXaw3dXft/Manifest b/x11-libs/libXaw3dXft/Manifest
new file mode 100644
index 000000000000..e7d88794e018
--- /dev/null
+++ b/x11-libs/libXaw3dXft/Manifest
@@ -0,0 +1,2 @@
+DIST libXaw3dXft-1.6.2c.tar.bz2 574326 SHA256 12fed1c4f71b12a7fe51ff2859ecf0c9dfb4c828f8bedfbde186fa6498285a9d SHA512 4bc2b8257cc44cbdf1640c9946acd5958694beef4af9f5910cf07b1d32133708561e59532a3ae8f1540b930f97649978910b2eed349e81486ab86f340363faad WHIRLPOOL 9a9df5a5ae37c22a1507d6dfbe062e8b135a9380773c07d337520f00c5423473e856e80113138d182ccc918c5faf21abc1a3555ffdbed9979169f85327fedba6
+DIST libXaw3dXft-1.6.2d.tar.bz2 584670 SHA256 c0ef54c2f40484507c3b7b4df3102b5284d258fde9557de0c417e89ba7f176fe SHA512 ac434b7f055d20ceb0bd17851d8ba69976ec562a60cb8012a259045e52c038278f0a8b25b52a61befab3aa169b74fd919278c671f1b6e282efb404e089772740 WHIRLPOOL bfeb4c0a169ce0ddbf9aeaec55b3dec964e5a273128a7831e9afee7b2763ca44f18d31432a61a57053abae63c87537f0f7ba530bc51fa2b8a40ef1a1df597b55
diff --git a/x11-libs/libXaw3dXft/libXaw3dXft-1.6.2c.ebuild b/x11-libs/libXaw3dXft/libXaw3dXft-1.6.2c.ebuild
new file mode 100644
index 000000000000..a2006c56eb27
--- /dev/null
+++ b/x11-libs/libXaw3dXft/libXaw3dXft-1.6.2c.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit xorg-2
+
+DESCRIPTION="Xaw3dXft library"
+HOMEPAGE="http://sourceforge.net/projects/sf-xpaint"
+SRC_URI="mirror://sourceforge/sf-xpaint/${P}.tar.bz2"
+
+KEYWORDS="amd64 x86"
+IUSE="unicode xpm"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXft
+ x11-libs/libXmu
+ x11-libs/libXt
+ xpm? ( x11-libs/libXpm )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/yacc
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable unicode internationalization)
+ $(usex xpm "--enable-multiplane-bitmaps" "")
+ --enable-arrow-scrollbars
+ --enable-gray-stipples
+ )
+
+ xorg-2_pkg_setup
+}
diff --git a/x11-libs/libXaw3dXft/libXaw3dXft-1.6.2d.ebuild b/x11-libs/libXaw3dXft/libXaw3dXft-1.6.2d.ebuild
new file mode 100644
index 000000000000..6dc774446722
--- /dev/null
+++ b/x11-libs/libXaw3dXft/libXaw3dXft-1.6.2d.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit xorg-2
+
+DESCRIPTION="Xaw3dXft library"
+HOMEPAGE="http://sourceforge.net/projects/sf-xpaint"
+SRC_URI="mirror://sourceforge/sf-xpaint/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="unicode xpm"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXft
+ x11-libs/libXmu
+ x11-libs/libXt
+ xpm? ( x11-libs/libXpm )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/yacc
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable unicode internationalization)
+ $(usex xpm "--enable-multiplane-bitmaps" "")
+ --enable-arrow-scrollbars
+ --enable-gray-stipples
+ )
+
+ xorg-2_pkg_setup
+}
diff --git a/x11-libs/libXaw3dXft/metadata.xml b/x11-libs/libXaw3dXft/metadata.xml
new file mode 100644
index 000000000000..402a82e8c6df
--- /dev/null
+++ b/x11-libs/libXaw3dXft/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">sf-xpaint</remote-id>
+ </upstream>
+</pkgmetadata>