summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/libdockapp/libdockapp-0.6.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/libdockapp/libdockapp-0.6.1.ebuild')
-rw-r--r--x11-libs/libdockapp/libdockapp-0.6.1.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/x11-libs/libdockapp/libdockapp-0.6.1.ebuild b/x11-libs/libdockapp/libdockapp-0.6.1.ebuild
new file mode 100644
index 000000000000..f0cb22a23972
--- /dev/null
+++ b/x11-libs/libdockapp/libdockapp-0.6.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils autotools
+
+IUSE=""
+
+DESCRIPTION="Window Maker Dock Applet Library"
+SRC_URI="http://solfertje.student.utwente.nl/~dalroi/libdockapp/files/${P}.tar.bz2"
+HOMEPAGE="http://solfertje.student.utwente.nl/~dalroi/libdockapp/"
+
+LICENSE="MIT public-domain"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+S=${WORKDIR}/${P/lib/}
+FONTDIR="/usr/share/fonts/${PN}-fonts"
+
+src_unpack()
+{
+ unpack ${A}
+ cd "${S}"
+
+ # sanitize fonts installation path
+ epatch "${FILESDIR}/install-paths.patch-${PV}"
+
+ # add legacy support for older dockapps
+ epatch "${FILESDIR}/legacy.patch-${PV}"
+
+ eautoreconf
+}
+
+src_install()
+{
+ make \
+ DESTDIR="${D}" \
+ SHAREDIR="${D}/usr/share/doc/${PF}/examples/" \
+ install || die "make install failed"
+
+ dodoc README ChangeLog NEWS AUTHORS
+}
+
+pkg_postinst()
+{
+ einfo
+ einfo "You need to add following line into 'Section \"Files\"' in"
+ einfo "/etc/X11/xorg.conf (or /etc/X11/XF86Config if you are still using XFree86)"
+ einfo "and reboot X Window System, to use these fonts."
+ einfo
+ einfo "\t FontPath \"${FONTDIR}\""
+ einfo
+ einfo "You also need to add the following line to /etc/fonts/local.conf"
+ einfo
+ einfo "\t <dir>${FONTDIR}</dir>"
+ einfo
+}
+
+pkg_postrm()
+{
+ einfo
+ einfo "You need to remove following line from 'Section \"Files\"' in"
+ einfo "/etc/X11/xorg.conf (or /etc/X11/XF86Config if you are still using XFree86)"
+ einfo "to unmerge this package completely."
+ einfo
+ einfo "\t FontPath \"${FONTDIR}\""
+ einfo
+ einfo "You also need to remove the following line from /etc/fonts/local.conf"
+ einfo
+ einfo "\t <dir>${FONTDIR}</dir>"
+ einfo
+}