summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2017-10-20 17:12:36 -0700
committerMatt Turner <mattst88@gentoo.org>2017-10-20 17:14:02 -0700
commitc105269d30758f8a2c849e994996f9d0da28fa47 (patch)
treed2f51f0617123b67fccbfbc6892440bb461acd8c /x11-libs/libdrm
parentnet-vpn/wireguard: include headers for happy building (diff)
downloadgentoo-c105269d30758f8a2c849e994996f9d0da28fa47.tar.gz
gentoo-c105269d30758f8a2c849e994996f9d0da28fa47.tar.bz2
gentoo-c105269d30758f8a2c849e994996f9d0da28fa47.zip
x11-libs/libdrm: Version bump to 2.4.85
Diffstat (limited to 'x11-libs/libdrm')
-rw-r--r--x11-libs/libdrm/Manifest1
-rw-r--r--x11-libs/libdrm/libdrm-2.4.85.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/x11-libs/libdrm/Manifest b/x11-libs/libdrm/Manifest
index 0e4f994c3444..2f203cfdbcda 100644
--- a/x11-libs/libdrm/Manifest
+++ b/x11-libs/libdrm/Manifest
@@ -4,3 +4,4 @@ DIST libdrm-2.4.80.tar.bz2 771243 SHA256 a82a519601e9cdfad795e760807eb07ac8913b2
DIST libdrm-2.4.81.tar.bz2 786276 SHA256 8cc05c195ac8708199979a94c4e4d1a928c14ec338ecbcb38ead09f54dae11ae SHA512 5f7a1524acad59890d3f890bed90a660a424e18a88d587ca356223bde4a7446d1c540f97ec11cb10d2e7ed1b4ae86127957634354a1be6d04199295ab24782e5 WHIRLPOOL 2694fe988c7ebf34b30076a10dcb2d5ba8a24ddddb1ad348da69874814d64e78ad48f959275faa02fabd798ae214f386ef8437bdf48d485f77519b8759d695df
DIST libdrm-2.4.82.tar.bz2 754053 SHA256 43fa2dbd422d6d41ac141272cc9855360ce4d08c7cf7f2c7bb55dfe449c4ce1c SHA512 e69fd8c2b392daabbb3a548179e3a21a555d5174c11d76a288eb2a08850849aa867c7777b67798ec00e026e998a3b128c22698f05a7b44eb24cddc5c8a3a02d0 WHIRLPOOL bf600559faf5ffe45b6f0192a561875e5284ea76d7611724c2e7f21e6f8aaa6d2e368546102170cffb713bb37fc4c5f98a08b6828e4f6f48f774d7b9b9d96906
DIST libdrm-2.4.84.tar.bz2 794348 SHA256 7ae9c24d91139ac9a2cdee06fe46dbe1c401a1eda1c0bd2a6d1ecf72f479e0aa SHA512 860ebc5fa934edee97e9e7e13aaa2f2e70a68b946f4f3893cd7f93b8296c10b3cd4ce4c23b1676eefe375286e6e2292b96e917d7976f65c61da3fa661e5e641a WHIRLPOOL 8984374145694034626d6ccd15d72123989f5e8a127922dd0be5ae26866f8ef9179617689bc75d9a9170bbc55419c7cb2762363e700e91291a78dfb7df740dc9
+DIST libdrm-2.4.85.tar.bz2 795471 SHA256 64e4cd87eaee38ae60b2984ef02b66159b9bdd33030040db2a04339cf15f6173 SHA512 c13b266ca2efd28506b9910306db4be378537dc13229b4d4d8f525e224d0f6a2a9ce326b9ae37dae1d716ae81c9c3bcc88d875104d567899e5854da3c63aa147 WHIRLPOOL ed8f0edf717a09d78d2a2c9d33e806d1eea024a0357c68df5aac684de8587f0ddc437bf03be078062600c0d9d7cee1b4bf8af625f1cea5155b2a6d621d803c52
diff --git a/x11-libs/libdrm/libdrm-2.4.85.ebuild b/x11-libs/libdrm/libdrm-2.4.85.ebuild
new file mode 100644
index 000000000000..b8477e723d2a
--- /dev/null
+++ b/x11-libs/libdrm/libdrm-2.4.85.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org libdrm library"
+HOMEPAGE="https://dri.freedesktop.org/"
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/mesa/drm.git"
+else
+ SRC_URI="https://dri.freedesktop.org/libdrm/${P}.tar.bz2"
+fi
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+VIDEO_CARDS="amdgpu exynos freedreno intel nouveau omap radeon tegra vc4 vivante vmware"
+for card in ${VIDEO_CARDS}; do
+ IUSE_VIDEO_CARDS+=" video_cards_${card}"
+done
+
+IUSE="${IUSE_VIDEO_CARDS} libkms valgrind"
+RESTRICT="test" # see bug #236845
+
+RDEPEND=">=dev-libs/libpthread-stubs-0.3-r1:=[${MULTILIB_USEDEP}]
+ video_cards_intel? ( >=x11-libs/libpciaccess-0.13.1-r1:=[${MULTILIB_USEDEP}] )
+ abi_x86_32? ( !app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ valgrind? ( dev-util/valgrind )"
+
+src_prepare() {
+ if [[ ${PV} = 9999* ]]; then
+ # tests are restricted, no point in building them
+ sed -ie 's/tests //' "${S}"/Makefile.am
+ fi
+ xorg-2_src_prepare
+ epatch_user
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ # Udev is only used by tests now.
+ --disable-udev
+ --disable-cairo-tests
+ $(use_enable video_cards_amdgpu amdgpu)
+ $(use_enable video_cards_exynos exynos-experimental-api)
+ $(use_enable video_cards_freedreno freedreno)
+ $(use_enable video_cards_intel intel)
+ $(use_enable video_cards_nouveau nouveau)
+ $(use_enable video_cards_omap omap-experimental-api)
+ $(use_enable video_cards_radeon radeon)
+ $(use_enable video_cards_tegra tegra-experimental-api)
+ $(use_enable video_cards_vc4 vc4)
+ $(use_enable video_cards_vivante etnaviv-experimental-api)
+ $(use_enable video_cards_vmware vmwgfx)
+ $(use_enable libkms)
+ # valgrind installs its .pc file to the pkgconfig for the primary arch
+ --enable-valgrind=$(usex valgrind auto no)
+ )
+
+ xorg-2_src_configure
+}