summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-09-08 07:19:38 +0200
committerJeroen Roovers <jer@gentoo.org>2015-09-08 07:19:38 +0200
commitde482196e41bb1b213c24f5486e40c2aa57a18f0 (patch)
tree8f0aede074055e0bc5a0713f1cdde5a9322d8c6f /x11-libs/libvdpau/libvdpau-1.1.1.ebuild
parentx11-misc/rofi: Version bump. (diff)
downloadgentoo-de482196e41bb1b213c24f5486e40c2aa57a18f0.tar.gz
gentoo-de482196e41bb1b213c24f5486e40c2aa57a18f0.tar.bz2
gentoo-de482196e41bb1b213c24f5486e40c2aa57a18f0.zip
x11-libs/libvdpau: Version bump.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'x11-libs/libvdpau/libvdpau-1.1.1.ebuild')
-rw-r--r--x11-libs/libvdpau/libvdpau-1.1.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/x11-libs/libvdpau/libvdpau-1.1.1.ebuild b/x11-libs/libvdpau/libvdpau-1.1.1.ebuild
new file mode 100644
index 000000000000..b4e4e7471167
--- /dev/null
+++ b/x11-libs/libvdpau/libvdpau-1.1.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+VIRTUALX_REQUIRED="test"
+inherit autotools-multilib virtualx
+
+DESCRIPTION="VDPAU wrapper and trace libraries"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/VDPAU"
+SRC_URI="http://people.freedesktop.org/~aplattner/vdpau/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="doc dri"
+
+RDEPEND=">=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ dri? ( >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}] )
+ !=x11-drivers/nvidia-drivers-180*
+ !=x11-drivers/nvidia-drivers-185*
+ !=x11-drivers/nvidia-drivers-190*
+ abi_x86_32? ( !app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ virtual/latex-base
+ )
+ dri? ( >=x11-proto/dri2proto-2.2 )"
+
+src_configure() {
+ local myeconfargs=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable doc documentation)
+ $(use dri || echo --disable-dri2)
+ )
+
+ autotools-multilib_src_configure
+}
+
+multilib_src_test() {
+ Xemake check
+}
+
+src_install() {
+ autotools-multilib_src_install
+ prune_libtool_files --modules
+}