summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/mx/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/mx/files')
-rw-r--r--x11-libs/mx/files/mx-1.4.2-gold.patch30
-rw-r--r--x11-libs/mx/files/mx-1.4.7-gl-types.patch53
2 files changed, 83 insertions, 0 deletions
diff --git a/x11-libs/mx/files/mx-1.4.2-gold.patch b/x11-libs/mx/files/mx-1.4.2-gold.patch
new file mode 100644
index 000000000000..0dc1a0f60afa
--- /dev/null
+++ b/x11-libs/mx/files/mx-1.4.2-gold.patch
@@ -0,0 +1,30 @@
+ mx/Makefile.am | 2 +-
+ mx/Makefile.in | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/mx/Makefile.am b/mx/Makefile.am
+index 0e5a61e..4f2b4a4 100644
+--- a/mx/Makefile.am
++++ b/mx/Makefile.am
+@@ -268,7 +268,7 @@ libmx_@MX_API_VERSION@_la_SOURCES = \
+ $(top_srcdir)/mx/mx.h \
+ $(NULL)
+
+-libmx_@MX_API_VERSION@_la_LIBADD = $(MX_LIBS)
++libmx_@MX_API_VERSION@_la_LIBADD = $(MX_LIBS) -lm
+
+ if HAVE_INTROSPECTION
+ -include $(INTROSPECTION_MAKEFILE)
+diff --git a/mx/Makefile.in b/mx/Makefile.in
+index 2fbf938..adfc59d 100644
+--- a/mx/Makefile.in
++++ b/mx/Makefile.in
+@@ -717,7 +717,7 @@ libmx_@MX_API_VERSION@_la_SOURCES = \
+ $(top_srcdir)/mx/mx.h \
+ $(NULL)
+
+-libmx_@MX_API_VERSION@_la_LIBADD = $(MX_LIBS)
++libmx_@MX_API_VERSION@_la_LIBADD = $(MX_LIBS) -lm
+ @HAVE_INTROSPECTION_TRUE@INTROSPECTION_GIRS = Mx-@MX_API_VERSION@.gir
+ @HAVE_INTROSPECTION_TRUE@Mx_@MX_API_VERSION_AM@_gir_NAMESPACE = Mx
+ @HAVE_INTROSPECTION_TRUE@Mx_@MX_API_VERSION_AM@_gir_VERSION = @MX_API_VERSION@
diff --git a/x11-libs/mx/files/mx-1.4.7-gl-types.patch b/x11-libs/mx/files/mx-1.4.7-gl-types.patch
new file mode 100644
index 000000000000..85c691378d84
--- /dev/null
+++ b/x11-libs/mx/files/mx-1.4.7-gl-types.patch
@@ -0,0 +1,53 @@
+From 297b654133436c6ee5146fce31529da4e52dfe74 Mon Sep 17 00:00:00 2001
+From: Brian Pepple <bpepple@fedoraproject.org>
+Date: Sat, 25 Aug 2012 17:41:59 -0400
+Subject: [PATCH] Replace GL data types with equivalent glib types.
+
+---
+ mx/mx-deform-texture.c | 8 ++++----
+ mx/mx-texture-frame.c | 2 +-
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/mx/mx-deform-texture.c b/mx/mx-deform-texture.c
+index 93c54d7..466cc9f 100644
+--- a/mx/mx-deform-texture.c
++++ b/mx/mx-deform-texture.c
+@@ -493,9 +493,9 @@ mx_deform_texture_class_init (MxDeformTextureClass *klass)
+ static void
+ mx_deform_texture_init_arrays (MxDeformTexture *self)
+ {
+- GLushort *idx, *bf_idx;
++ gushort *idx, *bf_idx;
+ gint x, y, direction;
+- GLushort *static_indices, *static_bf_indices;
++ gushort *static_indices, *static_bf_indices;
+ MxDeformTexturePrivate *priv = self->priv;
+
+ mx_deform_texture_free_arrays (self);
+@@ -503,8 +503,8 @@ mx_deform_texture_init_arrays (MxDeformTexture *self)
+ priv->n_indices = (2 + 2 * priv->tiles_x) *
+ priv->tiles_y +
+ (priv->tiles_y - 1);
+- static_indices = g_new (GLushort, priv->n_indices);
+- static_bf_indices = g_new (GLushort, priv->n_indices);
++ static_indices = g_new (gushort, priv->n_indices);
++ static_bf_indices = g_new (gushort, priv->n_indices);
+
+ #define MESH_INDEX(X, Y) (Y) * (priv->tiles_x + 1) + (X)
+
+diff --git a/mx/mx-texture-frame.c b/mx/mx-texture-frame.c
+index bde57ff..a88985f 100644
+--- a/mx/mx-texture-frame.c
++++ b/mx/mx-texture-frame.c
+@@ -200,7 +200,7 @@ mx_texture_frame_paint (ClutterActor *self)
+
+
+ {
+- GLfloat rectangles[] =
++ gfloat rectangles[] =
+ {
+ /* top left corner */
+ 0, 0,
+--
+1.7.12
+