summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-01-29 04:09:17 +1100
committerMichael Palimaka <kensington@gentoo.org>2016-01-29 04:09:33 +1100
commitaf3fb6e5c4b6a26bc87f05ef27e16a8966671b84 (patch)
treeeecfd33068c1f715db03aca1a358ca3c7fc74c98 /x11-libs/snorenotify/snorenotify-0.7.0.ebuild
parentkde-apps/kdepimlibs: avoid false warning about missing NEEDED (diff)
downloadgentoo-af3fb6e5c4b6a26bc87f05ef27e16a8966671b84.tar.gz
gentoo-af3fb6e5c4b6a26bc87f05ef27e16a8966671b84.tar.bz2
gentoo-af3fb6e5c4b6a26bc87f05ef27e16a8966671b84.zip
x11-libs/snorenotify: version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'x11-libs/snorenotify/snorenotify-0.7.0.ebuild')
-rw-r--r--x11-libs/snorenotify/snorenotify-0.7.0.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/x11-libs/snorenotify/snorenotify-0.7.0.ebuild b/x11-libs/snorenotify/snorenotify-0.7.0.ebuild
new file mode 100644
index 000000000000..9980b28a5f62
--- /dev/null
+++ b/x11-libs/snorenotify/snorenotify-0.7.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils gnome2-utils virtualx
+
+DESCRIPTION="Multi platform Qt notification framework"
+HOMEPAGE="https://techbase.kde.org/Projects/Snorenotify"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="sound test"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwebsockets:5
+ dev-qt/qtwidgets:5
+ sound? ( dev-qt/qtmultimedia:5 )
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ kde-frameworks/extra-cmake-modules
+ test? ( dev-qt/qttest:5 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package sound Qt5Multimedia)
+ $(cmake-utils_use_find_package test Qt5Test)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_test() {
+ virtx cmake-utils_src_test
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}