summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-02-27 14:45:43 -0500
committerMatt Turner <mattst88@gentoo.org>2021-02-27 14:55:43 -0500
commit5acd2dca8ee36b9d959be1d942a4f83c340af96a (patch)
treeb64ad20a0bbfde62b38a007d0c91c2e78280820e /x11-libs/vte
parentnet-libs/libyang: drop old (diff)
downloadgentoo-5acd2dca8ee36b9d959be1d942a4f83c340af96a.tar.gz
gentoo-5acd2dca8ee36b9d959be1d942a4f83c340af96a.tar.bz2
gentoo-5acd2dca8ee36b9d959be1d942a4f83c340af96a.zip
x11-libs/vte: Version bump to 0.62.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/vte')
-rw-r--r--x11-libs/vte/Manifest1
-rw-r--r--x11-libs/vte/vte-0.62.3.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/x11-libs/vte/Manifest b/x11-libs/vte/Manifest
index 9afeca85de41..7d4dd7e110e3 100644
--- a/x11-libs/vte/Manifest
+++ b/x11-libs/vte/Manifest
@@ -4,3 +4,4 @@ DIST vte-0.60.3.tar.xz 535504 BLAKE2B c5556fdb91d876aa681d2a9466fa4f4c0ee6be630d
DIST vte-0.62.1-command-notify.patch.xz 4844 BLAKE2B 22301fdc5f1969beb2ad9b316fea8972f696f0e54e1a24d5eceedec71162afc2991b7963a71ce8925a94f6c40e5303d3db760b872d0eebbdc6d05b22d3c59ecc SHA512 491e241b0f5aae50e59d25751e95579d40c47e7e4c7f2b279522347f7f2f7f00c92bdf5fa4a651e4146bcfa9439f03b6311b4061fb20c5679c09b97a4924dcf1
DIST vte-0.62.1.tar.xz 444672 BLAKE2B 83cf49c8700792a149d572bae692d4909ada613b43a752b55cb658926dc37041b98d69364a88f813b1cc6d20f0667ea566f994e0f08bd1dd918731d20edb1376 SHA512 2f8f76953e0ea6c604357ab08630d3822a252051d8997cf7714553fec1688735468726bfd74e03f122dd1c8d0717e511ec7ec1e5463a086bd407afc6f7df91cf
DIST vte-0.62.2.tar.xz 444888 BLAKE2B 07a9d302b3fe67fbc149f129da9e7482f516f3d8fb550bfcd2ddea000f059a24184e857b9f7c4c69c751e40a2b53c044d8596c990b722a22fa13b810a353414c SHA512 61ea130d43d60531dcaa8bddfecacfd4a934a2e868da69b598fad0a2feb04885fc0b5dd520dac4b0d3a4daf11ea70c5357066ed15759e36436346dae498e8ef8
+DIST vte-0.62.3.tar.xz 447152 BLAKE2B 2c55430490af577cdbad8bbcbb53902ccc4ab8d9643d5e8b3279e96b4285347e652e761644c957961732eeb50d12e33fa3d3c735be9899ad14c1e2f35377f2a7 SHA512 0475e2813b305bf1b5d48ece5959f2feb10e89b589fa3b75032ae466fd5254bf5c2fc6085dc296d65c5df84790a38892534ff401109843bf964ae62a8c540a81
diff --git a/x11-libs/vte/vte-0.62.3.ebuild b/x11-libs/vte/vte-0.62.3.ebuild
new file mode 100644
index 000000000000..80301a89aacd
--- /dev/null
+++ b/x11-libs/vte/vte-0.62.3.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+VALA_MIN_API_VERSION="0.32"
+
+inherit gnome.org meson vala xdg
+
+DESCRIPTION="Library providing a virtual terminal emulator widget"
+HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/VTE"
+
+LICENSE="LGPL-3+ GPL-3+"
+SLOT="2.91"
+IUSE="+crypt debug gtk-doc +icu +introspection systemd +vala vanilla"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+REQUIRED_USE="vala? ( introspection )"
+
+SRC_URI="${SRC_URI} !vanilla? ( https://dev.gentoo.org/~mattst88/distfiles/${PN}-0.62.1-command-notify.patch.xz )"
+
+RDEPEND="
+ >=x11-libs/gtk+-3.24.14:3[introspection?]
+ >=dev-libs/fribidi-1.0.0
+ >=dev-libs/glib-2.52:2
+ crypt? ( >=net-libs/gnutls-3.2.7:0= )
+ icu? ( dev-libs/icu:= )
+ >=x11-libs/pango-1.22.0
+ >=dev-libs/libpcre2-10.21
+ systemd? ( >=sys-apps/systemd-220:= )
+ sys-libs/zlib
+ introspection? ( >=dev-libs/gobject-introspection-1.56:= )
+ x11-libs/pango[introspection?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.13
+ app-text/docbook-xml-dtd:4.1.2 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ if ! use vanilla; then
+ # Part of https://src.fedoraproject.org/rpms/vte291/raw/f31/f/vte291-cntnr-precmd-preexec-scroll.patch
+ # Adds OSC 777 support for desktop notifications in gnome-terminal or elsewhere
+ eapply "${WORKDIR}"/${PN}-0.62.1-command-notify.patch
+ fi
+
+ # -Ddebugg option enables various debug support via VTE_DEBUG, but also ggdb3; strip the latter
+ sed -e '/ggdb3/d' -i meson.build || die
+
+ use vala && vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Da11y=true
+ $(meson_use debug debugg)
+ $(meson_use gtk-doc docs)
+ $(meson_use introspection gir)
+ -Dfribidi=true # pulled in by pango anyhow
+ $(meson_use crypt gnutls)
+ -Dgtk3=true
+ -Dgtk4=false
+ $(meson_use icu)
+ $(meson_use systemd _systemd)
+ $(meson_use vala vapi)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ mv "${ED}"/etc/profile.d/vte{,-${SLOT}}.sh || die
+}