summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/xvba-video
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/xvba-video')
-rw-r--r--x11-libs/xvba-video/Manifest1
-rw-r--r--x11-libs/xvba-video/files/xvba-video-0.8.0-VAEncH264VUIBufferType.patch12
-rw-r--r--x11-libs/xvba-video/files/xvba-video-0.8.0-assert-hw_image_hooks_glx.patch12
-rw-r--r--x11-libs/xvba-video/files/xvba-video-fix-mesa-gl.h.patch17
-rw-r--r--x11-libs/xvba-video/files/xvba-video-fix-out-of-source-builds.patch11
-rw-r--r--x11-libs/xvba-video/metadata.xml5
-rw-r--r--x11-libs/xvba-video/xvba-video-0.8.0-r3.ebuild59
-rw-r--r--x11-libs/xvba-video/xvba-video-9999.ebuild56
8 files changed, 173 insertions, 0 deletions
diff --git a/x11-libs/xvba-video/Manifest b/x11-libs/xvba-video/Manifest
new file mode 100644
index 000000000000..819cf84c6df5
--- /dev/null
+++ b/x11-libs/xvba-video/Manifest
@@ -0,0 +1 @@
+DIST xvba-driver-0.8.0.tar.bz2 80424 SHA256 bd56e64c619732956fe3e900520a704de90c1849f0b0e0ab6b8db5ff695d38a2 SHA512 1e968f6123c5563f5dfc1f01cd2b7ed9b3f6afa9cf93b50b2079b1408670f6048f8d6b6d47c1ebbad1defc3600788ddf85a93bee772d90e05a8769ff19e2425b WHIRLPOOL df19706f84c17c6141e9a3cacec230012767b8fb06117477b95ed4b511b52321e9092455d927ff4147b1a951aea234d35575758fd69ba577ade131fb27d79da1
diff --git a/x11-libs/xvba-video/files/xvba-video-0.8.0-VAEncH264VUIBufferType.patch b/x11-libs/xvba-video/files/xvba-video-0.8.0-VAEncH264VUIBufferType.patch
new file mode 100644
index 000000000000..3542d4ee6d19
--- /dev/null
+++ b/x11-libs/xvba-video/files/xvba-video-0.8.0-VAEncH264VUIBufferType.patch
@@ -0,0 +1,12 @@
+diff -ur a/src/xvba_dump.c b/src/xvba_dump.c
+--- a/src/xvba_dump.c 2012-11-23 14:29:10.000000000 +0100
++++ b/src/xvba_dump.c 2014-03-03 18:53:08.772012251 +0100
+@@ -150,8 +150,6 @@
+ _(VAEncSequenceParameterBufferType);
+ _(VAEncPictureParameterBufferType);
+ _(VAEncSliceParameterBufferType);
+- _(VAEncH264VUIBufferType);
+- _(VAEncH264SEIBufferType);
+ #endif
+ #undef _
+ }
diff --git a/x11-libs/xvba-video/files/xvba-video-0.8.0-assert-hw_image_hooks_glx.patch b/x11-libs/xvba-video/files/xvba-video-0.8.0-assert-hw_image_hooks_glx.patch
new file mode 100644
index 000000000000..7cb249a16f48
--- /dev/null
+++ b/x11-libs/xvba-video/files/xvba-video-0.8.0-assert-hw_image_hooks_glx.patch
@@ -0,0 +1,12 @@
+diff -ur xvba-video-0.8.0/src/xvba_image.c xvba-video-0.8.0-patched/src/xvba_image.c
+--- xvba-video-0.8.0/src/xvba_image.c 2011-06-14 13:07:13.000000000 +0200
++++ xvba-video-0.8.0-patched/src/xvba_image.c 2012-07-22 14:55:14.186667413 +0200
+@@ -423,7 +423,7 @@
+ }
+
+ #if USE_GLX
+-const HWImageHooks hw_image_hooks_glx attribute_hidden;
++extern const HWImageHooks hw_image_hooks_glx attribute_hidden;
+ #endif
+
+ // Commit image to the HW
diff --git a/x11-libs/xvba-video/files/xvba-video-fix-mesa-gl.h.patch b/x11-libs/xvba-video/files/xvba-video-fix-mesa-gl.h.patch
new file mode 100644
index 000000000000..578d3321d92d
--- /dev/null
+++ b/x11-libs/xvba-video/files/xvba-video-fix-mesa-gl.h.patch
@@ -0,0 +1,17 @@
+diff -urN xvba-driver-0.8.0.old/src/utils_glx.h xvba-driver-0.8.0/src/utils_glx.h
+--- xvba-driver-0.8.0.old/src/utils_glx.h 2013-02-04 20:04:00.476332874 +0100
++++ xvba-driver-0.8.0/src/utils_glx.h 2013-02-04 20:04:40.228329931 +0100
+@@ -25,6 +25,13 @@
+ #include <GL/glext.h>
+ #include <GL/glx.h>
+
++
++#if GL_GLEXT_VERSION >= 85
++/* XXX: PFNGLMULTITEXCOORD2FPROC got out of the GL_VERSION_1_3_DEPRECATED
++ block and is not defined if GL_VERSION_1_3 is defined in <GL/gl.h>
++ Redefine the type here as an interim solution */
++typedef void (*PFNGLMULTITEXCOORD2FPROC) (GLenum target, GLfloat s, GLfloat t);
++#endif
+ #ifndef GL_FRAMEBUFFER_BINDING
+ #define GL_FRAMEBUFFER_BINDING GL_FRAMEBUFFER_BINDING_EXT
+ #endif
diff --git a/x11-libs/xvba-video/files/xvba-video-fix-out-of-source-builds.patch b/x11-libs/xvba-video/files/xvba-video-fix-out-of-source-builds.patch
new file mode 100644
index 000000000000..23de8559a07a
--- /dev/null
+++ b/x11-libs/xvba-video/files/xvba-video-fix-out-of-source-builds.patch
@@ -0,0 +1,11 @@
+--- src/shaders/Makefile.am 2012-11-23 08:29:10.000000000 -0500
++++ src/shaders/Makefile.am.new 2014-01-30 18:38:27.954753460 -0500
+@@ -25,7 +25,7 @@
+ CLEANFILES += $(shaders_h)
+
+ %.h: %.pso pso2h.py
+- $(PYTHON) pso2h.py -n $*_fp -o $@ $<
++ $(PYTHON) $(top_srcdir)/src/shaders/pso2h.py -n $*_fp -o $@ $<
+ endif
+
+ # Only add those targets if the Cg compiler is available
diff --git a/x11-libs/xvba-video/metadata.xml b/x11-libs/xvba-video/metadata.xml
new file mode 100644
index 000000000000..01c4c004e735
--- /dev/null
+++ b/x11-libs/xvba-video/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+</pkgmetadata>
diff --git a/x11-libs/xvba-video/xvba-video-0.8.0-r3.ebuild b/x11-libs/xvba-video/xvba-video-0.8.0-r3.ebuild
new file mode 100644
index 000000000000..0c3eba57de0a
--- /dev/null
+++ b/x11-libs/xvba-video/xvba-video-0.8.0-r3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/vaapi/xvba-driver"
+[[ ${PV} = 9999 ]] && inherit git-2
+PYTHON_COMPAT=( python2_7 )
+AUTOTOOLS_AUTORECONF="yes"
+inherit eutils autotools-multilib python-any-r1
+
+DESCRIPTION="XVBA Backend for Video Acceleration (VA) API"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/vaapi"
+SRC_URI="http://dev.gentooexperimental.org/~scarabeus/xvba-driver-${PV}.tar.bz2"
+# No source release yet, the src_uri is theoretical at best right now
+#[[ ${PV} = 9999 ]] || SRC_URI="http://www.freedesktop.org/software/vaapi/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ MIT"
+SLOT="0"
+# newline is needed for broken ekeyword
+[[ ${PV} = 9999 ]] || \
+KEYWORDS="amd64 x86"
+IUSE="debug opengl"
+
+RDEPEND=">=x11-libs/libva-1.2.1-r1[X(+),opengl?,${MULTILIB_USEDEP}]
+ >=x11-libs/libvdpau-0.7[${MULTILIB_USEDEP}]"
+DEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ x11-drivers/ati-drivers"
+
+DOCS=( NEWS README AUTHORS )
+PATCHES=(
+ "${FILESDIR}"/${PN}-fix-mesa-gl.h.patch
+ "${FILESDIR}"/${PN}-fix-out-of-source-builds.patch
+ "${FILESDIR}"/${P}-VAEncH264VUIBufferType.patch
+ "${FILESDIR}"/${P}-assert-hw_image_hooks_glx.patch
+)
+
+S="${WORKDIR}/xvba-driver-${PV}"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ # bug 469208
+ sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac || die
+ autotools-multilib_src_prepare
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable opengl glx)
+ )
+ autotools-utils_src_configure
+}
diff --git a/x11-libs/xvba-video/xvba-video-9999.ebuild b/x11-libs/xvba-video/xvba-video-9999.ebuild
new file mode 100644
index 000000000000..6d66fbbf8cc3
--- /dev/null
+++ b/x11-libs/xvba-video/xvba-video-9999.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/vaapi/xvba-driver"
+[[ ${PV} = 9999 ]] && inherit git-2
+PYTHON_COMPAT=( python2_7 )
+AUTOTOOLS_AUTORECONF="yes"
+inherit eutils autotools-multilib python-any-r1
+
+DESCRIPTION="XVBA Backend for Video Acceleration (VA) API"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/vaapi"
+# No source release yet, the src_uri is theoretical at best right now
+[[ ${PV} = 9999 ]] || SRC_URI="http://www.freedesktop.org/software/vaapi/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ MIT"
+SLOT="0"
+# newline is needed for broken ekeyword
+[[ ${PV} = 9999 ]] || \
+KEYWORDS="~amd64 ~x86"
+IUSE="debug opengl"
+
+RDEPEND=">=x11-libs/libva-1.2.1-r1[X(+),opengl?,${MULTILIB_USEDEP}]
+ >=x11-libs/libvdpau-0.7[${MULTILIB_USEDEP}]
+ x11-drivers/ati-drivers"
+DEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig"
+
+DOCS=( NEWS README AUTHORS )
+PATCHES=(
+ "${FILESDIR}"/${PN}-fix-mesa-gl.h.patch
+ "${FILESDIR}"/${PN}-fix-out-of-source-builds.patch
+ "${FILESDIR}"/${P}-VAEncH264VUIBufferType.patch
+ "${FILESDIR}"/${P}-assert-hw_image_hooks_glx.patch
+)
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ # bug 469208
+ sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac || die
+ autotools-multilib_src_prepare
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable opengl glx)
+ )
+ autotools-utils_src_configure
+}