summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-02-17 21:36:41 -0500
committerMatt Turner <mattst88@gentoo.org>2023-02-17 21:40:41 -0500
commit3ff93e88590669f48495b7c30efc311f7b681326 (patch)
tree9546390d2164a35aa5b2f91a318c2d29a5445dab /x11-libs
parentprofiles/features/musl: unmask efivar-38 (diff)
downloadgentoo-3ff93e88590669f48495b7c30efc311f7b681326.tar.gz
gentoo-3ff93e88590669f48495b7c30efc311f7b681326.tar.bz2
gentoo-3ff93e88590669f48495b7c30efc311f7b681326.zip
x11-libs/libnotify: Version bump to 0.8.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libnotify/Manifest1
-rw-r--r--x11-libs/libnotify/libnotify-0.8.2.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/x11-libs/libnotify/Manifest b/x11-libs/libnotify/Manifest
index 2e0c4af9606c..dcfcc183d6a6 100644
--- a/x11-libs/libnotify/Manifest
+++ b/x11-libs/libnotify/Manifest
@@ -1 +1,2 @@
DIST libnotify-0.8.1.tar.xz 105368 BLAKE2B 840b56941e9773b4db5ce1ffba7ca3fc04e76877349c53ed1c985acf7405a575bc9709e0255edf4562b5596de97fcd7e9dbef32d99bc853b94b203a7da0c03e4 SHA512 464b7ff9f2f6268919f336bd9c6f8c243c29282ba6ada7e491ab514b3630977a319dfa522705c68e17fff2d87effc75e009d656bc46c5e92917ad64e66b25320
+DIST libnotify-0.8.2.tar.xz 105912 BLAKE2B d014d01e624a072a1a4e60d8606833e790fc9b47a93229486a7c7860d3d90eaae6bcf3f4f78599db8b2c0ed3d35569a1b20d8a8deb08c8fa5be98330b1205f60 SHA512 c9eb0630520382228237ae914654e27ba973efe29a27d040c2462016bd3e0704889aabc5d04d51906951cd404d7edd64262860b7636afd03dd76dedcf1f77cae
diff --git a/x11-libs/libnotify/libnotify-0.8.2.ebuild b/x11-libs/libnotify/libnotify-0.8.2.ebuild
new file mode 100644
index 000000000000..d961823a695b
--- /dev/null
+++ b/x11-libs/libnotify/libnotify-0.8.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson-multilib xdg-utils
+
+DESCRIPTION="A library for sending desktop notifications"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libnotify"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="gtk-doc +introspection test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="gtk-doc? ( introspection )"
+
+RDEPEND="
+ >=dev-libs/glib-2.38:2[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-libs/gobject-introspection-common-1.32
+ dev-util/glib-utils
+ virtual/pkgconfig
+ app-text/docbook-xsl-ns-stylesheets
+ dev-libs/libxslt
+ gtk-doc? (
+ dev-util/gi-docgen
+ app-text/docbook-xml-dtd:4.1.2
+ )
+ test? ( x11-libs/gtk+:3[${MULTILIB_USEDEP}] )
+"
+IDEPEND="app-eselect/eselect-notify-send"
+PDEPEND="virtual/notification-daemon"
+
+src_prepare() {
+ default
+ xdg_environment_reset
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ $(meson_native_use_feature introspection)
+ $(meson_native_use_bool gtk-doc gtk_doc)
+ -Ddocbook_docs=disabled
+ )
+ meson_src_configure
+}
+
+multilib_src_install_all() {
+ mv "${ED}"/usr/bin/{,libnotify-}notify-send || die #379941
+
+ einstalldocs
+
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/ || die
+ mv "${ED}"/usr/share/{doc,gtk-doc}/libnotify-0 || die
+ fi
+}
+
+pkg_postinst() {
+ eselect notify-send update ifunset
+}
+
+pkg_postrm() {
+ eselect notify-send update ifunset
+}