summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-28 00:48:44 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-28 00:48:44 +0100
commit49c43658730f6e17742690a8adfafc43ecd26bde (patch)
tree184cfa8c4aee1c10262cf09d6f77cc38f8dfbcbe /x11-libs
parentdev-python/pyftpdlib: bump to 1.5.6, drop Py2 (diff)
downloadgentoo-49c43658730f6e17742690a8adfafc43ecd26bde.tar.gz
gentoo-49c43658730f6e17742690a8adfafc43ecd26bde.tar.bz2
gentoo-49c43658730f6e17742690a8adfafc43ecd26bde.zip
x11-libs/goffice: Bump to 0.10.46
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/goffice/Manifest1
-rw-r--r--x11-libs/goffice/goffice-0.10.46.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/x11-libs/goffice/Manifest b/x11-libs/goffice/Manifest
index 595a4718f709..85307c5fc729 100644
--- a/x11-libs/goffice/Manifest
+++ b/x11-libs/goffice/Manifest
@@ -1,2 +1,3 @@
DIST goffice-0.10.41.tar.xz 2381656 BLAKE2B 7d73b892d91f917e3a47058f508094a16bb50860686dcf33c68ac8028b40e7ba74cc276f276672f29ddafef73b03887cf6280a2812305bd9b24ae3021c319d25 SHA512 d4b6a30b2b5d92e7500a1810626d20a2d4e5f66c1a879c904fe57df384bf4a480de322e9ae0a5fe7a44e73e060d9a33da6d56cd051c3d6cb1ebf0eae09fda2f8
DIST goffice-0.10.43.tar.xz 2381804 BLAKE2B 60e305620118f80595a0dfec8192648273f845c9f868142adb957796ee291e1e53b0f3d3f2446064d8014ec54e7008ac03eca7f2f4925efa00ff42b98810371b SHA512 979ccf67fe08d09a2cf0413b4674a44208aa5f4802ab086a463ea2b449fc8c9d1c96dea7234c8e715064cf1726a47d2a5428728a2ff0d00759d5fe7017dc709f
+DIST goffice-0.10.46.tar.xz 2397976 BLAKE2B a05696cde60b1cb1ee915bebd3a6e99d1f0a31dc232481615a1c6bbc05ee5433cdebfb05d96160026b260c752c2cfb11c0aecc338079cda66fd40b653fb8b0d1 SHA512 23714fef4dabccc76fe96b78d8eba9c9adb01cb9b3e2f1a9768598fb2a82742b2d2060a7d2548279998488c59e313d7a5863a96b2eb380f540b61fb08e0330f3
diff --git a/x11-libs/goffice/goffice-0.10.46.ebuild b/x11-libs/goffice/goffice-0.10.46.ebuild
new file mode 100644
index 000000000000..12d2ce5eb098
--- /dev/null
+++ b/x11-libs/goffice/goffice-0.10.46.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org libtool
+
+DESCRIPTION="A library of document-centric objects and utilities"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/goffice/"
+
+LICENSE="GPL-2"
+SLOT="0.10"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="+introspection"
+
+# FIXME: add lasem to tree
+RDEPEND="
+ >=app-text/libspectre-0.2.6:=
+ >=dev-libs/glib-2.40.0:2
+ >=dev-libs/libxml2-2.4.12:2
+ dev-libs/libxslt
+ >=gnome-base/librsvg-2.22:2
+ >=gnome-extra/libgsf-1.14.24:=[introspection?]
+ >=x11-libs/cairo-1.10:=[svg]
+ >=x11-libs/gdk-pixbuf-2.22:2
+ >=x11-libs/gtk+-3.20:3
+ >=x11-libs/pango-1.24:=
+ x11-libs/libXext:=
+ x11-libs/libXrender:=
+ introspection? (
+ >=dev-libs/gobject-introspection-1:=
+ >=gnome-extra/libgsf-1.14.23:=
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/perl
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.12
+ >=dev-util/intltool-0.35
+ virtual/perl-Compress-Raw-Zlib
+ virtual/perl-Getopt-Long
+ virtual/perl-IO-Compress
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-gtk-doc \
+ --disable-maintainer-mode \
+ --without-lasem \
+ --with-gtk \
+ --with-config-backend=gsettings \
+ $(use_enable introspection)
+}
+
+src_install() {
+ default
+ dodoc MAINTAINERS
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}