summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-30 18:30:07 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-30 19:00:20 -0400
commit9fa09f1be9a46a81a5e1c68bea43de4c34727b80 (patch)
treee4b27e5f736dc2e43952b337241fa57b5cc467d2 /x11-libs
parentdev-perl/BZ-Client: Version bump 4.4004 (diff)
downloadgentoo-9fa09f1be9a46a81a5e1c68bea43de4c34727b80.tar.gz
gentoo-9fa09f1be9a46a81a5e1c68bea43de4c34727b80.tar.bz2
gentoo-9fa09f1be9a46a81a5e1c68bea43de4c34727b80.zip
x11-libs/vte: Version bump to 0.64.1
Closes: https://bugs.gentoo.org/786249 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/vte/Manifest2
-rw-r--r--x11-libs/vte/vte-0.64.1.ebuild83
2 files changed, 85 insertions, 0 deletions
diff --git a/x11-libs/vte/Manifest b/x11-libs/vte/Manifest
index 2befb2bc1484..eea0c6812369 100644
--- a/x11-libs/vte/Manifest
+++ b/x11-libs/vte/Manifest
@@ -1,3 +1,5 @@
DIST vte-0.28.2.tar.xz 962340 BLAKE2B 1e4b5977962265be77917ccfc9118ed93232c03d7a16b6c08a27e721fe71f8c1dd1783a439530d7b3d915111cb8cc78281f1e9e351d6a83edd31f224309ca1e9 SHA512 d6a50481aaa8946cca3779e0b328fef551be534d70366a75385d1f8ead3fcddec57bed85c7d4bc2d9f34546532129e63083aafa33cbb0efcbc7dc9d66e7c45f6
DIST vte-0.62.1-command-notify.patch.xz 4844 BLAKE2B 22301fdc5f1969beb2ad9b316fea8972f696f0e54e1a24d5eceedec71162afc2991b7963a71ce8925a94f6c40e5303d3db760b872d0eebbdc6d05b22d3c59ecc SHA512 491e241b0f5aae50e59d25751e95579d40c47e7e4c7f2b279522347f7f2f7f00c92bdf5fa4a651e4146bcfa9439f03b6311b4061fb20c5679c09b97a4924dcf1
DIST vte-0.62.3.tar.xz 447152 BLAKE2B 2c55430490af577cdbad8bbcbb53902ccc4ab8d9643d5e8b3279e96b4285347e652e761644c957961732eeb50d12e33fa3d3c735be9899ad14c1e2f35377f2a7 SHA512 0475e2813b305bf1b5d48ece5959f2feb10e89b589fa3b75032ae466fd5254bf5c2fc6085dc296d65c5df84790a38892534ff401109843bf964ae62a8c540a81
+DIST vte-0.64.1-command-notify.patch.xz 4880 BLAKE2B d6ff5f4acac161980c8c18245e65795c7f0ea3d0819748894b055306ecd731d698cac578eff2750795a9180a9b17d79f220e814083012d5a04f4f351ff2a0e36 SHA512 174397aeca00399b138286fd4cc88941add041a1f2596fd42222d44c886c2e35b2a33041b58a102ee3acbcddc0cc40fcfde39d72ec46b640ee1db22d8ae684c4
+DIST vte-0.64.1.tar.bz2 486720 BLAKE2B bd8fb1f471a43aadf015cce8ae38c646521ca66e37652b72f7e94cec15a2a0a844d67116e9123ede44ba1b6ee569d1ecd0ff5e83067f6231802f5a77a798e446 SHA512 38bbbb4ed3d86740091c9ddee83f97bf5cb5c69c48e8a78592dd46e8f9334859a6c523e7b16dce110de71cd4a9a3b8b99a11816b61eae6e251dfc20cdbee6716
diff --git a/x11-libs/vte/vte-0.64.1.ebuild b/x11-libs/vte/vte-0.64.1.ebuild
new file mode 100644
index 000000000000..e1499ad22159
--- /dev/null
+++ b/x11-libs/vte/vte-0.64.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+VALA_MIN_API_VERSION="0.32"
+
+inherit gnome.org meson vala xdg
+
+DESCRIPTION="Library providing a virtual terminal emulator widget"
+HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/VTE"
+
+LICENSE="LGPL-3+ GPL-3+"
+SLOT="2.91"
+IUSE="+crypt debug gtk-doc +icu +introspection systemd +vala vanilla"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+REQUIRED_USE="vala? ( introspection )"
+
+# Upstream is hostile and refuses to upload tarballs.
+SRC_URI="https://gitlab.gnome.org/GNOME/${PN}/-/archive/${PV}/${P}.tar.bz2"
+SRC_URI="${SRC_URI} !vanilla? ( https://dev.gentoo.org/~mattst88/distfiles/${PN}-0.64.1-command-notify.patch.xz )"
+
+RDEPEND="
+ >=x11-libs/gtk+-3.24.14:3[introspection?]
+ >=dev-libs/fribidi-1.0.0
+ >=dev-libs/glib-2.52:2
+ crypt? ( >=net-libs/gnutls-3.2.7:0= )
+ icu? ( dev-libs/icu:= )
+ >=x11-libs/pango-1.22.0
+ >=dev-libs/libpcre2-10.21
+ systemd? ( >=sys-apps/systemd-220:= )
+ sys-libs/zlib
+ introspection? ( >=dev-libs/gobject-introspection-1.56:= )
+ x11-libs/pango[introspection?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.13
+ app-text/docbook-xml-dtd:4.1.2 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ if ! use vanilla; then
+ # Part of https://src.fedoraproject.org/rpms/vte291/raw/f31/f/vte291-cntnr-precmd-preexec-scroll.patch
+ # Adds OSC 777 support for desktop notifications in gnome-terminal or elsewhere
+ eapply "${WORKDIR}"/${PN}-0.64.1-command-notify.patch
+ fi
+
+ # -Ddebugg option enables various debug support via VTE_DEBUG, but also ggdb3; strip the latter
+ sed -e '/ggdb3/d' -i meson.build || die
+
+ use vala && vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Da11y=true
+ $(meson_use debug debugg)
+ $(meson_use gtk-doc docs)
+ $(meson_use introspection gir)
+ -Dfribidi=true # pulled in by pango anyhow
+ -Dglade=true
+ $(meson_use crypt gnutls)
+ -Dgtk3=true
+ -Dgtk4=false
+ $(meson_use icu)
+ $(meson_use systemd _systemd)
+ $(meson_use vala vapi)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ mv "${ED}"/etc/profile.d/vte{,-${SLOT}}.sh || die
+}