summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-09-15 15:22:58 +0200
committerDavid Seifert <soap@gentoo.org>2020-09-15 15:22:58 +0200
commitdc3830ef602e9e00b8a711c5f0374ee6cfe2ccbd (patch)
treed428f97591a6451b5c2091d0bb9abc6406c498cc /x11-libs
parentx11-libs/spread-sheet-widget: Disable static libraries (diff)
downloadgentoo-dc3830ef602e9e00b8a711c5f0374ee6cfe2ccbd.tar.gz
gentoo-dc3830ef602e9e00b8a711c5f0374ee6cfe2ccbd.tar.bz2
gentoo-dc3830ef602e9e00b8a711c5f0374ee6cfe2ccbd.zip
x11-libs/scw: Disable static libraries
Closes: https://bugs.gentoo.org/742659 Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/scw/scw-0.4.7-r2.ebuild (renamed from x11-libs/scw/scw-0.4.7-r1.ebuild)23
1 files changed, 15 insertions, 8 deletions
diff --git a/x11-libs/scw/scw-0.4.7-r1.ebuild b/x11-libs/scw/scw-0.4.7-r2.ebuild
index 479049556dfe..a180f163479a 100644
--- a/x11-libs/scw/scw-0.4.7-r1.ebuild
+++ b/x11-libs/scw/scw-0.4.7-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -14,15 +14,22 @@ IUSE="doc"
RDEPEND="
dev-libs/glib:2
- x11-libs/gtk+:2
-"
-DEPEND="
- ${RDEPEND}
- doc? ( dev-util/gtk-doc )
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}"
+BDEPEND="
dev-util/glib-utils
virtual/pkgconfig
-"
+ doc? ( dev-util/gtk-doc )"
src_configure() {
- econf $(use_enable doc gtk-doc)
+ econf \
+ --disable-static \
+ $(use_enable doc gtk-doc)
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
}