summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2020-07-08 18:08:10 +0200
committerGuilherme Amadio <amadio@gentoo.org>2020-07-08 18:11:25 +0200
commite7f6d3b17de9a4b496d88c769fc19b171d1976a9 (patch)
treeeba98848f89893505cb06df13e3f20545be25612 /x11-libs
parentmedia-radio/qsstv: Cleanup RedundantLongDescription (diff)
downloadgentoo-e7f6d3b17de9a4b496d88c769fc19b171d1976a9.tar.gz
gentoo-e7f6d3b17de9a4b496d88c769fc19b171d1976a9.tar.bz2
gentoo-e7f6d3b17de9a4b496d88c769fc19b171d1976a9.zip
x11-libs/gl2ps: version bump to 1.4.2
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gl2ps/Manifest1
-rw-r--r--x11-libs/gl2ps/files/gl2ps-1.4.2-cmake.patch58
-rw-r--r--x11-libs/gl2ps/gl2ps-1.4.2.ebuild51
3 files changed, 110 insertions, 0 deletions
diff --git a/x11-libs/gl2ps/Manifest b/x11-libs/gl2ps/Manifest
index 40cb87fca8c0..f532f77e3736 100644
--- a/x11-libs/gl2ps/Manifest
+++ b/x11-libs/gl2ps/Manifest
@@ -1,2 +1,3 @@
DIST gl2ps-1.3.9.tgz 294907 BLAKE2B b8473f9f3fc6cefa2374f6fdd94fb98d73ea79b9c0087ccc573f6b66eafe11098fc4312d8ff121abe2a8d6c9a3474f69dcb321ef978f8777b6dc077e5504621f SHA512 e6770c27d4832a300b4e16a9f98deb8557e7875460e7aa7e655fdb796f5dfffd5eccdc8b15f5a3ae151713fc46f97dacad48ee7550c41373b6fc8cfd21a437cb
DIST gl2ps-1.4.0.tgz 300339 BLAKE2B bda8742dea6c1b4eb3e3a3492e6f38229feb6480131ce69e3512e9c558f7817a34bc76985311c3879cfcec5f715f36f0b8300300dd26025cdb7e72478802aa7d SHA512 420b21a5b4397c9a9a2323a8686b8635c2683354c94762d2d0172c661fc36c4298042498dd8ef2323adf32f45aa4e0a3dba146058ccde597e5a46c2027cbf7ce
+DIST gl2ps-1.4.2.tgz 301134 BLAKE2B 43c93f93d09dd7a6af0711819647f5f82c0853a80822dbc600b7502f2c86612f5cb2edc31729c67abbab44cc8fec7aa1fa7e13f0d115b0d79c7a7d45fa1a3079 SHA512 46652e1b3825ace61dbd77c4b0bf451e7671c248eb18bbd3369e2fac00056ea4cd5d2578561984313c239e3b02f78b9d9a76d963c935af65a13bc2abfc538620
diff --git a/x11-libs/gl2ps/files/gl2ps-1.4.2-cmake.patch b/x11-libs/gl2ps/files/gl2ps-1.4.2-cmake.patch
new file mode 100644
index 000000000000..9865c439aa78
--- /dev/null
+++ b/x11-libs/gl2ps/files/gl2ps-1.4.2-cmake.patch
@@ -0,0 +1,58 @@
+--- a/CMakeLists.txt 2020-07-08 17:53:51.133105546 +0200
++++ b/CMakeLists.txt 2020-07-08 17:58:02.652237439 +0200
+@@ -50,4 +50,6 @@
+ option(ENABLE_ZLIB "Enable compression using ZLIB" ON)
+ option(ENABLE_PNG "Enable PNG support" ON)
++option(ENABLE_DOC "Enable documentation" OFF)
++option(ENABLE_EXAMPLES "Build and install examples" OFF)
+
+ set(GL2PS_MAJOR_VERSION 1)
+@@ -140,6 +142,4 @@
+
+ if(OPENGL_FOUND)
+- add_library(lib STATIC gl2ps.c gl2ps.h)
+- set_target_properties(lib PROPERTIES OUTPUT_NAME gl2ps)
+
+ add_library(shared SHARED gl2ps.c gl2ps.h)
+@@ -152,5 +152,5 @@
+ COMPILE_FLAGS "-DGL2PSDLL -DGL2PSDLL_EXPORTS")
+ endif()
+- install(TARGETS lib shared RUNTIME DESTINATION bin
++ install(TARGETS shared RUNTIME DESTINATION bin
+ LIBRARY DESTINATION lib${LIB_SUFFIX}
+ ARCHIVE DESTINATION lib${LIB_SUFFIX})
+@@ -160,15 +160,16 @@
+ set(GL2PS_DOC .)
+ else()
+- set(GL2PS_DOC share/doc/gl2ps)
++ set(GL2PS_DOC ${CMAKE_INSTALL_DOCDIR})
+ endif()
+
+ install(FILES gl2ps.h DESTINATION include)
+ install(FILES ${CMAKE_SOURCE_DIR}/README.txt DESTINATION ${GL2PS_DOC})
+-install(FILES ${CMAKE_SOURCE_DIR}/COPYING.LGPL DESTINATION ${GL2PS_DOC})
+-install(FILES ${CMAKE_SOURCE_DIR}/COPYING.GL2PS DESTINATION ${GL2PS_DOC})
++install(FILES ${CMAKE_SOURCE_DIR}/TODO.txt DESTINATION ${GL2PS_DOC})
++
++if(ENABLE_EXAMPLES)
+ install(FILES ${CMAKE_SOURCE_DIR}/gl2psTest.c DESTINATION ${GL2PS_DOC})
+ install(FILES ${CMAKE_SOURCE_DIR}/gl2psTestSimple.c DESTINATION ${GL2PS_DOC})
+
+-if(GLUT_FOUND)
++if(GLUT_FOUND AND BUILD_TESTING)
+ add_executable(gl2psTest WIN32 gl2psTest.c)
+ target_link_libraries(gl2psTest lib ${EXTERNAL_LIBRARIES})
+@@ -176,5 +177,7 @@
+ target_link_libraries(gl2psTestSimple lib ${EXTERNAL_LIBRARIES})
+ endif()
++endif()
+
++if(ENABLE_DOC)
+ find_package(LATEX)
+ if(PDFLATEX_COMPILER)
+@@ -195,4 +198,5 @@
+ endif()
+ endif()
++endif()
+
+ set(CPACK_PACKAGE_VENDOR "Christophe Geuzaine")
diff --git a/x11-libs/gl2ps/gl2ps-1.4.2.ebuild b/x11-libs/gl2ps/gl2ps-1.4.2.ebuild
new file mode 100644
index 000000000000..d97b83f7cc60
--- /dev/null
+++ b/x11-libs/gl2ps/gl2ps-1.4.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake
+
+DESCRIPTION="OpenGL to PostScript printing library"
+HOMEPAGE="http://www.geuz.org/gl2ps/"
+SRC_URI="http://geuz.org/${PN}/src/${P}.tgz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc png zlib"
+
+RDEPEND="
+ media-libs/freeglut
+ x11-libs/libXmu
+ png? ( media-libs/libpng:0= )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ doc? (
+ dev-tex/tth
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexrecommended )"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.4.2-cmake.patch )
+
+src_prepare() {
+ cmake_src_prepare
+ sed '/^install.*TODO\.txt/d' -i "${S}"/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
+ -DENABLE_DOC="$(usex doc)"
+ -DENABLE_PNG="$(usex png)"
+ -DENABLE_ZLIB="$(usex zlib)"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ install_name_tool \
+ -id "${EPREFIX}"/usr/$(get_libdir)/libgl2ps.dylib \
+ "${D}${EPREFIX}"/usr/$(get_libdir)/libgl2ps.dylib || die
+ fi
+}