summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/3dfb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/3dfb')
-rw-r--r--x11-misc/3dfb/3dfb-0.6.1-r1.ebuild30
-rw-r--r--x11-misc/3dfb/Manifest1
-rw-r--r--x11-misc/3dfb/files/0.6.1-gcc41.patch12
-rw-r--r--x11-misc/3dfb/files/3dfb-0.6.1-freeglut-compat.patch10
-rw-r--r--x11-misc/3dfb/metadata.xml8
5 files changed, 61 insertions, 0 deletions
diff --git a/x11-misc/3dfb/3dfb-0.6.1-r1.ebuild b/x11-misc/3dfb/3dfb-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..1152cd8b6776
--- /dev/null
+++ b/x11-misc/3dfb/3dfb-0.6.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="3D File Browser"
+HOMEPAGE="http://sourceforge.net/projects/dz3d/"
+SRC_URI="mirror://sourceforge/dz3d/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+RDEPEND="dev-libs/glib:2
+ media-libs/freeglut
+ virtual/opengl
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README WISHLIST )
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-gcc41.patch" \
+ "${FILESDIR}/${P}-freeglut-compat.patch"
+ epatch_user
+}
diff --git a/x11-misc/3dfb/Manifest b/x11-misc/3dfb/Manifest
new file mode 100644
index 000000000000..6a29076b7074
--- /dev/null
+++ b/x11-misc/3dfb/Manifest
@@ -0,0 +1 @@
+DIST 3dfb-0.6.1.tar.gz 102343 SHA256 94321725651711a7f7e61f8c479e519985f980e788dfa6a840300d8a41dacf3f SHA512 3eb43dd80d5ffaea8845e84e2cf21599ee36739ac99d558c4c11592363970795e60b30f444229c987f527a0765fa657111d7a54eef84b5d3d9375c7a812588f1 WHIRLPOOL 4d589d3f9a0b3823e7e64db15f147eced83224db5c20e73c40ac98a7192b93a409f36d561017fc4d23a354e210bdf1e9cafddee8461fe94c88abc79cb578263a
diff --git a/x11-misc/3dfb/files/0.6.1-gcc41.patch b/x11-misc/3dfb/files/0.6.1-gcc41.patch
new file mode 100644
index 000000000000..2a964f66c21d
--- /dev/null
+++ b/x11-misc/3dfb/files/0.6.1-gcc41.patch
@@ -0,0 +1,12 @@
+diff -Nur 3dfb-0.6.1.orig/src/gui.cpp 3dfb-0.6.1/src/gui.cpp
+--- 3dfb-0.6.1.orig/src/gui.cpp 2004-07-28 22:32:21.000000000 +0000
++++ 3dfb-0.6.1/src/gui.cpp 2006-09-18 21:35:01.271923722 +0000
+@@ -70,7 +70,7 @@
+
+
+ static fileMap fileMap;
+-static levelLocation levels[fileMap.maxLevels];
++static levelLocation levels[1024];
+
+
+
diff --git a/x11-misc/3dfb/files/3dfb-0.6.1-freeglut-compat.patch b/x11-misc/3dfb/files/3dfb-0.6.1-freeglut-compat.patch
new file mode 100644
index 000000000000..f05e3538120d
--- /dev/null
+++ b/x11-misc/3dfb/files/3dfb-0.6.1-freeglut-compat.patch
@@ -0,0 +1,10 @@
+--- src/main.cpp.bak 2014-03-13 12:24:32.155889466 +0400
++++ src/main.cpp 2014-03-13 12:24:42.482890090 +0400
+@@ -7,6 +7,7 @@
+
+ int main(int argc, char **argv)
+ {
++ glutInit(&argc, argv);
+ gui_init();
+ glutMainLoop();
+ return(0);
diff --git a/x11-misc/3dfb/metadata.xml b/x11-misc/3dfb/metadata.xml
new file mode 100644
index 000000000000..d0053fa8abcf
--- /dev/null
+++ b/x11-misc/3dfb/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-effects</herd>
+ <upstream>
+ <remote-id type="sourceforge">dz3d</remote-id>
+ </upstream>
+</pkgmetadata>