summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/alltray
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/alltray')
-rw-r--r--x11-misc/alltray/Manifest1
-rw-r--r--x11-misc/alltray/alltray-0.7.5.1.ebuild49
-rw-r--r--x11-misc/alltray/files/alltray-0.7.4-include-fixes.patch30
-rw-r--r--x11-misc/alltray/metadata.xml13
4 files changed, 93 insertions, 0 deletions
diff --git a/x11-misc/alltray/Manifest b/x11-misc/alltray/Manifest
new file mode 100644
index 000000000000..913b05b89cfc
--- /dev/null
+++ b/x11-misc/alltray/Manifest
@@ -0,0 +1 @@
+DIST alltray-0.7.5.1dev.tar.gz 481458 SHA256 09dad447b85ecb57debcb423f34381db7f112a010fbc83e4f65b3b31cf416514 SHA512 4cdba8a1a6d6969205387d985fda0cc479006ad009e3e35614569a5214d302b3852504c4d8ed0cf6557e202b941cc004033b4396a7b11e734a93317d70bc3efe WHIRLPOOL 6e9b65540b322a5f6902a204386cd80467b50f593dcb8933e34157e21f4c4f9c3e312e260f32c0fd31c592f9437f10bb754195ab0868592e24fbd941310117ae
diff --git a/x11-misc/alltray/alltray-0.7.5.1.ebuild b/x11-misc/alltray/alltray-0.7.5.1.ebuild
new file mode 100644
index 000000000000..83ad8c95c954
--- /dev/null
+++ b/x11-misc/alltray/alltray-0.7.5.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+VALA_MIN_API_VERSION="0.14"
+
+inherit autotools vala
+
+MY_P=${P}dev
+
+DESCRIPTION="An application which allows any application to be docked into the system notification area"
+HOMEPAGE="http://alltray.trausch.us/"
+SRC_URI="http://code.launchpad.net/${PN}/trunk/${PV}dev/+download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ gnome-base/libgtop:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libwnck:1"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( AUTHORS ChangeLog HACKING NEWS README )
+
+src_prepare() {
+ sed -i -e 's:-DG.*DISABLE_DEPRECATED::' src/Makefile.{am,in} || die #391101
+
+ sed -i \
+ -e '/Encoding/d' \
+ -e '/Categories/s:Application;::' \
+ -e '/Icon/s:.png::' \
+ data/alltray.desktop{,.in} || die
+
+ vala_src_prepare
+ sed -i -e '/AC_PATH_PROG/s:valac:${VALAC}:g' configure.ac || die
+
+ eautoreconf
+}
diff --git a/x11-misc/alltray/files/alltray-0.7.4-include-fixes.patch b/x11-misc/alltray/files/alltray-0.7.4-include-fixes.patch
new file mode 100644
index 000000000000..55814f5e70e5
--- /dev/null
+++ b/x11-misc/alltray/files/alltray-0.7.4-include-fixes.patch
@@ -0,0 +1,30 @@
+--- alltray/src/Application.c
++++ alltray/src/Application.c
+@@ -16,6 +16,7 @@
+ #include <gdk-pixbuf/gdk-pixdata.h>
+ #include <config.h>
+
++#include "gtop_glue.h"
+
+ #define ALL_TRAY_TYPE_APPLICATION (all_tray_application_get_type ())
+ #define ALL_TRAY_APPLICATION(obj) (G_TYPE_CHECK_INSTANCE_CAST ((obj), ALL_TRAY_TYPE_APPLICATION, AllTrayApplication))
+--- alltray/src/AttachHelper.c
++++ alltray/src/AttachHelper.c
+@@ -16,6 +16,7 @@
+ #include <string.h>
+ #include <gtk/gtk.h>
+
++#include "x11_glue.h"
+
+ #define ALL_TRAY_TYPE_ATTACH_HELPER (all_tray_attach_helper_get_type ())
+ #define ALL_TRAY_ATTACH_HELPER(obj) (G_TYPE_CHECK_INSTANCE_CAST ((obj), ALL_TRAY_TYPE_ATTACH_HELPER, AllTrayAttachHelper))
+--- alltray/src/Process.c
++++ alltray/src/Process.c
+@@ -16,6 +16,7 @@
+ #include <libwnck/libwnck.h>
+ #include <stdio.h>
+
++#include "gtop_glue.h"
+
+ #define ALL_TRAY_TYPE_PROCESS (all_tray_process_get_type ())
+ #define ALL_TRAY_PROCESS(obj) (G_TYPE_CHECK_INSTANCE_CAST ((obj), ALL_TRAY_TYPE_PROCESS, AllTrayProcess))
diff --git a/x11-misc/alltray/metadata.xml b/x11-misc/alltray/metadata.xml
new file mode 100644
index 000000000000..2e4a29de1851
--- /dev/null
+++ b/x11-misc/alltray/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+With AllTray you can dock any application into the system tray/notification
+area. A high-light feature is that a click on the "close" button will minimize
+to system tray. It is written in C using GTK and Xlib. It works well with Gnome,
+KDE and XFCE 4.2.
+ </longdescription>
+</pkgmetadata>