summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/bbcd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/bbcd')
-rw-r--r--x11-misc/bbcd/Manifest1
-rw-r--r--x11-misc/bbcd/bbcd-0.3.1-r1.ebuild30
-rw-r--r--x11-misc/bbcd/files/bbcd-0.3.1-gcc3.3.patch20
-rw-r--r--x11-misc/bbcd/files/bbcd-0.3.1-gcc4.3.patch11
-rw-r--r--x11-misc/bbcd/files/bbcd-0.3.1_0.3.1a.diff41
-rw-r--r--x11-misc/bbcd/metadata.xml8
6 files changed, 111 insertions, 0 deletions
diff --git a/x11-misc/bbcd/Manifest b/x11-misc/bbcd/Manifest
new file mode 100644
index 000000000000..157ac09505da
--- /dev/null
+++ b/x11-misc/bbcd/Manifest
@@ -0,0 +1 @@
+DIST bbcd-0.3.1.tar.gz 74853 SHA256 30a63b349d6eb6dd0018e5d76e8f1f97fdde60798f9dfec210662a47e65a8875
diff --git a/x11-misc/bbcd/bbcd-0.3.1-r1.ebuild b/x11-misc/bbcd/bbcd-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..13523fdf6036
--- /dev/null
+++ b/x11-misc/bbcd/bbcd-0.3.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Basic CD Player for blackbox wm"
+HOMEPAGE="http://tranber1.free.fr/bbcd.html"
+SRC_URI="http://tranber1.free.fr/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="media-libs/libcdaudio
+ x11-libs/libX11"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}_${PV}a.diff
+ epatch "${FILESDIR}"/${P}-gcc3.3.patch
+ epatch "${FILESDIR}"/${P}-gcc4.3.patch
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+ rm -rf "${D}"/usr/doc || die
+ dodoc AUTHORS BUGS ChangeLog NEWS README
+}
diff --git a/x11-misc/bbcd/files/bbcd-0.3.1-gcc3.3.patch b/x11-misc/bbcd/files/bbcd-0.3.1-gcc3.3.patch
new file mode 100644
index 000000000000..906dabf616ca
--- /dev/null
+++ b/x11-misc/bbcd/files/bbcd-0.3.1-gcc3.3.patch
@@ -0,0 +1,20 @@
+--- bbcd-0.3.1/Color.cc.org 2003-12-07 14:55:51.791299707 +0100
++++ bbcd-0.3.1/Color.cc 2003-12-07 14:56:07.724194970 +0100
+@@ -32,6 +32,7 @@
+ //#include <stdio.h>
+ //}
+ #include <iostream>
++#include <assert.h>
+
+
+ BColor::ColorCache BColor::colorcache;
+--- bbcd-0.3.1/Texture.cc.org 2003-12-07 14:55:57.382507797 +0100
++++ bbcd-0.3.1/Texture.cc 2003-12-07 14:56:41.924228114 +0100
+@@ -37,6 +37,7 @@
+ #include "Texture.hh"
+ //#include "BaseDisplay.hh"
+ #include "Image.hh"
++#include <assert.h>
+ //#include "Screen.hh"
+ //#include "blackbox.hh"
+
diff --git a/x11-misc/bbcd/files/bbcd-0.3.1-gcc4.3.patch b/x11-misc/bbcd/files/bbcd-0.3.1-gcc4.3.patch
new file mode 100644
index 000000000000..90c2d4ab8d8e
--- /dev/null
+++ b/x11-misc/bbcd/files/bbcd-0.3.1-gcc4.3.patch
@@ -0,0 +1,11 @@
+Add header to be compatible with gcc-4.3 and glibc-2.8.
+--- bbcd-0.3.1/Image.cc
++++ bbcd-0.3.1/Image.cc
+@@ -29,6 +29,7 @@
+ //# include <stdio.h>
+ //#endif // HAVE_STDIO_H
+ #include <iostream>
++#include <cstring>
+
+ #include <algorithm>
+ using std::max;
diff --git a/x11-misc/bbcd/files/bbcd-0.3.1_0.3.1a.diff b/x11-misc/bbcd/files/bbcd-0.3.1_0.3.1a.diff
new file mode 100644
index 000000000000..75db91941727
--- /dev/null
+++ b/x11-misc/bbcd/files/bbcd-0.3.1_0.3.1a.diff
@@ -0,0 +1,41 @@
+diff -urN bbcd-0.3.1/CD_Ctrl.cc bbcd-0.3.2/CD_Ctrl.cc
+--- bbcd-0.3.1/CD_Ctrl.cc Sun Jun 23 18:35:27 2002
++++ bbcd-0.3.2/CD_Ctrl.cc Mon Feb 3 09:29:00 2003
+@@ -116,7 +116,7 @@
+ cd_resume(getCdFd());
+ return di.disc_current_track;
+ }
+- if(di.disc_mode == CDAUDIO_COMPLETED) {
++ if(di.disc_mode == CDAUDIO_COMPLETED || di.disc_mode == CDAUDIO_NOSTATUS) {
+ cd_play(getCdFd(), di.disc_first_track);
+ return di.disc_first_track;
+ }
+Binary files bbcd-0.3.1/test_cd_ctrl and bbcd-0.3.2/test_cd_ctrl differ
+diff -urN bbcd-0.3.1/test_cd_ctrl.cc bbcd-0.3.2/test_cd_ctrl.cc
+--- bbcd-0.3.1/test_cd_ctrl.cc Thu Jun 27 22:52:36 2002
++++ bbcd-0.3.2/test_cd_ctrl.cc Mon Feb 3 09:19:42 2003
+@@ -88,10 +88,20 @@
+
+ CD_Controler cd(deviceName);
+ if(info) {
+- std::cout << "Drive status: \n";
+- std::cout << "Disc present ? " << (cd.isDiscPresent()?"yes":"no") << "\n";
+- std::cout << "Is drive playing ? " << (cd.isPlaying()?"yes":"no") << "\n"
+- << "Is drive paused ? " << (cd.isPaused()?"yes":"no") << "\n";
++ std::cout << "Drive status: \n"
++ << "Disc present? " << (cd.isDiscPresent()?"yes":"no") << "\n"
++ << "Is drive playing? " << (cd.isPlaying()?"yes":"no") << "\n"
++ << "Is drive paused? " << (cd.isPaused()?"yes":"no") << "\n"
++ << "Audio status: ";
++ switch(cd.getAudioStatus()) {
++ case CD_Controler::Invalid: std::cout<<"Invalid"; break;
++ case CD_Controler::Play: std::cout<<"Play"; break;
++ case CD_Controler::Paused: std::cout<<"Paused"; break;
++ case CD_Controler::Completed: std::cout<<"Completed"; break;
++ case CD_Controler::Error: std::cout<<"Error"; break;
++ case CD_Controler::NoStatus: std::cout<<"No Status"; break;
++ }
++ std::cout<<std::endl;
+ }
+
+ if(pause) {
diff --git a/x11-misc/bbcd/metadata.xml b/x11-misc/bbcd/metadata.xml
new file mode 100644
index 000000000000..36762631649d
--- /dev/null
+++ b/x11-misc/bbcd/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+ <longdescription>
+ Basic CD Player app for Blackbox.
+ </longdescription>
+</pkgmetadata>